Adobe InDesign CS5

Project 3 guide

Overview of Adobe InDesign CS5 workspace
In this guide, you’ll learn how to do the following:
•

Work with the InDesign workspace, tools, document windows, pasteboard, panels, and layers.

•

Customize the workspace.

•

Change the magnification of a document.

•

Navigate through a document by using the Pages panel and page controls in the document window.

Exploring the workspace
The InDesign workspace encompasses everything you see when you first open or create a document: the Tools panel,
document window, pasteboard, and other panels. You can customize and save the work area to suit your work style.
For example, you can choose to display only those panels you frequently use, minimize and rearrange panel groups,
resize windows, and add additional document windows.
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Figure 1 Adobe InDesign CS5 interface
The default workspace in InDesign (Figure 1) includes an Application bar at the top of the screen. Within this
Application bar are the InDesign application icon, main menu, application controls, View controls, and the workspace
switcher. Below this bar is the Control panel, the Tools panel on the left, panels on the right, and one or more
document windows, which are opened separately.
•

The main menu across the top organizes commands in menus.

•

The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related
tools are grouped together.

•

The Control panel displays control options for the currently selected tool.

© 2010 Adobe Systems Incorporated

Overview of Adobe InDesign CS5 workspace

1

Project 3 guide

Adobe InDesign CS5

•

Document windows display document pages for the files you’re currently working on. Each page or spread
in a document is surrounded by its own pasteboard, which can store objects for the document as you create
the layout.

•

Panels help you monitor and modify your work. You can reorganize, group, stack, or dock panels.

Customizing the workspace
By saving the current size and position of panels in your InDesign interface as a named workspace, you can restore
that workspace even if you move or close a panel. The names of saved workspaces appear in the workspace switcher.
To create a custom workspace:

1. Move and manipulate the interface layout in InDesign to
suit your needs (Figure 2).
2. From the workspace switcher menu, select New
Workspace (Figure 3).
The New Workspace dialog box appears (Figure 4).
3. Name your workspace and select the items to save in the
workspace: your placement of panels is saved if you
select the Panel Locations option; any keyboard shortcuts
and menus you customized are saved if you select the
Menu Customization option.
4. Click OK.
The name of your new workspace appears in the
workspace switcher.

Figure 2 Custom interface layout

Figure 3 Workspace switcher menu

Figure 4 New Workspace dialog box
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5. Choose Window > Workspace.
Notice that your new workspace now appears at the top
of the Workspace menu.
Even if you make changes, you can return to the
workspace you saved by selecting it from the menu or
from the workspace switcher (Figure 5).
You can restore the saved workspace at any time by
choosing Reset [your named] Workspace from the
workspace switcher menu.

Figure 5 Selecting a saved workspace

Opening a file in InDesign
In general, you open document and template files the same way you do in other programs. When you open an
InDesign template, it opens as a new, untitled document. Document files use the extension .indd, template files use
the extension .indt, library files use the extension .indl, and book files use the extension .indb.
You can also use the File > Open command to open files from InDesign 1.x and later (including Asian-language
versions), InDesign Interchange (.inx) files, Adobe PageMaker 6.0 and later, QuarkXPress 3.3 and 4.1, and
QuarkXPress Passport 4.1. In addition, other software vendors may make plug-in software with which you can open
other file formats.
To open an existing file:

1. Start InDesign.
The Welcome screen appears (Figure 6). If you do not
see the welcome screen, choose Help > Welcome Screen.
This screen allows you to easily access:
•

Recent items

•

New documents

•

Learning materials for getting started, understanding
new features, and resources

•

Web links to the InDesign community

2. To open an existing InDesign document, click Open
under Open A Recent Item, browse to the location of
your file, and click Open.

Figure 6 InDesign Welcome screen

3. You can also select File > Open from the main menu.
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Tools panel overview
Some tools in the Tools panel (Figure 7) are for selecting, editing, and creating page elements. Other tools are for
choosing types, shapes, lines, and gradients. You can change the overall layout of the Tools panel to fit your preferred
window and panel layout.
Click a tool to select it from the default Tools panel. The Tools panel also contains several hidden tools related to the
visible tools. Hidden tools are indicated by arrows to the right of the tool icons. Select a hidden tool by clicking and
holding the current tool in the Tools panel and then selecting the tool you want.
The name of the tool and its keyboard shortcut appear when you hold the pointer over the tool—this text is called a
tool tip. You can turn off tool tips by choosing None from the Tool Tips menu in General preferences (Windows) or
Interface Preferences (Mac OS).

Figure 7 Overview of the Tools panel
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The Zoom tool

You can use the Zoom tool to change the magnification level in your document.
To use the Zoom tool to change the magnification:

1. Open a multipage document, examine the filename at the
top of the document window, and notice the percentage
listed at the end of the filename (Figure 8).
This represents the current enlargement view of the page,
or zoom level.
2. Move the pointer over the Tools panel and hover over the
magnifying-glass icon until a tool tip appears, identifying
the tool by name and providing its keyboard shortcut
(Figure 9).
3. Select the Zoom tool by clicking the Zoom tool button in
the Tools panel or by pressing Z, the keyboard shortcut
for the Zoom tool.

Figure 8 Document window with zoom level

4. Click anywhere in the document window.
The document zooms in according to a preset percentage
level, which replaces the previous value in the document
window. The location you clicked when you used the
Zoom tool becomes the center of the enlarged view.
5. Using the Zoom tool, drag a rectangle to enclose a region
of the document (Figure 10).
The selection enlarges to fill the entire document
window.

Figure 9 Tool tip

Figure 10 Selecting a rectangular region
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6. To zoom out, Alt-click (Windows) or Option-click (Mac
OS) (Figure 11).

Figure 11 Zooming out in a document
The Hand tool

The Hand tool moves a document within the document window. This is useful if you want to see a part of the
document that is currently out of view.
To scroll around the document with the Hand tool:

1. Zoom into an area of your document until part of the
page is out of view (Figure 12).
2. Select the Hand tool from the Tools panel (Figure 13).

Figure 12 Document window with scroll bars

Figure 13 Hand tool
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3. Using the Hand tool, drag to scroll around and view
different parts of the document (Figure 14).

Figure 14 Using the Hand tool to move around a
document
How to select an object and work with the Control panel

The Control panel (Window > Control) offers quick access to options, commands, and other panels related to the
current page item or objects you select (this is called contextual). By default, the Control panel is docked to the top of
the document window; however, you can dock it to the bottom of the window, convert it to a floating panel, or hide it
altogether
To use the Selection tool and Control panel:

1. With a document open, choose the Selection tool from
the Tools panel and then select an object in your
document.
Notice that the Control panel information reflects such
things as the position, size, and rotation of that object
(Figure 15).
2. Next, choose the Type tool and select a region of text.
The Control panel changes to show options that provide
control over text formatting (Figure 16).
Figure 15 Control panel with image selected

Figure 16 Control panel with text selected
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Navigating through the pages in your document

You can turn pages by using the Pages panel, the page buttons at the bottom of the document window, the scroll bars,
or a variety of other commands.
To navigate through a document:

1. You can move from one page to another by using the
arrow controls in the lower left corner of the document
window (Figure 17). Click the forward arrow to go to the
next page and the back arrow to go to the previous page.
An arrow control is dimmed if there is no page to go to. A
pop-up menu also allows you to navigate by page
number.
2. A second way to navigate your document is by using the
Pages panel (Figure 18). This panel lists document
layout templates in the top section and actual pages in the
lower section. To choose a page in your document,
double-click the page icon in the lower section.

Figure 17 Using the controls at the lower left of the
document window

The document window displays the selected page.
3. You can also go directly to a particular page by choosing
Layout > Go To Page and then entering the page number
(Figure 19).

Figure 18 Using the Pages panel to navigate

Figure 19 Using a menu command to navigate
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Working with layers
Each document includes at least one named layer. By using multiple layers, you can create and edit specific areas or
kinds of content in your document without affecting other areas or kinds of content. For example, if your document
prints slowly because it contains many large graphics, you can use one layer for just the text in your document; then,
when it’s time to proofread the text, you can hide all other layers and quickly print the text layer only. You can also
use layers to display alternate design ideas for the same layout, or versions of advertisements for different regions.
Think of layers as transparent sheets stacked on top of each other. If a layer doesn’t have objects on it, you can see
through it to any objects on layers behind it.
You can draw objects in a document and use them as paths or as frames. Paths are vector graphics like those you
create in a drawing program such as Adobe Illustrator. Frames are identical to paths, with only one difference—they
can be containers for text or other objects. A frame can also exist as a placeholder—a container without contents. As
containers and placeholders, frames are the basic building blocks for a document’s layout.
To create layers and work with objects:

1. Choose Window > Layers.
The Layers panel opens (Figure 20). Notice there is an
existing layer labeled Layer 1. You will use this layer as
the background.
2. Double-click Layer 1 in the Layers panel.
The Layer Options dialog box opens (Figure 21).
3. Specify the layer options in the Layer Options dialog
box, and then click OK.
Color Assigns a color to identify the objects on that layer.

New Layer button

Figure 20 Layers panel

Show Layer Makes a layer visible. Selecting this option is
the same as making the eye icon visible in the Layers
panel.
Show Guides Makes the guides on the layer visible.
When this option is not selected for a layer, the guides
cannot be made visible, even by selecting View > Show
Guides for the document.
Lock Layer Prevents changes to any objects on the layer.
Selecting this option is the same as making the crossedout pencil icon visible in the Layers panel.

Figure 21 Layer Options dialog box

Lock Guides Prevents changes to all ruler guides on the
layer.
Print Layer Allows the layer to be prevented from
printing. When printing or exporting to PDF, you can
determine whether to print hidden and nonprinting layers.
Suppress Text Wrap When Layer Is Hidden Makes text on
other layers flow normally when the layer is hidden and it
contains objects with text wrap applied.
4. In the Tools panel, select the Rectangle tool.
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5. Drag in the document window to create the background
shape in the document (Figure 22).
6. Double-click the Fill box in the Tools panel (Figure 23).
The color Color Picker opens (Figure 24).
When chosen, Fill displays the selected color.
7. Click OK.
8. Create a new layer by clicking the New Layer button in
the Layers panel.
This is Layer 2, into which you will import a graphic.
9. In the Tools panel, select the Rectangle Frame tool.
10. Drag in the document window to create the foreground
frame in the document into which you want to place a
graphic (Figure 26). Make sure the shape is the proper
orientation to fit the image, but don’t worry abou the
exact size because you can fix that later.

Figure 22 Dragging the Rectangle Tool in the
document window

Fill

Stroke
Apply Color

Figure 23 Fill and Stroke tools in the Tools panel

Figure 24 Color Picker

Figure 25 Creating a graphics frame
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11. Choose File > Place.
The Place dialog box opens (Figure 26).
12. Select a graphics file.
13. Click Open.
14. The pointer changes to a Loaded Graphics icon, with a
thumbnail of the image. Click inside the selected frame to
place the image.
The image is placed inside the document in the layer.
15. Select Object > Fitting.
There are several options for fitting the content to the
frame or the frame to the content (Figure 27).
If the new image is smaller or larger than the frame, you
can refit the frame by choosing Object > Fitting > Fit
Frame To Content.

Figure 26 Place dialog box

The frame is fit to the placed object (Figure 28).
16. In the Layers panel, click on a layer’s disclosure triangle
to reveal the objects and their stacking order on that
given layer for the active spread (Figure 29).
You can change the stacking order of objects by dragging
items up or down in the list. In the Layers panel you can
also show or hide and lock or unlock individual page
items.

Figure 27 Object fitting options

Figure 28 Object placed with a frame

Figure 29 Layers panel with expanded layer
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How to set up a document
When working in Adobe InDesign CS5, your first step is to create a new document. When creating a new document,
you set dimensions, margins, and other characteristics for the document.
This guide explains how to create a new document with the dimensions of a business card.

Creating a new document
In the following steps, you first change preferences so you view document dimensions in inches, and then create a
new document. By default, InDesign measures documents in picas. Picas are a standard print measurement unit; there
are 72 picas to an inch. As you advance in layout design, you may find it useful to work in picas. To start, though, it
will be easier to think in terms of inches.
To create a new document:

1. Start InDesign and choose Edit > Preferences > Units &
Increments (Windows) or InDesign > Preferences > Units
& Increments (Mac OS).
The Preferences dialog box appears with the Units &
Increments section selected (Figure 1).
2. Select Inches in the Horizontal and Vertical pop-up
menus.
This sets the document’s horizontal and vertical unit of
measurement to inches.
Note: If you are used to working with points and picas,
keep the measurements at their default.
3. Leave other settings unchanged, and click OK to close
the Preferences dialog box.
4. Choose File > New > Document.

Figure 1 Units & Increments section of the
Preferences dialog box

The New Document dialog box appears (Figure 2).
Because you changed ruler units to inches, the Page Size,
Margins, and the other document dimensions appear in
inches.
5. Deselect Facing Pages.
Because this document is only one page, you do not need
facing pages.
In a facing page spread, pages sit opposite one another.
Books and magazines usually have facing pages.
When you select the Facing Page option, InDesign treats
the two pages as one spread, and you can work on laying
out both pages at once.
6. In the Width box, type 3.5. In the Height box, type 2.

Figure 2 New Document dialog box

These are the standard dimensions for a business card in
the United States.
For other documents, of course, you would enter different
settings. For example, a standard page in the United
States is 8.5 inches by 11 inches.
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7. Leave Columns set to 1.
If this were a document with multiple columns of text,
you could set multiple columns here.
8. In the Margins section, make sure the Make All Settings
The Same icon (the chain link) is selected.
This setting tells InDesign to set all margins to the same
value.
You will often want to set margins the same to give
documents a uniform appearance. If you want to set
different margins for top, bottom, left, and right, leave the
Make All Settings The Same icon deselected and enter
widths for each margin.

Figure 3 New InDesign document

9. Type .25 in the Top box and press the Tab key.
All margins change to .25 inches.
10. Click OK.
The new document opens in InDesign (Figure 3).
Observe that the margins are marked by a margin guide.
Also observe that the rulers along the left and across the
top are marked in inches.

Using multiple page sizes
You can define different page sizes for pages within a single document. This feature is especially useful when you
want to manage related designs in one file. For example, you can include business card, letterhead, and envelope
pages in the same document (Figure 4).

Business card

Letterhead

Envelope

Figure 4 Multiple page sizes in same docuement
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To create different page sizes within a document:

Use the Page panel to select the master page or layout page you want to resize, and then modify the page settings.
1. Choose File > New > Document.
The New Document dialog box appears (Figure 5). The
New Document dialog box combines the Document
Setup and the Margins And Columns dialog boxes, so
that you can set up the page size, margins, and page
columns all in one place.
2. Confirm the Page Size is set to Letter, and specify other
document setup options. For example, enter 3 in the
Number Of Pages text box as this project needs a
document with three pages. Leave the other settings as
they are for now. You can change these settings later to
define the custom page sizes.
3. Deselect the Facing Pages option to let each page stand
alone.
4. Click OK to open a new document with the settings you
specified.

Number Of Pages text box

Facing Pages option

Figure 5 New Document dialog box

5. If the Pages panel isn’t visible, choose Window > Pages.
6. In the document, select the first page by clicking it.
Observe that page 1 is selected in the Pages panel
(Figure 6).
7. Click the Edit Page Size button in the Pages panel, and
select US Business Card.
The page size is altered to 3.5 inches by 2 inches.
Edit Page Size button

8. Next modify the default margins for the business card.
Choose Layout > Margins And Columns.
The Margins and Columns dialog box opens (Figure 7).

Figure 6 Pages panel

9. Type .25 in the Top box and press the Tab key.
All margins change to .25 inches.
10. Click OK to accept the new margin settings.
11. In the Pages panel, double-click on the third page.
Observe that page 3 is also selected in the document.

Figure 7 Margins And Columns dialog box
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12. Click the Edit Page Size button and select Custom Page
Size.
The Custom Page Size dialog box opens (Figure 8).
13. In the Width box, type 9.5. In the Height box, type 4.125.
These are the standard dimensions for a #10 commercial
envelope in the United States.
14. Click OK.
The three-page layout is ready for use (Figure 9).
Figure 8 Custom Page Size dialog box

Figure 9 InDesign layout using multiple page sizes
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How to use master pages
When you start creating multi-page documents, keeping their appearance uniform from page to page can be difficult.
If your pages are uniform, you not only produce a clean design but you also help readers navigate through your
document because they know what to expect on each page.
Like other layout programs, Adobe InDesign CS5 provides a master page feature with which you can set common
characteristics for each page, such as headings, footers, page numbers, and number of columns. Master pages
maintain these common characteristics in one place (Figure 1). This means you can create new pages that are
consistent with previous pages and also change common characteristics instantly by making changes to the master
page.
With careful planning, master pages (or “masters”) offer a quick way to make layout changes to multiple document
pages. With very long documents, such as yearbooks, you can even create multiple masters for different types of
pages, such as club pages, candid pages, and student pages.

Figure 1 Master page linked to three pages
This guide covers the following topics:
•

Creating master pages

•

Creating new pages based on masters

•

Modifying master pages

•

Applying master pages
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Using the Pages panel
You manage master pages through the Pages panel (Figure 2). The Pages panel displays thumbnails of all pages in
the document, along with the master pages applied to them.

Pages panel menu

Masters currently
used in document
Thumbnails of masters

Indicates master
applied to page

Page spreads in document

Figure 2 Pages panel

Creating master pages
You can create a new master from scratch or from an existing page or spread.
To create a new master page from scratch:

1. Open a file in InDesign.
2. Choose Window > Pages to display the Pages panel.
3. Choose New Master in the Pages panel menu.
The New Master dialog box appears (Figure 3).
By default, InDesign assigns a letter in sequence as a
prefix for the master page. For example, if you have
master pages with prefixes “A” and “B,” InDesign adds
“C” to the next master you create.

Figure 3 New Master dialog box

4. You can also type a different prefix in the Prefix text box,
using as many as four characters.
5. Enter a name for the master in the Name text box.
6. You can choose to base this master on an existing master
page. In the example (Figure 2), CGC and CG are
available as bases.

2

How to use master pages

© 2010 Adobe Systems Incorporated

Adobe InDesign CS5

Project 8 guide

7. Number Of Pages refers to the number of pages in a
spread. For most documents, you will set up 2-page
spreads, but you can enter up to 10 pages here.
Note: To add multiple two-page spreads based on a
single master, simply add multiple instances of the same
master. If you enter 10 in the Number Of Pages text box,
you will not produce five 2-page spreads; instead, you
will produce one 10-page spread.
8. Click OK.
The New Master dialog box closes and the new master
appears in the Pages panel (Figure 4).

Figure 4 New Master in Pages panel

To create a master based on an existing spread:

You may have already created a layout spread and wish to convert it to a master.
1. Choose Window > Pages to display the Pages panel.
2. Do either of the following:
•

Drag an entire spread from the Pages section of the
Pages panel to the Masters section (Figure 5).

•

Select a spread in the Pages panel and choose Save
As Master from the Pages panel menu.

Any objects on the original page or spread become part
of the new master.
Note: If you based the original page on a master, the new
master is based on the original page’s master.

Pages section
Figure 5 A spread in the Pages panel

Creating new pages based on masters
When you add new pages in InDesign, they are automatically linked to the current document’s master.
You can also create pages based on a different master by using the Pages panel.

© 2010 Adobe Systems Incorporated
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To create a page based on a master:

1. If the Pages panel is not already visible, choose Window
> Pages to display it.
2. Drag one of the master pages from the top of the panel
into the lower part of the panel, dragging it to the left or
right of a spread (Figure 6).
If you drag the master on top of an existing page, the
master is applied to the page instead of creating a new
page.
3. Release the mouse button.
A new, empty page is added after the current page
(Figure 7).
Figure 6 Dragging to create a new page

Figure 7 New page added
To apply a master page to an existing page:

1. If the Pages panel is not already visible, choose Window
> Pages to display it.
2. Drag one of the master pages from the top of the panel
into the lower part of the panel, dragging it on top of a
current page.
3. Release the mouse button.
The new master is applied to the page. In Figure 8, this is
indicated by the letters CG in the page’s thumbnail.

Figure 8 Master page applied
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How to use the ruler, grid, guides, and the Align panel
Much of your job as a page designer is to place text and graphics on the page in a pleasing, organized way. Although
you can do much of this placing by “eyeballing it”—using your judgment to position text and graphics—Adobe
InDesign CS5 provides a number of tools to help you position objects in exact locations.
Note: You may have encountered the grid and guides (and even a version of the Align panel) in Adobe Photoshop
CS5, Adobe Illustrator CS5, or Adobe Flash CS5. If so, you will find that the grid and guides in InDesign differ
slightly from those in the other programs. For example, InDesign automatically adds guides in default locations,
whereas in Photoshop CS5 you generally need to add guides by hand.
This document covers four tools to help you position objects:
•

Rulers

•

Guides

•

Grids

•

The Align panel

Using rulers
Rulers can be useful in figuring general placement. For example, if you want to place a logo 1 inch inside the edge of
a business card, you can use the ruler to do so.
Rulers appear at the top and left edges of the workspace. (If you don’t see them, select View > Show Rulers). By
default, the zero point of these rulers is at the top-left corner of your page, but you can change this zero point.
By default, rulers measure in picas. Pica is a print term—one pica equals 12 points, in the sense of a 12 point font.
You can change the unit of measurement for the rulers to inches. When you do, all tabs, margins, indents, and other
measurements appear in inches.
Rulers work well with ruler guides. You can place ruler guides at specific horizontal or vertical measurement points.

Using guides
Guides are thin lines that aid with object placement. By default, InDesign adds two types of guides to your
documents: margin guides and column guides. Margin guides indicate where margins begin; column guides indicate
where columns fall. Ruler guides are similar to the guides in Photoshop CS5 and other Adobe tools. You can place
ruler guides anywhere on the page and relocate them as you desire. You can also snap objects to guides. With
snapping turned on, objects automatically click into place as you move them close to a guide. Guides can be very
useful for lining up objects on a page.
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To add a guide:

1. Start InDesign and create a new document.
2. Make sure the rulers are visible. If the rulers are not
visible, choose View > Show Rulers.
3. Drag from the horizontal ruler down into the document to
create a guide (Figure 1).
As you drag, the guide appears as a thin line (colored
blue by default).
As you drag, you can see the guide’s position on the
vertical ruler. The vertical coordinate is also displayed
beside the pointer. This can help you position the guide.
4. When you reach the 1-inch mark on the vertical ruler,
release the mouse to drop the guide.

Figure 1 Dragging a guide

The guide is now available for your use.
To snap objects to guides:

1. Choose View > Grids & Guides and confirm that Snap
To Guides is selected.
2. Select the Rectangle tool in the Tools panel (Figure 2).

Selection tool

3. Drag in the document to draw a small rectangle.
4. Select the Selection tool in the Tools panel (Figure 2).
5. Click the edge of the rectangle you drew and drag it close
to a guide.
As you do, you should feel the rectangle jump to align
with the guide (Figure 3). This is the effect of Snap To
Guides.
Note: As you move a shape, the X and Y coordinate
tooltip hints appear to help to best align the shape to the
page.

Rectangle tool

Figure 2 Tools panel

Figure 3 Object snapped to a guide

2

How to use the ruler, grid, guides, and the Align panel

© 2010 Adobe Systems Incorporated

Adobe InDesign CS5

Project 3 guide

Using the grid
A grid is a series of thin horizontal and vertical lines that overlay your entire page. Before desktop publishing tools,
layout editors arranged copy and images on sheets of paper with such grids.
In InDesign, you can choose from two kinds of grids: a baseline grid for aligning columns of text and a document
grid for aligning objects. On the screen, a baseline grid resembles ruled notebook paper and a document grid
resembles graph paper. You can customize both kinds of grids.
Using the baseline grid

A baseline grid is useful for making sure your text lines up across columns. The baseline is the lower edge of text—
the point of the lowest segment of letters except those that extend below the baseline, such as g and y.
To display a baseline grid, choose View > Grids & Guides > Show Baseline Grid.
The idea is to keep the baselines of all text—both headings and body text—on the same increment, as in Figure 4.
A good idea is to set leading—the space between text lines—at the same increment as the baseline grid. For example,
if you set the baseline grid to 14 points, you should also set leading to 14 points. This ensures that text lines align with
the baseline grid, as in Figure 4.
Keeping everything on the same baseline grid gives the page a clean, uniform appearance.

Figure 4 Baseline grid
Using the document grid

The document grid is useful for aligning objects—not just text—across your document. You can use the document
grid to make sure an image is at the same height as a heading, for example. Many designers find it useful to think of
layout in terms of grids, with everything on the page placed on a grid. The document grid helps you align page
objects with each other both vertically and horizontally.
In InDesign, you can customize both the baseline grid and the document grid in terms of spacing, line thickness, and
color. You may find spacing helpful, especially if you know you’re arranging your page in, for example, half-inch
increments. Line thickness and color are a matter of preference—they’re part of customizing your work environment.
The grid does not appear in anything you print or publish; it’s for working purposes only. You can also snap objects to
the grid. With snapping turned on, objects automatically click into place as you move them close to gridlines.
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To use the document grid:

1. Choose Edit > Preferences > Grids (Windows) or
InDesign > Preferences > Grids (Mac OS).
The Preferences dialog box appears, with the Grids
section selected (Figure 5).
2. Deselect the Grids In Back option at the bottom of the
dialog box.
This lets you see the grid over your document.
Under Document Grid, observe the settings for
Horizontal and Vertical. By default, these should be set to
the following:
•

Gridline Every: 1 in.

•

Subdivisions: 8

This means a major gridline appears every 1 inch, with
this major grid subdivided 8 times, at 1/8-inch
increments.
Depending on the scale of your document, you might find
it useful to increase the size of these settings.

Grids In Back option

Figure 5 Grids section of the Preferences dialog
box

3. Click OK.
The Preferences dialog box closes.
4. Choose View > Grids & Guides > Show Document Grid.
The document grid appears over your document
(Figure 6).
You can now position objects in the document along this
grid. Of course, once you position your objects, you may
want to hide the document grid to see your work better.
Figure 6 Document grid applied
Snapping objects to the grid

You can make the grid even more useful by setting objects to snap to the grid. With Snap To Document Grid turned
on, objects are automatically positioned along grid lines.
To snap objects to the grid:

1. Choose View > Grids & Guides > Snap To Document
Grid.
2. Select the Rectangle tool in the Tools panel.
3. Drag in the document to draw a small rectangle.
4. Select the Selection tool in the Tools panel.
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5. Click the edge of the rectangle you drew and drag it
somewhere else in the document.
As you do, the rectangle clings to the grid (Figure 7).
This is the effect of Snap To Document Grid.
X and Y coordinate tooltip hints are available to help you
position the shape on the page.

Figure 7 Object snapped to grid

Using the Align panel
The Align panel (Figure 8) offers a series of tools for arranging objects in relation to each other, to the page, to the
page’s margins, and to multipage spreads.
For example, by using the Align panel, you can locate a text box in the exact horizontal center of a page or align it
with the left margin. You can even select three text boxes and distribute them evenly across the left margin. Again,
you could do some of this by hand, but the Align panel can save you lots of time.

Alignment Location pop-up menu

Figure 8 Align panel
The Align panel has two sets of options:
Align Objects: Arrange objects along a vertical or horizontal line.
Distribute Objects: Even out the spaces between a series of objects.
For each of these, you can choose one of four Alignment Location options:
•

Align to selection

•

Align to page

•

Align to margins

•

Align to spread

The following table describes how Align Objects and Distribute Objects work with these four options.
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Align to selection

Align to page

Align to margins

Align to spread

Align Objects

Rearranges objects
along left edge, right
edge, top edge, bottom edge, vertical center, or horizontal
center.

Rearranges objects in
relation to page’s left
edge, vertical center,
and so on.

Rearranges objects in
relation to page’s left
margin, right margin,
top margin, or bottom
margin, or centers them
between the margins.

Rearranges objects in
relation to the entire
pagespread’s left edge,
right edge, top edge, or
bottom edge or in the
center of the spread.

Distribute
Objects

Distributes three or
more selections
according to left edge,
right edge, top edge,
bottom edge, vertical
center, or horizontal
center. Edges are
determined by the
bounding box enclosing each selected
object.

Distributes three or
more selections
according to left edge,
right edge, top edge,
bottom edge, vertical
center, or horizontal
center across the entire
height (vertical) or
width (horizontal) of
the page.

Distributes three or
more selections according to left edge, right
edge, top edge, bottom
edge, vertical center, or
horizontal center across
the entire height (vertical) or width (horizontal) between the
margins.

Distributes three or
more selections
according to left edge,
right edge, top edge,
bottom edge, vertical
center, or horizontal
center across the entire
height (vertical) or
width (horizontal)
across the spread.

The Align panel helps you quickly create uniform, orderly arrangements of frames and shapes. For example, the
frames in Figure 9 are haphazardly arranged. You can use the Align panel to arrange them in an orderly, organized
manner.
To use the Align panel:

1. Select the Rectangular Frame tool in the Tools panel.
2. Drag in the document to create a small rectangular frame.
3. With the frame still selected, choose Edit > Duplicate.
Repeat to create several rectangular frames of identical
size.
4. With the Selection tool, drag each frame and arrange the
frames so they do not overlap each other .
5. Drag with the Selection tool until you have selected
multiple objects (Figure 9).

Figure 9 Unaligned frames
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6. Choose Window > Object & Layout > Align to display
the Align panel (Figure 10).
7. To align the left edges of the frames, select Align To
Selection and then Align Left Edges (Figure 11).
This command aligns the selected objects by their left
edges. You can also choose to align objects with the left,
right, or center of the page or to the left, right, or center
between the margins.
8. To distribute the frames equally, select Align To
Selection and then Distribute Vertical Centers.
Observe that the spaces between pairs of frames are equal
(Figure 12).

Figure 10 Align panel

Figure 11 Left edges aligned

Figure 12 Frames distributed
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How to place images on a page
To add images to an Adobe InDesign CS5 page, you need to place them on the page within a graphics frame.
InDesign supports most major image formats. Commonly used formats include TIFF, BMP, JPEG, PDF, PSD, and AI.
You can place any of these formats on a page.
You can resize an image and its graphics frame independently. This gives you a wide degree of control over how your
image appears on the page.
When you place images on a page, you are actually placing a link from the page to the graphics file. When the page is
printed, InDesign prints the image on the page according to your specifications.

Placing images on a page without first creating a graphics frame
You use the Place command to put images and other objects on a page. You can put images and other objects on a
page either within a frame or without first creating a frame. You may find it more precise to first create a graphics
frame and then place the image within the frame. If you place an image on a page without first creating a frame,
InDesign automatically creates a graphics frame around the image.
To place an image on the page without a graphics frame:

1. Create a new document in InDesign.
2. Choose File > Place.
The Place dialog box appears (Figure 1).
3. Browse to the location of the file you want to place.
4. Make sure the Show Import Options and Replace
Selected Item options are deselected.
You can use the Show Import Options option to manage
advanced options for placed images. This option
becomes more important when you place image formats
such as Adobe Photoshop and Adobe Illustrator files.
When you select the Replace Selected Item option,
InDesign replaces whatever content is in the currently
selected frame with your new image.
5. Make sure the Preview option is selected (Windows).
A thumbnail of the image appears in the lower-right
corner of the Place dialog box (Windows).
6. Select the file and click Open.

Replace Selected Item option

Preview option

Figure 1 Place dialog box

The Place dialog box closes and the pointer changes to a
Loaded Graphics icon, with a thumbnail of the image.
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7. Click the page where you want to place the image.
The image is inserted into the page, at its current size
(Figure 2). The image may overlap margins.
To minimize RAM use, InDesign displays images at a
minimal quality by default.
8. To display the image at full quality, choose View >
Display Performance > High Quality Display.
The image’s quality changes.
Note: This setting does not change how the image
appears when printed.
9. Click the Selection tool in the Tools panel.
10. Click the image.

Figure 2 Image placed on page

Observe that selection handles appear around the image,
indicating that the image is in a graphics frame.
11. Choose Object > Select > Content.
This command selects the image inside the graphics
frame.
12. Press the Delete key.
The image is deleted and the graphics frame sized to fit
the image remains (Figure 3).

Figure 3 Empty graphics frame

Placing images into graphics frames
Generally, you will want to create a graphics frame before placing an image. This gives you more control over the
location of the image than when you place an image without first creating a frame.
To place an image into a graphics frame:

1. Select the Rectangle Frame tool in the Tools panel
(Figure 4).
2. Drag it across the page to create a graphics frame.

Rectangular Frame tool

The frame is selected when you finish drawing it.
Observe the selection handles at its edges.
3. Choose File > Place.

Figure 4 Tools panel

The Place dialog box appears (Figure 1).
4. Browse to the location of the file you want to place.
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5. Make sure the Show Import Options option is deselected.
The Show Import Options option lets you manage
advanced options for placed images. This option
becomes more important when you place image formats
such as Adobe Photoshop and Adobe Illustrator files.
6. Select the Preview option (Windows), and select the
Replace Selected Item option.
When the Preview option is selected, a thumbnail of the
image appears in the lower-right corner of the Place
dialog box (Windows).
When you select the Replace Selected Item option,
InDesign replaces whatever content is in the currently
selected frame with your new image.

Figure 5 Portion of image in frame

7. Select the file and click Open.
The image is added to the graphics frame.
If the image is larger than the frame, only a portion of the
image appears (Figure 5).
8. Select Object > Fitting.
This menu provides several options for fitting the content
to the frame or the frame to the content (Figure 6).

Figure 6 Object fitting options

If the new image is smaller or larger than the frame, you
can refit the frame by choosing Object > Fitting > Fit
Frame To Content.
The frame is fit to the placed object (Figure 7).

Figure 7 Image fitted to frame
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How to transform objects
You can modify an object’s size or shape and change its orientation on the pasteboard by using the Free Transform
tool.

Using the Free Transform tool
The Free Transform tool works the same way in Adobe InDesign CS5 that it does in Adobe Photoshop CS5 and
Adobe Illustrator CS5, by providing a way to perform any transformation with just one tool. You can combine
transformations, such as scale, rotate, reflect, and shear, when the Free Transform tool is active.
To use the Free Transform tool:

1. Start InDesign and open a document.
2. Select the Free Transform tool from the transformation
tools in the Tools panel (Figure 1).
3. Select a text or graphic frame by clicking on it.
A bounding box appears around the edge of the frame,
with handles on the sides and corners (Figure 2).
Figure 1 Transformation tools

Handles

Figure 2 Frame selected with Free Transform tool
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4. Drag one of the handles to scale the frame (Figure 3).
5. Release the mouse button to apply the scale (Figure 4).
6. Move the pointer just outside one of the corner handles.
Note: Because you are using the Free Transform tool,
rotation, reflection, and shear are all immediately
available here.
The pointer turns into a rotation icon (Figure 5).

Figure 3 Dragging to scale frame

Figure 4 Scale result

Figure 5 Rotation icon
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7. Drag the pointer clockwise or counterclockwise.
The frame rotates with an angle indicator showing the
number of degrees the image has rotated (Figure 6).
8. Release the mouse button to apply the rotation
(Figure 7).
9. Drag one of the handles to the opposite side of the shape
(Figure 8).

Figure 6 Rotating image

Figure 7 Rotation result

Figure 8 Dragging to reflect
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10. Release the mouse button to apply the reflection
(Figure 9).
11. To shear objects, begin dragging a handle, and then hold
down Ctrl (Windows) or Command (Mac OS)
(Figure 10). Hold down Alt+Ctrl (Windows) or
Command+Option to shear from both sides of the object.
12. Release the mouse button to apply the shear (Figure 11).

Figure 9 Reflection result

Figure 10 Applying a shear

Figure 11 Shear result
Using the Transform Again command

1. Apply one of the transformations described in the
previous section.
2. Choose the Selection tool in the Tools panel (Figure 12).

Selection tool

3. Select another object.
4. Choose Object > Transform Again > Transform Again.
The transformation you applied to the first object has also
been applied to the second object.
Figure 12 Tools panel
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How to use text
Because Adobe InDesign CS5 is a page layout tool, working with text is an important skill. With InDesign, you add
all text (and all content) into frames. Frames are shapes (called paths) that hold content on a page. You can’t add text
without adding a text frame, and that’s a good thing, because frames offer you a wide range of possibilities for
formatting and positioning text and for controlling text flow—how text continues from frame to frame.
In this guide, you’ll learn to add text frames and to apply basic formatting—such as font family, font size, and text
color—and advanced text formatting—such as leading, kerning, tracking, and shifting the baseline. Advanced text
composition options give you greater control over how paragraphs appear in the final document.

Adding a text frame
In InDesign, you place all text within text frames. The easiest way to create a text frame is with the Type tool.
Note: You can also create text frames with the frame tools. Using the Ellipse Frame tool and Polygon Frame tool, you
can create text frames that are nonrectangular, such as a circle, hexagon, or star.
To create a text frame with the Type tool:

1. Start InDesign and create a new document.
2. Select the Type tool in the Tools panel (Figure 1).
The pointer changes to the Type tool pointer (a text
insertion icon bordered by a dotted line).
3. Drag the Type tool across the page to create a Text frame
(Figure 2).

Selection tool

Type tool

To help you position the frame, you may find it useful to
show the Document grid (View > Grids & Guides >
Show Document Grid).
As you drag, a blue box appears (Figure 2), with an
indicator for width and height.

Figure 1 Tools panel

4. Release the mouse to create the text frame.
Observe that a blinking text-insertion point appears in the
text frame.
5. Type some text, such as your name.
The text appears in whatever font family, font size, and
other text settings were previously set in the Type Control
panel.

Figure 2 Dragging to create a text frame
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6. Without moving the insertion point, click the Selection
tool at the top of the Tools panel (Figure 3).
Frame handles appear at the edges of the text frame
(Figure 2). You can use these handles to resize the text
frame.
You can recognize text frames by the text ports—empty
squares that are larger than frame handles—on their left
and right sides. You use text ports to make connections
between text frames.

Text port

Frame handle

Figure 3 Frame handles on text frame

Formatting text
In layout, the appearance of text is an art in itself. Although much of your text’s impact will derive from its
typography (the font you choose for your text), you can fine-tune its appearance by adjusting a number of additional
factors. Such fine-tuning is especially important for titles and other large-set text, because you want this text to stand
out to create interest, and readers will notice subtle adjustments to large-set text more than to text set in smaller sizes.
You format text by using the Control panel (Figure 4).
Select character or
paragraph style

Font size

All caps

Font family

Font style

Underline
Kerning

Tracking

Leading

Character style
Alignment

Justify

Strikethrough
Small caps

Figure 4 Type Control panel

Selecting text and applying basic formatting to text
To change the color of text, you first need to select it. (Text will not change if you change settings with only the text
frame selected.) You can use the Control panel and Tools panel to modify the font, color, and stroke of text. Fill refers
to the color inside the outline of a character. Stroke refers to the outline itself. By default, characters do not have a
stroke applied.
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To select text:

1. Choose the Type tool.
2. Click in a text frame with text.
3. Drag the pointer over the text to select it (Figure 5).
The text is highlighted.
4. Choose a different font family in the Font Family pop-up
menu, such as Franklin Gothic Medium.

Figure 5 Text selected

5. Choose a different font size in the Font Size pop-up
menu, such as 18 pt.
Fill

6. Select the Small Caps button.
With Small Caps, all lowercase letters appear as small
uppercase letters.
7. Double-click the Fill box in the Tools panel (Figure 6).
The color Color Picker opens (Figure 7).

Stroke
Apply Color

Figure 6 Fill and Stroke tools in the Tools panel

When you have text selected, the Fill box appears with a
small “T.”
8. Select a color for the text fill in the Color Picker.
9. Click OK.
The text changes fill color.
10. Double-click the Stroke box in the Tools panel.
The Color Picker appears.
11. Select a color for the text stroke in the Color Picker.
12. Click OK.
The text changes stroke color.

Figure 7 Color Picker

13. Click away from the text to deselect it and observe your
results (Figure 8).

Figure 8 Basic text formatting applied

Adjusting text spacing and applying baseline shift
To improve readability and meet design goals, you can also adjust the spacing between lines and characters—leading,
tracking, and kerning—and change the vertical location of some characters—baseline shift.
Adjusting leading

Leading refers to the space between lines. You’re probably used to differentiating between single-spaced and doublespaced text. By adjusting leading, you can fine-tune the space between lines.
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To adjust leading:

1. With the Text tool, select some text.
2. Choose a value in the Leading pop-up menu (Figure 9).
You can also enter a numeric value in the Leading menu’s
text box.
For example, 24-point leading was applied to the 12 point
text in Figure 10.

Leading pop-up menu

Figure 9 Leading menu in the Control panel

Figure 10 Leading applied to text
Adjusting tracking

Tracking refers to the space between characters across a line of text. When you adjust tracking, you can space the
letters further apart. (You will usually not want to reduce tracking unless you’ve already increased it.)
Tracking is measured in 1/1000 em. Em is relative to the current type size. In a 12-point font, 1 em equals 12 points;
in a 10-point font, 1 em equals 10 points. To give characters dramatic spacing, you need to enter fairly high numbers
in the Tracking box—at least 300.
To adjust tracking:

1. Select some text.
2. Choose a value in the Tracking pop-up menu
(Figure 11).
You can also enter a numeric value in the Tracking popup menu’s text box.

Tracking pop-up menu

Figure 11 Tracking menu in the Control panel

For example, tracking of 500 was applied to the 18-point
text in Figure 12.

Figure 12 Tracking applied to text
Adjusting kerning

Kerning refers to the space between any two characters. By default, InDesign applies metrics kerning to your text.
Metrics kerning automatically adjusts the space between letters so letter pairs that produce gaps—such as LA, Pa, Ta,
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We, and Yo—have spacing consistent with letter pairs that do not produce gaps. These letter pairs are called kern
pairs and are included with most fonts.
For fonts that do not include such pairs (which is rare), you can use another kind of automatic kerning called optical
kerning. Optical kerning adjusts the space between letters, based on their shapes. Optical kerning is also useful when
you use two different typefaces or sizes in one or more words on a line.
You may also want to adjust kerning manually. Usually, you only need to adjust it for large font sizes or when you
want the letters to look very close together. To adjust kerning between letters, click between them and change settings
in the Kerning pop-up menu in the Control panel (Figure 13).
Kerning pop-up menu

Figure 13 Kerning menu in the Control panel
Applying baseline shift

A font’s baseline is the lowest point of letters that do not extend below the baseline the way y and g do. You can use
baseline shift to adjust the baseline for one or more characters.
•

If you enter a positive number in the Baseline Shift pop-up menu, the text moves up from the baseline.

•

If you enter a negative number in the Baseline Shift pop-up menu, the text moves down from the baseline.

To apply baseline shift:

1. Select the character to which you wish to apply baseline
shift.
2. Click in the Baseline Shift pop-up menu, and then press
the Up or Down Arrow key to adjust the character’s
baseline (Figure 14).
For example, in Figure 15, the baseline for the J and L
has been adjusted negatively.

Baseline Shift pop-up menu

Figure 14 Baseline Shift menu in the Control panel

Figure 15 Baseline shift applied to text.
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Managing overset text
As you make formatting changes—especially changes that increase the total amount of space occupied by text—you
may create overset text. Overset text refers to text that does not fit in the text frame. When text is overset, a red plus
(+) will appear in the right text port (Figure 16).
Indicates text is overset

Figure 16 Frame with overset text
In these cases, you can take one of three actions:
•

Reduce font size, leading, or tracking so that the text fits into the frame.

•

Increase the size of the text frame.

•

Flow excess text into another text frame. (For more information on this option, see InDesign Help and the
“How to manage text flow between frames” guide.)

Advanced text composition
The appearance of text on your page depends on a complex interaction of processes called composition. Using the
word spacing, letterspacing, glyph scaling, and hyphenation options you’ve selected, InDesign composes your type
in a way that best supports the specified parameters.
InDesign offers two composition methods: Adobe Paragraph Composer (the default) and Adobe Single-line
Composer. You can select which composer to use from the Paragraph panel menu, the Justification dialog box, or the
Control panel menu at the right end of the Control panel.
The Paragraph Composer considers where to place line breaks and can respace earlier lines in the paragraph (based
on such principles as evenness of letterspacing, word spacing, and hyphenation) in order to eliminate unattractive
breaks later in the paragraph. The result is paragraphs with even spacing and fewer hyphens.
The Single Line Composer offers a traditional approach to composing text one line at a time. This option is useful if
you want to deal with paragraph composition in the last stages of your document production.
Suppose you want to precisely control word spacing and letterspacing, as well as the width of characters in a set of
justified paragraphs. You can use the Paragraph Composer to do this.
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To set a composition method for a paragraph:

1. Select some text that contains multiple paragraphs.
2. Choose Type > Paragraph.

Paragraph menu

The Paragraph panel opens (Figure 17).
3. Choose Justification from the Paragraph panel menu.
The Justification dialog box opens (Figure 18)
4. Change the default values to the following values in the
Justification dialog box:
•

Word Spacing Minimum 60%, Maximum 150%

•

Letter Spacing Minimum -50%, Maximum 150%

•

Glyph Scaling Minimum 80%, Maximum 120%

•

Auto Leading 140%

Figure 17 Paragraph panel

The Minimum and Maximum values define a range of
acceptable spacing for justified paragraphs only. The
Desired value defines the desired spacing for both
justified and unjustified paragraphs:
Word Spacing The space between words that results from
pressing the spacebar. Word Spacing values can range
from 0% to 1000%; at 100%, no additional space is
added between words.

Figure 18 Justification dialog box

Letter Spacing The distance between letters, including
kerning or tracking values. Letter Spacing values can
range from -100% to 500%: at 0%, no space is added
between letters; at 100%, an entire space width is added
between letters.
Glyph Scaling The width of characters (a glyph is any
font character). Glyph Scaling values can range from
50% to 200%.
5. Set the Single Word Justification option to specify how
you want to justify single-word text lines.
Note: In narrow columns, a single word can occasionally
appear by itself on a line. If the paragraph is set to full
justification, a single word on a line may appear to be too
stretched out. Instead of leaving such words fully
justified, you can center them or align them to the left or
right margins.

Figure 19 Paragraph text justified with last line
aligned left

6. Click OK.
The Adobe Paragraph Composer lays out the paragraph
text (Figure 19). Observe how the text is justified
according to the settings you entered in step 4.
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How to use character and paragraph styles
Whether you’re working with long or short documents, styles can help you keep text formatting consistent. Styles are
a collection of text attributes you can save and apply to new text.
A consistent design, especially in longer documents, helps readers navigate through your document and also helps
maintain a clean, appealing style and design layout.
Adobe InDesign CS5 has two kinds of styles:
•

Character styles collect information about the way textual characters appear: font size, font family, font
style (bold, italic), tracking, and leading. You choose character styles by using the Character Styles panel
(Window > Styles > Character Styles).

•

Paragraph styles include everything in character styles and also information about text orientation
(horizontal and vertical), tab stops, and other paragraph attributes. You can apply a paragraph style to one
paragraph or a range of paragraphs. Paragraph styles are available through the Paragraph Styles panel
(Window > Styles > Paragraph Styles).

Use character styles only when you know you will be applying styles to a few words rather than to the whole
paragraph. Otherwise, paragraph styles are generally more versatile.
This guide covers the following topics:
•

Creating paragraph styles based on existing formatting

•

Creating paragraph styles from scratch

•

Applying paragraph styles

•

Editing styles

•

Creating and applying character styles

Creating styles based on existing formatting
One of the easiest and fastest ways to create a style is to base it on text you have already formatted. This way, you can
see how the text appears on the page before saving the text attributes as a style.
To create a style based on existing formatting:

1. Start InDesign, create a new document, and create a text
frame by using the Type tool.
2. Add text to the text frame and apply formatting.
The text in the example (Figure 1) has the following
formatting:
•

Font family: Tahoma

•

Font size: 18 points

•

Font color: Red

Create New Style

Figure 1 Paragraph Styles panel

3. Select the text by using the Type tool.
4. Choose Window > Styles > Paragraph Styles to display
the Paragraph Styles panel (Figure 1).
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5. With text still selected, click the Create New Style button
at the bottom of the Paragraph Styles panel.
The new style appears in the Paragraph Styles panel
(Figure 2).
6. Select the style and choose Style Options from the
Paragraph Styles panel menu (Figure 3).
The Paragraph Style Options dialog box appears
(Figure 4).
7. In the Style Name text box, enter a name for the style.

Figure 2 New style created in the Paragraph
Styles panel

You will later use this name to apply the style, so make
the name as meaningful as possible.
For example, you might name the style after its function
(Second-Level Heading) or its appearance (Tahoma 18 pt
Red).
8. Click OK to close the Paragraph Style Options dialog
box.

Figure 3 Paragraph Styles panel menu

The renamed style is now available in the Paragraph
Styles panel (Figure 5).

Figure 4 Paragraph Style Options dialog box

Figure 5 Style renamed
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Creating a style from scratch
There may be a specific look and feel for a character or paragraph style you want to achieve. If so, you can create a
custom style.
To create a custom style:

1. If the Paragraph Styles panel is not open, choose Window
> Styles > Paragraph Styles to display it.
2. Choose New Paragraph Style from the Paragraph Styles
panel menu (Figure 3).
The New Paragraph Style dialog box appears (Figure 6).
3. In the Style Name text box, enter a name for the style.
You will later use this name to apply the style, so make
the name as meaningful as possible.
For example, you might name the style after its function
(Second-Level Heading) or its appearance (Tahoma 18 pt
Red).
4. In the General category of the New Paragraph Styles
dialog box (which appears by default), you can set the
following options:
•

In the Based On pop-up menu, choose a style on
which to base the current style. If you base this style
on an existing style, all changes made to the “base”
style—known as the parent style—will affect the
new style—known as the child style. For more
information on parent and child styles, see InDesign
Help.

•

In the Next Style pop-up menu, you can designate a
style to follow the style you’re defining. If you set
this option, the next style will automatically be
applied to the next paragraph after you press Enter
(Windows) or Return (Mac OS) at the end of a
paragraph to which the style has been applied. For
example, many headings are followed by “normal”
or “body text” styles. If you set a style called “body
text” as the next style for a heading, body text will be
applied automatically when you press Enter or
Return (Figure 7).
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Figure 7 Next style

How to use character and paragraph styles

3

Project 6 guide

Adobe InDesign CS5

5. Click other options on the left side of the New Paragraph
Style dialog box to set attributes in other categories.
For example, you might make changes in the following
categories:
•

Basic Character Formats: Font family, font size,
font style, kerning, leading, tracking, case, and so on.

•

Advanced Character Formats: Horizontal and
vertical scale, baseline shift, and skew.

•

Indents And Spacing: Text indent, space after text,
alignment, and so on. Use the Align To Grid option
to align all text to the document grid.

•

Character Color: Sets character color from a list that
includes any swatches you have created.

6. When you are satisfied with your changes, click OK to
create the style.
The New Paragraph Style dialog box closes and the new
style is available in the Paragraph Styles panel.

Applying a style
Once you create a style by using any method, you can apply that style to new or existing text.
To apply a style:

1. Create a text frame by using the Type tool.
2. Add text to the text frame.
3. If the Paragraph Styles panel is not open, choose Window
> Styles > Paragraph Styles to display it.
4. Select the text by using the Type tool (Figure 8).
5. In the Paragraph Styles panel, click a style to apply it.

Figure 8 Selecting the text to apply a style

6. Click anywhere to deselect the text.
The style’s formatting has been applied to the text
(Figure 9).

Figure 9 Style applied
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Editing a style
Even after you apply a style to text, you can make changes to the style. These changes are applied automatically to all
text with that style applied.
To edit a style:

1. If the Paragraph Styles panel is not open, choose Window
> Styles > Paragraph Styles to display it.
2. Click a style to select it.
Ideally, this should be a style you have previously applied
to text
3. Choose Style Options from the Paragraph Styles panel
menu (Figure 3).
The Paragraph Style Options dialog box appears
(Figure 10).
4. On the left side of the Paragraph Style Options dialog
box, click the Basic Character Formats option to expand
the Basic Character Formats category.
5. Change some of the following attributes:
•

Font family

•

Font size

•

Case

•

Leading

Basic Character Formats category

Figure 10 Paragraph Style Options dialog box

6. Click OK to apply the changes.
Any text with the style applied has changed.
The text in the example (Figure 11) has been changed to
the following:
•

Font family: Times New Roman

•

Font size: 18 points

•

Case: Small Caps

© 2010 Adobe Systems Incorporated
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Creating and applying character styles
Character styles can include only those attributes you can apply to characters. Character styles are useful when you
want to apply special formatting to a word or phrase within a paragraph—even a paragraph that has a paragraph style
applied to it. Character styles override paragraph styles.
To create a character style:

1. Choose Window > Styles > Character Styles to display
the Character Styles panel (Figure 12).
2. Choose New Character Style from the Character Styles
panel menu (Figure 13).
The New Character Style dialog box appears
(Figure 14).
The set of options on the left side is more limited than in
the Paragraph Style Options dialog box.
3. In the Style Name text box, enter a name for the new
character style.

Figure 12 Character Styles panel

You will later use this name to apply the style, so make
the name as meaningful as possible.
For example, you might name the style after its function
(Text Highlight) or its appearance (Tahoma 14 pt Red).
4. Click options on the left side of the dialog box to set
attributes in other categories.
For example, you might make changes in the following
categories:
•

Basic Character Formats: Font family, font size,
font style, kerning, leading, tracking, case, and so on.

•

Advanced Character Formats: Horizontal and
vertical scale, baseline shift, and skew.

•

Character Color: Sets character color from a list that
includes any swatches you have created.

Figure 13 Character Styles panel menu

5. When you are satisfied with your changes, click OK to
create the character style
Figure 14 New Character Style dialog box
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To apply a character style:

1. Create a text frame by using the Type tool.
2. Add text to the text frame.
3. If the Character Styles panel is not open, choose Window
> Styles > Character Styles to display it.
4. Select one or two words of the text by using the Type tool
(Figure 15).

Figure 15 Applying a character style

5. In the Character Styles panel, click the style to apply it.
6. Click anywhere to deselect the text.
The style’s formatting has been applied to the selected
text (Figure 16).
The style is not automatically applied to the entire
paragraph as it is when you apply a paragraph style.
Figure 16 Character style applied
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How to wrap text around objects
You’ve probably seen documents with a picture set within a long text block, or with a “pull out quote” positioned in
the middle of a text block. Designers create this effect by wrapping text around these objects. In Adobe InDesign
CS5, you can add shapes or frames within text frames and wrap text around them.

Wrapping text around a simple shape
In the steps that follow, you fill a text block with placeholder text, then draw a rectangle over the text. You then select
the Wrap Around Object shape option to rearrange the text around the rectangle.
You might use this technique to add a small graphic to the middle of a text block, or to illustrate something described
in the text block.
To wrap text around a simple shape:

1. Start InDesign and create a new document. Create a text
frame by using the Type tool.
2. Choose Type > Fill With Placeholder Text to fill the
frame with placeholder text.
3. Choose the Rectangle tool in the Tools panel (Figure 1)
and drag the pointer over the text to draw a rectangle
(Figure 2).

Rectangle tool

Figure 1 Tools panel

The rectangle appears over the text.
4. Make sure the rectangle is still selected. On the right side
of the Control panel, click the Wrap Around Object
Shape button (Figure 3).
Observe that the text now wraps around the rectangle
(Figure 4).

Figure 2 Rectangle drawn over text

Wrap Around Object Shape button

Figure 3 Control panel

Figure 4 Text wrapped around object
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Using text wrap to add a pullout quotation
Publications often include pullout quotations to add interest. These key quotations are highlighted in a text box and
placed in the middle of a text block.
To wrap text for a pullout quotation:

1. Choose the Rectangular Frame tool in the Tools panel.
2. Drag the pointer over the text to draw a rectangle
(Figure 5).
The rectangle appears over the text.
3. Make sure the rectangle is still selected. On the right side
of the Control panel, click the Wrap Around Object
Shape button (Figure 6).

Figure 5 Frame in the middle of a text block

4. Choose the Selection tool in the Tools panel.
5. Click the edge of the frame to select it.
6. Choose Object > Content > Text to change the frame to a
text frame.
7. Add text to the text frame to complete the pullout
quotation (Figure 7).

Figure 6 Wrap Around Object Shape applied

Figure 7 Pullout quotation complete

Spread Rotation
Now you no longer need to rotate your monitor when designing a publication with both horizontal and vertical pages.
The Rotate Spread command enables you to temporarily turn your document in 90-degree increments so you can
easily work on text and images that are not right-side-up relative to the rest of the document.
To rotate a spread:

1. Start InDesign and choose File > New to display the New
Document dialog box (Figure 8).
2. In the Number of Pages box, enter 3.
You can enter a higher number, but make it at least 3. You
want at least 3 pages because InDesign places the first
page by itself, the way the first page of a magazine or
book usually appears on the right side by itself. When
you select 3 pages, you ensure you’ll get at least one
facing page spread.
3. Click OK to close the New Document dialog box and
create the document.
The document opens on the first page.
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4. Choose View > Rotate Spread > 90° CW.
The first page of the layout rotates one-quarter turn
clockwise relative to the other pages in the document
(Figure 9).
5. Choose Window > Pages to display the Pages panel.
Beside page 1 the View Is Rotated -90˚ icon indicates
that the representation of the page in the Pages panel is
rotated 90° counterclockwise (Figure 10). (This may
seem a bit confusing, but you rotated the page clockwise,
and what you see in the Pages panel has not changed, so
it’s as if the representation had been rotated back 90˚
from the actual position of the page.)

Figure 9 Three-page layout showing first page
rotated 90°

View is Rotated -90° icon

Figure 10 Pages panel
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How to manage text flow between frames
In Adobe InDesign CS5, you’ve probably noticed that sometimes a red plus appears in a text frame when you fill it
with more text than fits. This red plus indicates the text is overset. Overset text is text that does not fit in the text
frame.
You could solve the problem of overset text by making the text frame bigger, but often you will want to continue the
text in another text frame, either on the same page or on another page. This is called text flow. Flow means the overset
text continues in another text frame. Newsletters and newspapers use text flow when they begin a story on one page
and continue it on a later page (often marked with “Continues on page 11”). You can also use text flow to continue
text between two different text frames on the same page.
In the example (Figure 1), the upper text frame is overset and needs to flow to the lower text box.

Figure 1 Overset text frame
Text flow relates to text frame ports. Each text frame has an in port and an out port. When the text is overset, a red
plus appears in the out port.

In port

Out port plus sign indicating overset

Figure 2 Text frame with ports
To flow text to another text frame, you click in the out port (Figure 2). When you do, the pointer becomes a loaded
text icon, which looks like a small arrow with the first few lines of your text attached. When you move the loaded text
icon over a text frame, a pair of chain links appears in the icon, indicating that clicking in that text frame will link it to
the overset text frame to continue the text flow.
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Depending on where you place the loaded text icon, it changes appearance. When you move the loaded text icon over
a text frame, the icon is enclosed in parentheses. When you move the loaded text icon next to a guide or grid snapping
point, the black pointer becomes white.

Flowing text from one text frame to another
The text in a frame can be independent of other frames, or it can flow between connected frames.
To flow text from one text frame to another:

1. Start InDesign and open a document.
2. Select the Type tool in the Tools panel (Figure 3).
3. Drag the Type tool on the page to create a text frame, and
repeat the process to create another text frame (Figure 4).

Selection tool

4. Type, paste, or place enough text in one text frame so the
text is overset (Figure 2).
5. Click the Selection tool in the Tools panel (Figure 3).

Type tool

6. Click the out port on the overset text frame (Figure 5).
The pointer changes to a loaded text icon.

Figure 3 Tools panel

Figure 4 Two text frames

Text frame out port

Figure 5 Overset text added to one frame
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7. Move the pointer over the second text frame.
The pointer changes to a loaded text icon enclosed in
parentheses.
8. Click in the second text frame.
The overset text flows into the second text frame
(Figure 6).
9. Try adding some text to the first text frame.
As you do so, some text shifts into the second text frame.
10. Choose Edit > Select All.

Figure 6 Text flow between frames

The text in both frames is selected (Figure 7).

Figure 7 All text selected in both frames

Using autoflow options
The previous section describes how to flow text manually. With manual text flow, each time you want to flow text to
another text frame, you have to click in one text frame’s out port and click in another text frame with the loaded text
icon. However, InDesign also gives you ways to flow text automatically, so that, for example, the loaded text icon
automatically appears when text is overset. These options are known as autoflow options. You use autoflow by using
the key combinations in the following table while you click with the loaded text icon.
The table describes autoflow options.
Key held down

What it does

Alt (Windows) or Option (Mac OS)

Semi-autoflow: Works like manual text flow except
that the pointer becomes a loaded text icon each
time the end of a frame is reached until all text is
flowed into your document.
When you use semi-autoflow, it’s as if the out port
is clicked automatically each time you finish
flowing text into a text frame if the text is overset.
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Key held down

What it does

Shift

Autoflow: With this option, InDesign adds pages
and frames until all text is flowed into your
document. Each frame takes up an entire page. If
you added columns to pages in the New Document
dialog box, InDesign adds text in columns.
For example, if your pages have two columns, and
you hold down the Shift key while clicking with the
loaded text icon, InDesign adds two-column pages
filled with text until all text has been added.
Note: In order for InDesign to add pages with
columns, you need to have added columns to the
document at the time you created it in the New
Document dialog box. Alternately, you can create a
master page with two columns. When you use
Autoflow on a page created with a master page,
InDesign adds more pages using the format of the
master page. For more information on master
pages, please see InDesign help.

Shift+Alt (Windows) or Shift+Option (Mac OS)

Fixed-page autoflow: Flows all text into the
document without adding frames or pages. With
this option, InDesign creates one text frame on the
current page, without adding additional pages.

The following steps guide you through using the semi-autoflow option described previously. Again, the initial steps
described in this guide had you flowing text manually by clicking a text frame’s out port each time you wanted to
resolve overset text. Semi-autoflow is similar to manual text flow except the loaded icon automatically appears when
flow is complete if text is overset. Fixed-page autoflow works like autoflow, except InDesign does not add additional
pages. Any remaining text is overset.
To use semi-autoflow:

1. Open a document with one or more text frames.
2. Type, paste, or place enough text that the text will be
overset not just past the frame, but past the page.
For example, you might paste or place two or more
single-spaced pages of 12-point text.

Figure 8 Autoflow icon

3. Click the Selection tool in the Tools panel.
4. Hold down the Shift key and click the out port on the
overset text frame (Figure 4).
The pointer changes to a loaded text icon with the
autoflow option (Figure 8).
5. Move the pointer somewhere in the page and click.
6. InDesign automatically adds pages and frames to
accommodate the text flow (Figure 9).
Figure 9 Result of autoflow
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How to fill text with an image
You’ve seen the effect: a postcard with the word “Maui,” the letters filled in with images of sand, sea, and jungle.
Text and image come together to create a compelling effect. This guide shows you how to fill text with one or more
images. To do so, you first convert the letters of a text line to frames, and then fill those frames with images.
To fill a line of text with one image:

1. Create a new a document in Adobe InDesign CS5.
2. Choose Window > Type & Tables > Character to display
the Character panel.

Font menu

Your text needs to be fairly large and thick so the images
show clearly inside the text characters.
3. Set the following or similar options in the Character
panel (Figure 1):
•

From the Font pop-up menu, choose a thick font,
such as Arial Black or Fat.

•

From the Font Size pop-up menu, choose 72 pt. You
could type an even higher number into the Font Size
box.

•

Font Size menu

Figure 1 Character panel

Adjust tracking and kerning as desired. Because
you’re only creating one line, you do not need to
worry about leading.
Selection tool

4. Select the Type tool in the Tools panel (Figure 2) and
drag on the page to create a text frame.
5. Type a short line of text in the text frame, such as
Whales.
Note: If you type in all capitals, the image has more
room to show through.
6. When you finish typing, select the text with the Type
tool.

Type tool

Figure 2 Tools panel

Next, you convert the text to an outline. An outline is
basically a frame in the shape of the text’s letters.
7. Choose Type > Create Outlines.
An outline is added to the text (Figure 3).
Note: You might first need to choose Type > Show All
Menu Items to make the Create Outlines menu item
available.

Figure 3 Text selected with Type tool

8. Choose the Selection tool in the Tools panel (Figure 2).
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9. Click one of the letters in the text.
The outlines of the letters become visible as frames
(Figure 4).
10. With the text outline still selected, choose File > Place.

Figure 4 Outlines of letters

The Place File dialog box appears.
11. Make sure Show Import Options is deselected and
Replace Selected Item is selected.
You use the Show Import Options option to manage
advanced options for placed images. This option
becomes especially important when you place image
formats such as Adobe Photoshop and Adobe Illustrator
files.

Figure 5 Initial step of text filed with image

The Replace Selected Item option asks InDesign to put
the new image in place of whatever content is in the
currently selected frame.
12. Select the Preview option (Windows).
When the Preview option is selected, a thumbnail of the
image appears in the lower-right corner of the Place
dialog box.
13. Browse to the location of the image file you want to
appear in the letters of your text.

Figure 6 Image selected

14. Select the file and click Open.
The Place dialog box closes, and the letter outlines fill
with the selected image (Figure 5).
Note: Even though the letters appear to be separate, they
function as a single frame.
The image isn’t automatically well positioned behind the
text. Your next task is to reposition the image.
15. With the text outlines still selected, choose Object >
Select > Content.
The image becomes selected. Only part of the image is
visible through the text.

Figure 7 Positioning image behind text

Note: If the text outlines become deselected, you can
click anywhere in the text and then choose Object >
Select > Content to select the image inside the graphic
frame .
16. As you drag the image to position it behind the text, the
full image appears with X and Y coordinates to help
guide you for proper placement (Figure 7).

Figure 8 Text filled with image

17. Release the mouse to accept the changes (Figure 8).
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How to add page numbers
As in many word processing programs, you can automatically update page numbers in Adobe InDesign CS5. You do
so by adding a page-number marker to a text frame on your pages and specifying where the page number should
appear.
•

Because page numbers update automatically, the page number is always correct—even as you add, remove,
or rearrange pages in the document.

•

Because you add page numbers to a text frame, you can apply styling and formatting to it as you would any
other text.

•

If the automatic page number is on a master page, it displays the master page prefix, such as “A.” On a
document page, it displays the page number.

Adding page numbers
Before you add page numbers, you need to decide where to put them. In the following steps, you’ll create a facing
page spread and add page numbers to the upper-left and upper-right corners of the spread. A facing page spread
consists of two pages with mirrored margins—think of a typical book or magazine layout where two sequential
pages, such as pages 2 and 3, face each other.
To add page numbers:

1. Start InDesign and choose File > New to display the New
Document dialog box (Figure 1).
2. Select the Facing Pages option.
When you select the Facing Pages option, you instruct
InDesign to add pages in two-page spreads.
3. In the Number of Pages box, enter 3.
You can enter a higher number, but make it at least 3. You
want at least 3 pages because InDesign places the first
page by itself, the way the first page of a magazine or
book usually appears on the right side by itself. When
you select 3 pages, you ensure you’ll get at least one
facing page spread.

Figure 1 New Document dialog box

4. Click OK to close the New Document dialog box and
create the document.
The document opens on the first page.
5. To get to the two-page spread, either press the Page
Down key or use the scroll bar to scroll down to pages 2
and 3, which should appear in a facing page spread
(Figure 2).

Add text frames here

You’re going to add page numbers in the upper-right and
upper-left corners.

Figure 2 Two-page spread
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6. Select the Type tool in the Tools panel (Figure 3).
7. Position the pointer in the upper-left corner of the spread.
Drag the Type tool on the page to create a text frame
(Figure 4).

Selection tool

Width and height coordinates appear to help properly size
the text frame.
The text frame should be large enough to hold the longest
page number in your document. For example, if your
document has 50 pages, the text frame needs to be large
enough to hold two characters.

Type tool

Figure 3 Tools panel

8. Click in the text frame and choose Type > Insert Special
Character > Markers > Current Page Number.
A 2 appears in the text frame (Figure 5).
By default, the number will appear in whatever font size
you last applied in the Control panel.
9. Select the page number with the Type tool and apply
formatting to it, such as a font and font size, by using the
Control panel (Figure 6).
10. Repeat steps 4–6, but position the text frame in the upperright corner of the spread.

Figure 4 Text frame in upper-left corner of spread

A 3 appears in the text frame.
11. After you add the page number, click the Right Align
button in the Control panel (Figure 6).
You’re right-aligning the page number so it appears in the
right corner (Figure 7).
Continue adding page numbers to the other pages in your
document.

Figure 5 Page number inserted

When you are finished, close the document.
Font family

Font size

Right Align button

Figure 6 Control panel

Figure 7 Page number right-aligned
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Adding page numbers to master pages
In the previous section, you added page numbers to the individual pages of a document. You can make the pagenumber process easier by using master pages. Master pages—which you’ll learn more about in the “How to use
master pages” guide—determine the appearance of pages in a document. When you add elements to a master page,
these elements appear on every page in the document. By adding page numbers to a master page, you ensure that page
numbers will appear on every document.
To add page numbers to master pages:

1. Start InDesign and open a new document.
2. Choose Window > Pages to display the Pages panel
(Figure 8).
Master pages appear in the upper pane of the panel.
The page in the lower pane has an A in the upper-left
corner (unless you’ve previously changed the master
page).
Two joined pages appear next to A-Master, indicating
that the master is a two-page spread. A spread is a twopage layout. You’re going to add page numbers in each
corner of the spread.
3. Double-click the A-Master to display it.
The two-page spread appears (Figure 9). You’re going to
add page numbers in the upper-left and upper-right
corners.

Master pages

Double-click to open

Figure 8 Pages panel

Add text frames here

Figure 9 Two-page spread
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4. Select the Type tool in the Tools panel (Figure 10).
5. Position the pointer in the upper-left corner of the spread
and drag the Type tool on the page to create a text frame
(Figure 11).

Selection tool

Width and height coordinates appear to help properly size
the text frame.
The text frame should be large enough to hold the longest
page number in your document. For example, if your
document has 50 pages, the text frame needs to be large
enough to hold two characters.

Text tool

Figure 10 Tools panel

6. Click in the text frame and choose Type > Insert Special
Character > Markers > Current Page Number.
An A appears in the text frame because you added the
page number to a master page (Figure 12).
By default, the A will appear in whatever font size you
last applied in the Control panel.
7. Select the A with the Type tool and apply formatting to it,
such as a font and font size, using the Control panel .

Figure 11 Text frame in upper-left corner of spread

8. Repeat steps 4–6, but position the text frame in the upperright corner of the spread.
9. After you add the page number, click the Right Align
button in the Control panel.
You’re right-aligning the page number so it appears in the
right corner (Figure 13).

Figure 12 Page number inserted

Now that you’ve added page numbers to the master,
you’re going to see how they appear on the actual pages.
10. If it is not still visible, choose Window > Pages to display
the Pages panel.
11. Click a page in the lower panel to open it.
The page opens.

Figure 13 Page number right-aligned

A page number appears in place of the A on the
document’s pages (Figure 14).

Figure 14 Page number as it appears on page
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How to prepare files for print
Preparing files for printing involves the following steps:
•

Setting printer settings

•

Using Preflight to confirm that the file has all components necessary for printing

•

Packaging the files for printing

For more information on printing, see the Adobe Print Resource Center at www.adobe.com/go/print_resource.

Printing to a printer
You set printer settings through the Adobe InDesign CS5 Print dialog box. In the following steps, you set printer
settings and then print to your printer.
To print to a printer:

1. Start InDesign and open the document to be printed.
2. Select File > Print
The Print dialog box appears (Figure 1) with the General
area selected in the left pane.
3. Under Pages, select the pages you want to print.
4. Under Options, make sure Visible & Printable Layers is
selected in the Print Layers menu.
This means everything you see in your InDesign
document will print.
5. In the left pane, choose Setup.
The Setup area of the Print dialog box appears
(Figure 2).
6. Under Paper Size, choose Letter.
This the default size paper loaded in most printers.
Alternately, you can select the dimensions of the paper in
your printer.

Figure 1 Print dialog box

Figure 2 Setup area of Print dialog box
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7. In the left pane, choose Marks And Bleed to display the
Marks And Bleed area of the Print dialog box.
8. Select All Printer’s Marks (Figure 3).
This tells InDesign to print all the marks that let you cut
your document to your desired size. See Figure 5 for an
example of marks.
Because printers do not print to the page edge, you will
usually need to crop your document after printing. Crop
marks show you where to cut your document.
9. Select Output in the left pane.
The Output area of the Print dialog box appears
(Figure 4).
10. In Output settings, make sure Composite RGB is selected
in the Color menu.
All Printer’s Marks option

11. Leave the other settings unchanged, and click Print to
print the document.

Figure 3 Marks And Bleed area of Print dialog box

When the document prints, it shows all of the printer’s
marks (Figure 5).

Figure 4 Output area of Print dialog box

Figure 5 Printed file
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Sending files to a print vendor
Unlike your printer at home or school, print vendors have very specific requirements for what they will print. These
requirements have been established to ensure the printed copies you receive look the way you expected. As you gain
experience as a designer, you will find that meeting these requirements results in fewer problems with print vendors.
After all, you’re paying a lot of money to get your designs printed.
Most print vendors accept print projects in one of two formats:
•

PDF/X-1: A special kind of PDF that restricts PDF features (such as comments) that might interfere with the
print process.

•

Native files: The set of files you used to create your InDesign document. These include the InDesign file itself,
any fonts used in the document, and any image files used in the document.

Preparing a PDF/X-1 for a print vendor

The PDF/X-1 file format is widely used by print vendors in the United States. PDF/X-1 is a PDF file that excludes
everything that might interfere with producing a quality print job, such as RGB images, annotations, form fields, and
comments. For more information, see www.pdfx.info/ or the Adobe Acrobat user manual.
Note: Because PDF/X-1 excludes all RGB images, you need to be sure the images in your InDesign document are
CMYK. It is best to convert images to CMYK TIFFs in Photoshop before placing them in an InDesign file.
To prepare a PDF/X-1 file:

1. Start InDesign and open the document you want to
prepare for a print vendor.
2. Choose File > Export.
The Export dialog box appears (Figure 6).
3. Specify a name and location for the file.
4. Specify Adobe PDF (Print) in the Save As Type menu
(Windows) or the Format menu (Mac OS).
5. Click Save.
The Export Adobe PDF dialog box appears.
Figure 6 Export dialog box

© 2010 Adobe Systems Incorporated

How to prepare files for print

3

Project 3 guide

Adobe InDesign CS5

6. From the Adobe PDF Preset pop-up menu, choose PDF/
X-1a:2001 (Figure 7).
7. Leave other settings unchanged, and click Export.
A message will appear that shows you the progress of the
export.
8. When the export is complete, browse to the location of
the exported file and open the file.
The PDF looks like any other PDF, without comments
and other features.
9. Close the file without saving.
Note: Be careful not to save the document in Adobe
Acrobat 9. Saving the document could change the
settings, meaning the document would no longer conform
to the PDF/X-1a:2001 standard.

Figure 7 Export Adobe PDF dialog box

Sending native files to a print vendor

Some print vendors may require you to send native files to be printed. Native files consist of the following:
•

The InDesign file for the project

•

Any images used in the project

•

Any fonts used in the project

To prepare native files, first check that all of the appropriate files are available, and then package these files in one
folder to send to the print vendor.
Using Preflight

Use a feature of InDesign called Preflight to confirm that all graphics and fonts used in the file are available for
printing. Preflight is the industry-standard term for performing a quality check on the document.
While you edit your document, the Preflight panel warns of problems that can prevent a document or book from
printing or outputting as desired. These problems include missing files or fonts, low-resolution images, overset text,
and a number of other conditions.
To take advantage of live preflighting, create or specify a preflight profile in the early stages of creating a document.
If Preflight is turned on, a red circle icon appears in the status bar when InDesign detects any problems. You can open
the Preflight panel and view the Info section to get basic guidance for fixing the problems.
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To use Preflight:

1. Double-click the Preflight icon at the bottom of
document window. The Preflight icon is green if no
errors are detected or red (Figure 8) if errors are
detected.

Figure 8 Preflight icon in document window

The Preflight panel appears.
For this print job Preflight encounters one missing image
link and several missing fonts (Figure 9).
2. In this example, the logo.psd link is missing. Doubleclick on the image file in the Preflight panel to help
locate the broken link within the InDesign layout.

Image file

3. Choose Window > Links.
The Links panel shows all images placed in the
document. Broken links are flagged with a question mark
symbol (Figure 10).
4. In the example (Figure 10), the logo image is missing.
To locate the image on your system, double-click the
question mark icon.

Figure 9 Error area of the Preflight panel

If the image is not on your system, you should copy the
image to your system before continuing to prepare the
package. Without the image file, your print vendor will
not be able to print your document correctly.
The Locate dialog box appears.
5. In the Locate dialog box, browse to the location of the
missing image (Figure 11).
6. Select the image and click Open.
The Locate dialog box closes.
7. Return to the Preflight panel.
The Missing link error is resolved; however a Missing
font error remains. Double-click the text string ('Jane
Lui') in the Preflight panel to help locate the missing
fonts within the InDesign layout.

Figure 10 Preflight Links and Images category

Figure 11 Locate dialog box
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8. Choose Type > Find Font.
Select the missing font names in the Fonts In Document
list (Figure 12).
9. To replace a font, select the new font you want to use
from the Replace With list, and do one of the following:
•

To change just one occurrence of the selected font,
click Change. This option is not available if multiple
fonts are selected.

•

To change the font in that occurrence, and then find
the next instance, click Change/Find. This option is
not available if multiple fonts are selected.

•

Figure 12 Find Font dialog box

To change all instances of the font selected in the list,
click Change All. If you want any paragraph or
character style that includes the font being searched
for to be redefined, select Redefine Style When
Changing All.

When there are no more occurrences of a font in your
file, its name is removed from the Fonts In Document
list.
10. Return to the Preflight panel and confirm that all
preflight errors have been resolved.
Packaging files for a print vendor

When you package a file, you collect into one folder all of the assets a print vendor will need to print the file. You
could do this manually, but the Package utility in InDesign makes this process much easier.
To package a file:

1. Choose File > Package. (If Package does not appear in
the File menu, try choosing a different workspace, such
as Window > Workspace > Advanced.)
The Summary area of the Package dialog box appears.
An alert icon indicates any problem areas (Figure 13).
2. If you're notified of problems in the Package dialog box,
do one of the following:
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•

Click Cancel, and use the Preflight panel to resolve
problem areas.

•

In the left pane, click the problem area (such as
Fonts) and then correct the problem. When you’re
satisfied with the document, begin the packaging
process again.

How to prepare files for print

Figure 13 Package Summary dialog box

© 2010 Adobe Systems Incorporated

Adobe InDesign CS5

Project 3 guide

3. When there are no problems, click Package in the
Package dialog box to begin packaging.
The Printing Instructions dialog box opens (Figure 14).
4. Fill in the printing instructions. The filename you type is
the name of the report that accompanies all other
packaging files. Enter the following information:
•

Your contact information, including company,
address, email, and phone number.

•

Any instructions for printing, such as number of
copies or when the print vendor should call you.

5. Click Continue.

Figure 14 Printing Instructions dialog box

The Printing Instructions dialog box closes.
The Package Publication (Windows) or Create Package
Folder (Mac OS) dialog box appears (Figure 15).
6. Select the following options:
•

Copy Fonts

•

Copy Linked Graphics

•

Update Graphic Links In Package

7. In the Package Publication dialog box, browse to a folder
for the packaged document.
8. Click Package.
A dialog box appears warning you about copying fonts.
Many font companies, such as Adobe, let you send a
copy of your font to the printer. Check your font license
to be sure.
Although most print vendors will have a copy of the font
you’re using, you send them the font to make sure it’s the
correct one.

Figure 15 Package Publication dialog box

9. Click OK in the Warning dialog box.
InDesign creates the document package.
10. Close or minimize InDesign. Navigate to the folder on
your system where you placed the package (Figure 16).
The folder contains an INDD file, a text file with your
instructions, a Font folder, and a Links folder.
11. Open the Links folder.
You should see files for the images you’ve included in
the document.
You can now submit the package to a print vendor.
Figure 16 Folder containing print package
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How to create interactive documents
You can use Adobe InDesign CS5 to create dynamic web content or interactive documents. InDesign supports export
to SWF or PDF.

Interactive web documents for Flash
For SWF files, you specify the page size according to monitor resolution (such as 800x600). An exported SWF file is
ready for viewing in Adobe Flash Player and may include interactive elements such as page transitions, hyperlinks,
and navigation buttons.
In this guide, you will learn how to create web documents by using InDesign (Figure 1). Steps include how to create
an interactive button, how to add a page transition, and how to export to SWF format. InDesign includes many more
options for adding interactivity to your web document. Once you are comfortable with the basics, try experimenting
with additional features such as rollover and click states for buttons, animating objects by using animation motion
presets, and modifying the export SWF options.

Document in InDesign before SWF export

Interactive SWF file in web browser

Figure 1 Create interactive documents by using InDesign
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Consider the following factors when designing your InDesign document for SWF output.
Document setup factors

•

How InDesign pages are converted When you export to SWF, InDesign spreads become separate clips in a
timeline, like slides in a slide show. Each spread is mapped to a new keyframe. In Flash Player, you advance
through the spreads of the exported document by pressing arrow keys or clicking interactive buttons.

•

Page size When you create a document, you can choose a specific resolution, such as 800x600, from the
Page Size menu in the New Document dialog box. During export, you can also adjust the scale or resolution
of the exported SWF file.

Conversion factors

•

Color SWF files use RGB color. When a document is exported to SWF, InDesign converts all color spaces
(such as CMYK and LAB) to sRGB. InDesign converts spot colors to equivalent RGB process colors. To
avoid unwanted color changes in artwork with transparent text choose Edit > Transparency Blend Space >
Document RGB. To avoid unwanted color changes in images with transparency, avoid using a lossy
compression during export.

•

Text When exporting to SWF, you can determine whether to output text as Flash text or convert it to outlines
or pixels. Text exported as Flash Classic Text remains fully searchable in web browsers when saved as SWF
files.

•

Images When you export images to SWF, you can change image compression, JPEG quality, and resolution
settings during export.

•

Transparency Before exporting to SWF, make sure that transparent objects do not overlap any interactive
element, such as a button or hyperlink. If an object with transparency overlaps an interactive element, the
interactivity may be lost during export. In some instances, choosing a lossy compression reduces the quality
of images with transparency. When exporting, choose PNG (Lossless) to improve the quality.

Interactivity factors

You can include buttons, page transitions, hyperlinks, animation, and media files in exported SWF files.

2

•

Buttons For buttons in an exported SWF file, the Next Page and Previous Page actions are especially useful
controls for playback in Flash Player. However, some actions that work in interactive PDF files have no
effect in Flash Player. When you choose an action in the Buttons panel, do not select an option from the PDF
Only section.

•

Page Transitions All page transitions work well in Flash Player. In addition to page transitions that appear
when you turn the page, you can add an interactive page curl during export that lets you drag corners of
pages to turn them.

•

Hyperlinks Create links to websites or to other pages in the document.

•

Movies and sound clips Movies and sound clips are included in an exported SWF file if they’re in SWF
format for movies and MP3 format for sound clips.

How to create interactive documents
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To create interactive SWF (Flash) files for the web:

1. Start InDesign and choose File > New > Document.
The New Document dialog box appears (Figure 2).
2. When creating a document intended for the web, choose
Web from the Intent menu in the New Document dialog
box.
3. Enter 2 or more pages in the Number Of Pages box.
4. Choose Letter from the Page Size menu.
5. Click OK to close the New Document dialog box.
First, you need to create an interactive button that allows
users to move from page to page in the exported SWF
file.
6. Import an image, draw a shape, or add text to the
document.

Figure 2 New Document dialog box
Selection tool

7. Use the Selection tool (Figure 3) to select the image,
shape, or text frame that you want to convert to a button.
8. Choose Window > Interactive > Buttons.

Figure 3 Tools panel

The Buttons panel appears (Figure 4).

Buttons panel
menu

Note: Sample buttons are also available. Click the
Buttons panel menu to access the Sample Buttons panel
(Figure 5). You can drag predefined navigation buttons
into your document and attach actions to these instead of
an existing image, shape, or text frame in the document.
9. Click the Convert Object To A Button icon in the Buttons
panel (Figure 4).
The object is converted to a button and the Buttons panel
is updated.

Convert Object To
A Button

10. Name the new button in the Name text box and confirm
that the Hidden Until Triggered option is not selected.
Next, you need to define the mouse event and assign an
action for the button.

Figure 4 Buttons panel

Figure 5 Sample Buttons panel
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11. Click the Event button, and select from the available
options (Figure 6). An event defines how actions are
activated.
•

On Release When the mouse button is released after
a click. This is the most commonly used event,
because it gives the user one last chance to drag the
cursor off the button and not activate the action.

•

On Click When the mouse button is clicked (without
being released). Unless you have a specific reason
for using On Click, it’s preferable to use On Release
so that users have a chance to cancel the action.

•

On Roll Over When the mouse pointer enters the
button area defined by the button’s bounding box.

•

On Roll Off When the mouse pointer exits the button
area.

Event button

Figure 6 Event menu

12. Click the Add New Action button, and choose an action
to assign to the event you just selected.
Add New
Action button

For example, if you are working with a multipage spread,
you might choose Go To Next Page from the list of
destination options (Figure 7).
If you choose Go To URL, specify the web page address.
Some actions, such as Go To Next View, do not have
additional settings.
13. With the object still selected, choose Window >
Interactive > Page Transitions to add page transitions
such as wipes or dissolves.
The Page Transitions panel appears (Figure 8).
14. From the Transition menu, select Page Turn (SWF Only).
You can move your mouse over the Preview area to see
how the transition works.

Figure 7 Add New Action menu

15. Choose File > Save.
16. To export the document to SWF format, choose File >
Export.

Preview area

The Export dialog box appears.

Transition menu

Figure 8 Page Transitions panel
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17. Choose Flash Player (SWF) from the Save As Type
(Windows) or Format (Mac OS) menu, and click Save.
The Export SWF dialog box appears (Figure 9).
You can specify the export options in the Export SWF
dialog box.
18. For this example, accept the default export options. For
more information about Export SWF options, see “SWF
export options” in InDesign Help.
19. Click OK.
The Generate Flash Player (SWF) progress dialog box
appears and the file is processed.
The file opens in your default browser.
20. Test the button interactions in your interactive SWF file
(Figure 10).

Figure 9 Export SWF dialog box

Figure 10 Testing hyperlinks in the browser
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Animation
You can use Animation effects to make objects move in InDesign documents you export as SWF files. For example,
you can apply a motion preset to drop a heading in from the top or to make an image of an automobile appear to move
in from the right side of the screen and screech to a halt (Figure 11). Use the following tools and panels to animate
documents.
•

Animation panel Apply a motion preset and edit settings such as duration and speed.

•

Direct Selection tool and Pen tool Edit the path on which the animated object travels.

•

Timing panel Determine the order in which objects on a page are animated.

•

Preview panel View the animation in an InDesign panel.

Page title drops in
from the top

Automobile moves in
from the right and
stops

Figure 11 Examples of animation options
For more detailed information about how to use animation in InDesign, refer to InDesign Help.
Animating a document with motion presets

Motion presets are pre-made animations that you can apply to objects quickly. Use the Animation panel to apply
motion presets and change animation settings such as duration and speed. The Animation panel also lets you specify
when an animated object plays.
These motion presets are the same as those found in Adobe Flash Professional CS5. You can import any custom
motion preset created in Flash Professional, and you can save motion presets you create and edit for sharing with
others.
Note: Animation features are supported only when exporting to Adobe Flash Player (SWF). They are not supported
when exporting to Interactive PDF. To add animation effects to a PDF file, export a selection as a SWF file from
InDesign and place that SWF file in the InDesign document.
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Motion preset options

Motion preset options appear in the Animation panel (Figure 12). To display the Animation panel, choose Window >
Interactive > Animation. Click the disclosure triangle beside Properties to display advanced settings.
•

Name Specify a name for the animation. Descriptive names are especially useful when setting up an action
that triggers the animation.

•

Preset Choose from a list of predefined motion settings.

•

Event(s) By default, On Page Load is selected, which means the animated object plays when the page opens
in the SWF file. Choose On Page Click to trigger the animation when readers click the page. Choose On
Click (Self) or On Roll Over (Self) to trigger the animation when readers click the object or move the mouse
over it. If you create a button action that triggers the animation, On Button Event is selected. You can
specify multiple events to start the animation. If you select the On Roll Over (Self) event, you can also select
Reverse On Roll Off. This option reverses the action of the animation when the mouse moves off the object.

•

Create Button Trigger Click this button to trigger the animation from an existing object or button. After you
click Create Button Trigger, click the object that triggers the animation. The object is converted to a button,
if necessary, and the Buttons panel appears.

•

Duration Specify how much time it takes for the animation to occur.

•

Play Specify the number of times the animation is played, or select Loop to cause the animation to play
repeatedly until it’s stopped.

•

Speed Choose an option to determine whether the animation speed is a steady rate (None), starts slowly and
speeds up (Ease In), or slows down at the end (Ease Out).
Animation panel menu

Preset preview

Preset menu
Events menu
Create Button Trigger
button

Animate options

Animation proxy

Figure 12 Animation panel
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The following options are available when Properties is expanded (Figure 12).
•

Animate Choose one of the following settings from the Animate menu. Each setting is illustrated in the
example (Figure 13).
◦

From Current Appearance uses the object’s current properties (scale percentage, rotation angle, and
position) as the starting point of the animation.

◦

To Current Appearance uses the object’s properties as the ending point of the animation. This option is
especially useful in slide shows. For example, objects that fly in from off the page can appear on the
page rather than on the pasteboard, improving the appearance of the printed document.

◦

To Current Location uses the current object’s properties as the starting point of the animation and the
object’s position as the ending point. This option is similar to From Current Appearance, except that the
object finishes in its current location and the motion path is offset. This option is especially useful for
certain presets, such as blurs and fades, to prevent the object from appearing in an undesirable state at
the end of the animation.
Proxy

Object and path before
animation

From Current Appearance

To Current Appearance

To Current Location

Figure 13 Animate settings
Note: To display the proxy at the end of the motion path, click the Show Animation Proxy at the bottom of
the Animation panel. A proxy is the visual representation of the object at the end of a motion path.
•

Rotate Specify a rotation angle that the object completes during the animation.

•

Origin Use the proxy to specify the origin point of the motion path on the animated object.

•

Scale Specify a percentage value to determine whether the object increases or decreases in size during
playback.

•

Opacity Choose an option to determine whether the animation remains solid (None), gradually becomes
visible (Fade In), or gradually becomes invisible (Fade Out).

•

Visibility Select Hide Until Animated or Hide After Animating to make an object invisible before or after
playback.

To animate a document with motion presets:

1. Place the object you want to animate in your document.
2. Choose Window > Interactive > Animation.
The Animation panel appears (Figure 12).
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3. Choose a motion preset from the Preset menu, such as
Fly In From Right.
A green motion path appears, indicating the start, finish,
and travel path of the object (Figure 14).
4. Specify other motion preset options such as Event(s),
Duration, Play, and Speed.

Figure 14 Motion path

5. To edit the motion path, use the Pen tool and Direct
Selection tool.
6. (Optional) If you place more than one object in the
document, use the Timing panel (Window > Interactive >
Timing) to determine the order of when animated objects
play (Figure 15).
For example, you can change one set of animations that
occur when the page is loaded, and then change another
set of animations that occur when the page is clicked.
Animated objects are listed in the order they were
created. Animations listed for the Page Load event occur
sequentially by default. Animations listed for the Page
Click event are played in sequence each time the page is
clicked.

Figure 15 Timing panel

7. Choose Window > Interactive > Preview to preview the
animation in InDesign (Figure 16).
8. If you made changes to the motion preset and you want to
save the custom preset for other uses, choose Save from
the Animation panel menu.
Note: You can also delete, duplicate, import, or export
motion presets from the Animation panel menu.
9. Type a name for the preset and click OK.

Play
preview

Clear
preview

Figure 16 Preview panel

Dynamic PDF documents
Creating a dynamic PDF document is a good way to create an interactive slide show. As with interactive SWF
documents, you can create interactive PDF documents with buttons, movies and sound clips, hyperlinks, bookmarks,
and page transitions. You can also set up documents in InDesign and convert themto forms in Acrobat.
In this guide you will learn how to create dynamic PDF documents by using InDesign. Steps include how to create a
bookmark, insert a URL link, apply a decorative page transition, and export to PDF format. Once you are familiar
with the basics, try adding movies and sound clips into your dynamic PDF document.
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Create interactive documents for PDF

You can export Adobe PDF documents that include the following interactive features.
•

Bookmarks Bookmarks you create in the InDesign document appear in the Bookmarks tab on the left side of
the Adobe Acrobat or Adobe Reader window. Each bookmark jumps to a page, text, or graphic in the
exported PDF file.

•

Movies and sound clips You can add movies and sound clips to a document, or you can link to streaming
video files on the Internet. These movies and sound clips can be played back in the exported PDF file.

•

Hyperlinks In an exported PDF document, clicking a hyperlink jumps to another location in the same
document, to a different document, or to a website. You can create hyperlinks to pages, URLs, text anchors,
e-mail addresses, and files. If you create a hyperlink to a page or text anchor in a different document, make
sure the exported files appear in the same folder.

•

Cross-references A cross-reference refers readers from one part of your document to another in the exported
PDF file. Cross-references are especially useful in user guides and reference manuals. When you export a
document with cross-references to PDF, the cross-references act as interactive hyperlinks.

•

Page transitions Page transitions apply a decorative effect, such as a dissolve or wipe, when you turn the
page in the exported PDF while in Full Screen mode.

To create an interactive document for PDF:

1. Start InDesign and choose File > New > Document.
The New Document dialog box appears.
2. When creating a document intended for printing, accept
the default Print from the Intent menu in the New
Document dialog box.

Bookmarks panel
menu

3. Enter 2 or more pages in the Number Of Pages box.

Create New
Bookmark

4. Choose Letter from the Page Size menu.

Figure 17 Bookmarks panel

5. Click OK to close the New Document dialog box.
The first step is to create a bookmark to another section
of the document.
6. Choose Window > Interactive > Bookmarks.
The Bookmarks panel appears (Figure 17).
7. Select text in your document.
By default, the text you select becomes the bookmark
label.
8. Do one of the following to create the bookmark:
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•

Click the Create New Bookmark button in the
Bookmarks panel.

•

Choose New Bookmark from the panel menu.
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9. Accept the default bookmark name, or rename the
bookmark.
Bookmarks appear in the Bookmarks navigation pane
when you open the exported PDF file in Adobe Reader or
Acrobat.
Note: You can use the Bookmarks panel menu to rename
and delete bookmarks. Drag bookmarks in the panel to
rearrange. You can nest a list of bookmarks to show a
relationship between topics. Nesting creates a parent/
child relationship. You can expand and collapse this
hierarchical list as desired. Changing the order or nesting
order of bookmarks does not affect the appearance of
your actual document.

Hyperlinks panel
menu

Create New
Hyperlink

Figure 18 Hyperlinks panel

Next, you will create a hyperlink that takes you to an
external website destination.
10. Choose Window > Interactive > Hyperlinks.
The Hyperlinks panel appears (Figure 18).
11. Select the text, frame, or graphic you want to be the
hyperlink’s source.
12. Do one of the following to create the hyperlink:
•

Click the Create New Hyperlink button in the
Hyperlinks panel.

•

Choose New Hyperlink in the Hyperlinks panel
menu.

Figure 19 New Hyperlink dialog box

The New Hyperlink dialog box appears (Figure 19).
Note: Use the Hyperlinks panel menu to edit, delete,
reset, or locate hyperlinks.
13. Choose URL from the Link To menu.
14. In the URL text field, type or paste the destination URL
for the hyperlink.
15. Specify appearance options, such as the following:
Character Style Choose a character style to apply to the
hyperlink source. The Character Style option is available
only if the hyperlink source is selected text, not a selected
frame or graphic.
Type Select Visible Rectangle or Invisible Rectangle.
Highlight Select Invert, Outline, Inset, or None. These
options determine the appearance of the hyperlink when
readers click it in the PDF file.
Color Select a color for the visible hyperlink rectangle.
Width Select Thin, Medium, or Thick to determine the
thickness of the hyperlink rectangle.
Style Select Solid or Dashed to determine the appearance
of the hyperlink rectangle.
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16. Click OK.
Note: If a URL hyperlink isn’t working in the exported
PDF, the problem may be that the hyperlink is a shared
destination. Double-click the hyperlink in the Hyperlinks
panel, choose URL from the Link To menu, deselect
Shared Hyperlink Destination, and click OK.
17. Choose File > Export.
18. Specify a name and location for the file.
19. For Save As Type (Windows) or Format (Mac OS),
choose Adobe PDF (Interactive).
20. Click Save.
The Export To Interactive PDF dialog box appears
(Figure 20).
21. Select the Open In Full Screen Mode option to ensure the
interactive PDF fills the entire screen when it opens.

Figure 20 Export to Interactive PDF dialog box

22. Click OK.
The Generating PDF progress dialog box appears and the
file is processed.
The file opens in your default application for PDF files.
Note: If you are asked whether you want to view the
document in Full Screen mode, click Yes.
23. Click anywhere in the PDF document to advance to the
next page.
24. Test the hyperlinks you created (Figure 21).
Note: If you receive a warning that the document is
trying to connect to a website, click Allow.

Figure 21 Testing hyperlinks in Acrobat

25. Close Full Screen mode by pressing Ctrl+L (Windows)
or Command+L (Mac OS) or Esc.
26. To display the navigation pane in Adobe Acrobat or
Adobe Reader, do one of the following:
•

Click any panel button on the left side of the work
area to display that panel.

•

Choose View > Navigation Panels > Show
Navigation Pane.

27. Test the bookmarks you created (Figure 22).
Figure 22 Bookmarks in the navigation pane in
Acrobat
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