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Overview of the Adobe Flash Professional CS5 
workspace

Stage

The Stage is the white, rectangular area of the Adobe Flash Professional CS5 workspace (Figure 1). Objects you 
place on the Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the 
Stage) will not appear in the finished movie, but you can place objects there until you want them to appear on the 
Stage.

Figure 1 Flash workspace
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Timeline and layers

The Timeline is where you control the images and sounds in your Flash document (Figure 2). The Timeline is divided 
into frames. In the Timeline, you work with these frames to organize and control the content of your document. You 
place frames in the Timeline in the order you want the objects in the frames to appear in your finished content.

A keyframe is a frame where a new symbol instance appears in the Timeline. A keyframe can also be a frame that 
includes ActionScript code to control some aspect of your document. You can also add a blank keyframe to the 
Timeline as a placeholder for symbols you plan to add later or to explicitly leave the frame blank.

A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between property keyframes to produce fluid animations. Because 
property keyframes let you produce animation without drawing each individual frame, they make creating animation 
easier. A series of frames containing tweened animation is called a motion tween.

Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline. The playhead, represented by 
a red rectangle with a long red line, shows the current frame you are viewing on the Timeline. You can click a frame 
to move the playhead to that frame, or you can drag the playhead back and forth on the Timeline to quickly view all 
or any part of your animation.

Layers in the Timeline provide a way to organize the elements of your movie. You can draw and edit objects on one 
layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves from 
top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the layer 
name to a new position. The layer controls appear on the left side of the Timeline. Each layer has an option for hiding 
or showing the layer, locking it, and displaying its contents as outlines.

Figure 2 Timeline
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Edit bar

The edit bar, at the top of the Stage, lets you quickly navigate between different parts of your Flash document 
(Figure 3). It lets you switch between scenes and symbols. You can also change the magnification level of the Stage. 

Figure 3 Edit bar

Panels

Panels provide easy access to controls that help you work 
with the content in your document (Figure 4). By default, the 
Property inspector and the Library panel are docked to the 
right side of the workspace. Any available panel can be 
opened by selecting it in the Window menu.

You can undock panel groups, add panels to a group, undock 
individual panels, rearrange the order of docked panels, and 
collapse and close panel groups. To undock a panel, drag it by 
its tab or title bar away from its current position. You can drag 
it into another dock or make it free-floating.

Figure 4 Panels
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Tools panel

The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 5). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.)

Figure 5 Flash Tools panel
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Selection tools

Selection tool (black arrow): Click an object to select it. Drag a selected object to move it.

Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points.

Free Transform tool: Resize or rotate selected objects by dragging. Also has the Gradient Transform tool (transform a 
gradient or bitmap fill by adjusting the size, direction, or center of the fill).

3D Rotation tool: Rotate movie clip instances in 3D space. A 3D rotation control appears on top of selected objects 
on the Stage. The X control is red, the Y control is green, and the Z control is blue. 

3D Translation tool: Move movie clip instances in 3D space. When you select a movie clip with the tool, its three 
axes, X, Y, and Z, appear on the Stage on top of the object. The X axis is red, the Y axis is green, and the Z axis is 
blue.

Lasso tool: Drag to select an area.

Drawing tools

Pen tool: Create straight or curved lines. You can also create Bezier curves.

Text tool: Create or edit text and text fields.

Line tool: Draw straight lines.

Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Also has the 
PolyStar tool (create either polygon or star shapes—you can set how many points both shapes have), the Oval tool 
(create circles and ovals), the Rectangle Primitive tool, and the Oval Primitive tool. Primitive shapes are individual 
objects that can be edited in the Property inspector.

Pencil tool: Create lines in any of three modes—straighten, smooth, or ink.

Brush tool: Create shapes with fills only.

Spray Brush tool: The Spray Brush acts like a particle sprayer, letting you “brush” a pattern of shapes onto the Stage 
at one time. By default, the Spray Brush emits a spray of dot particles using the currently selected fill color. However, 
you can use the Spray Brush tool to apply a movie clip or graphic symbol as a pattern.

Deco Drawing tool: Apply an effect to a selected object. Choose effects from the Property inspector after you select 
the Deco Drawing tool.

Bone tool: Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other using 
an articulated structure of bones. This tool allows you to add bones to a set of objects in relation to each other.

Bind tool: Inverse kinematics tool that allows you to click a control point or a bone with this Bind tool and display the 
connections between the bones and control points. You can then change the connections in a variety of ways.

Paint Bucket tool: Add fill inside a shape or change the fill color.

Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape.

Eyedropper tool: Sample a color from swatches or anywhere on the screen.

Eraser tool: Erase parts of an image.

View tools

Hand tool: Drag the Stage to view another part of your document.

Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS).
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Color tools

Stroke Color: Set the stroke color.

Fill Color: Set the fill color.

Property inspector

The Property inspector provides easy access to the most commonly used attributes of the current selection, either on 
the Stage or in the Timeline. You can make changes to the object or document attributes in the Property inspector 
without accessing the menus or panels that also control these attributes.

Depending on what is currently selected, the Property inspector displays information and settings for the current 
document, text, symbol, shape, bitmap, video, group, frame, or tool. When two or more different types of objects are 
selected, the Property inspector displays the total number of objects selected. By default, the Property inspector is 
visible; you can hide or show it by selecting Window > Properties. The illustrations (Figure 6) show the properties 
for a text object and a rectangle shape, respectively.

Figure 6 Property inspector for text (left) and for rectangle (right)
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Arranging the Flash workspace

You can create a custom workspace by moving and manipulating panels, such as adding, removing, docking, 
grouping, or collapsing them. You can save these custom workspaces and switch among them. Flash provides several 
preset workspaces, arranged for particular tasks or types of users.

To switch between workspaces:

1. Start Flash and choose File > New (ActionScript 3.0). 

An empty Flash document opens.

2. Select a preset workspace in the workspace switcher 
menu (Figure 7), such as the Designer workspace.

The panels are rearranged.

Figure 7 Workspace switcher

To create a custom workspace:

1. Start Flash and choose File > New (ActionScript 3.0). 

An empty Flash document opens.

2. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.

3. Choose Window > Workspace > New Workspace (or 
choose New Workspace in the workspace switcher)..

The New Workspace dialog box opens (Figure 8).

4. Enter a name for the new workspace.

5. Click OK.

The workspace is now available through the workspace 
switcher.

Figure 8 New Workspace dialog box
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Frames and keyframes
Like films, Adobe Flash Professional CS5 documents divide lengths of time into frames. In the Timeline, you work 
with these frames to organize and control the content of your document. You place frames in the Timeline in the order 
you want the objects in the frames to appear in your finished content. 

Frames define increments on the Timeline (Figure 1). The order in which frames appear on the Timeline determines 
the order in which they appear when a Flash document plays. You can arrange keyframes on the Timeline to edit the 
sequence of events in an animation.

A keyframe is a frame where a new symbol instance appears in the Timeline. A keyframe can also be a frame that 
includes ActionScript code to control some aspect of your document. You can also add a blank keyframe to the 
Timeline as a placeholder for symbols you plan to add later or to explicitly leave the frame blank.

A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between the property keyframes in order to produce fluid 
animations. Because property keyframes let you produce animation without drawing each individual frame, they 
make creating animation easier. A series of frames containing tweened animation is called a motion tween.

A tweened frame is any frame that is part of a tween.

A static frame is any frame that is not part of a tween.

You arrange keyframes and property keyframes in the Timeline to control the sequence of events in your document 
and its animation.

A keyframe is indicated on the Timeline with a solid black circle. The frame where a keyframe span ends has a small 
white rectangle. A blank keyframe is indicated by an empty circle.

Figure 1 Frames

You can do the following with frames or keyframes:

• Insert frames, keyframes, and blank keyframes.

• Remove frames, keyframes, and blank keyframes.

• Convert frames to keyframes or blank keyframes.

• Drag frames and keyframes to a new location on the same layer or on a different layer.

• Copy and paste frames and keyframes.
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Representing animations in the Timeline

Flash distinguishes tweened animation from frame-by-frame animation in the Timeline by displaying different 
indicators in each frame that contains content. The following frame content indicators appear in the Timeline:

• A span of frames with a blue background indicates a motion tween. A black dot in the first frame of the span 
indicates that the tween span has a target object assigned to it. Black diamonds indicate the last frame and any 
other property keyframes. Property keyframes are frames that contain property changes explicitly defined by 
you. By default, Flash displays all types of property keyframes. All other frames in the span are interpolated by 
Flash depending on the properties changed in these keyframes. A ball that moves across the Stage, for example, 
might have an initial keyframe that positions it on the left of the Stage, and another keyframe that positions it on 
the right. All other positions of the ball—moving from left to right—are interpolated in the frames between the 
two keyframes . 

• A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween 
span still contains its property keyframes and can have a new target object applied to it.

• A span of frames with a green background indicates an inverse kinematics (IK) pose layer. Pose layers contain 
IK armatures and poses. Each pose appears in the Timeline as a black diamond. Flash interpolates the positions 
of the armature in the frames between poses.

• A black dot at the beginning keyframe, with a black arrow and blue background, indicates a classic tween.

• A dashed line indicates that the classic tween is broken or incomplete, such as when the final keyframe is 
missing.

• A black dot at the beginning keyframe with a black arrow and a light green background indicates a shape tween.

• A black dot indicates a single keyframe. Light gray frames after a single keyframe contain the same content with 
no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the span.

• A small a indicates that the frame is assigned a frame action with the Actions panel. 

• A red flag indicates that the frame contains a label.

• A green double slash indicates that the frame contains a comment.

• A gold anchor indicates that the frame is a named anchor.
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How to get started with ActionScript
ActionScript 3.0 is the scripting language of Adobe Flash Professional CS5. You can use ActionScript to add 
complex interactivity, playback control, and data display to your application. For example, you might want to animate 
a picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture.

ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects.

You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help:

• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use classes to 
create objects.

• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what class it 
is created from and set its properties. You can create as many objects as you want from a single class—if you 
have a bicycle class, you can create many bicycle objects, each with its own properties (one bicycle might be red 
while another might be green).

• Property: One of the pieces of data bundled together in an object. A property helps define an object—it provides 
the object’s characteristics. A song object might have properties named melody and title. You set the properties 
of an object when you create the object, but you can change them later as needed. A property is a variable that 
belongs to an object.

• Variable: A name that represents a value in the computer’s memory. As you write code, you write the variable’s 
name as a placeholder for the value. This allows you to write code even if you don’t know all the possible values 
a visitor might provide. If you create a variable firstName, you can tell your program to display the visitor’s first 
name without knowing in advance what the visitor’s first name is.

• Method: An action that can be performed by an object. For example, the class horse might have a method called 
gallop(). When the method gallop() is called, it shows an animation of the horse galloping from one point to 
another.

• Function: A block of code that carries out specific tasks and can be reused in your program. For example, you 
might create a function called checkEmail() to verify that text typed by a visitor is a valid e-mail address. Each 
time a visitor provides an e-mail address, you can call checkEmail() to make sure the visitor has provided text 
that can actually be used as an e-mail address. If you ever want to update the function, you only have to do it 
once instead of in each place where e-mail addresses must be validated. You can also think of a method as a 
function attached to an object.

• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many events 
are related to user interaction—for example, a user clicking a button or pressing a key on the keyboard. The 
technique for specifying certain actions that should be performed in response to particular events is known as 
event handling.

If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the Movie Clip class.

You can modify various characteristics of any movie clip. When a movie clip is selected, the Property inspector 
shows some of the characteristics you can change, such as its X coordinate or its width. Or you can make color 
adjustments such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as 
using the Free Transform tool to rotate the rectangle. All of the ways you can modify a movie clip symbol in the Flash 
authoring environment are also things you can do in ActionScript. In ActionScript, you use the methods of the 
MovieClip class to manipulate or change the properties of your movie clip.
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help).

Using Script Assist mode

You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Actions panel 
provides Script Assist mode to simplify the coding process.

Figure 1 Actions panel in Script Assist mode

In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode.

One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie.

Actions toolbox

Script navigator
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Script Assist 
button

Script pane
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To use ActionScript to stop a movie:

1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe.

2. If the keyframe is not selected, select it by clicking it.

3. Select Window > Actions to display the Actions panel.

4. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button in the upper-right corner 
(Figure 2).

Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your timeline is 
the movie clip), so you must locate the Movie Clip class. 
The Movie Clip class is part of the Flash.Display 
package.

5. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package to 
display the classes it contains.

6. Scroll down again to find the Movie Clip class and click 
to expand it (Figure 3).

7. Click Methods to view the methods available for the 
Movie Clip class.

Figure 2 Actions panel

Figure 3 Movie Clip class

Script Assist button



Activity 5.1 guide Adobe Flash Professional CS5

4 How to get started with ActionScript © 2010 Adobe Systems Incorporated

8. Scroll down to the Stop method. Do one of the following: 

• Double-click the Stop method.

• Drag the Stop method into the Script pane.

Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the code necessary 
for the Movie Clip class. The second line is the Stop 
action itself. The red code not_set_yet indicates you 
should use Script Assist to finish the code.

9. Click in the Object field in the parameters area of the 
Actions panel.

The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to control.

10. Click the Insert Target Path button.

The Insert Target Path dialog box appears (Figure 5).

11. Select the Relative option and click Root.

This sets the target path to this.

12. Click OK to close the Insert Target Path dialog box.

The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, frame 40.

Note: In ActionScript, this is used the same way that you 
would refer to yourself as “me” instead of using your full 
name. Remember that the main timeline is an instance of 
the MovieClip class. In Figure 6, Flash uses this to refer 
to the movie clip that frame 40 belongs to.

13. Close the Actions panel.

Figure 4 Stop method

Figure 5 Insert Target Path dialog box

Figure 6 Stop method applied to frame 40
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Event handling

The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements:

• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image?

• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events.

• The response: What action(s) do you want performed when the event happens?

When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. An event listener is a function Flash 
Player executes in response to specific events.

Adding an event listener is a two-step process:

• First, you create a function or class method for Flash Player to execute in response to the event. This function is 
sometimes called the listener function.

• Second, you use the addEventListener() method to connect the listener function with the target of the event. The 
addEventListener() function tells Flash what object to listen to, what event to listen for, and what function to 
execute in response.

To use ActionScript to go to another frame:

1. Create a button users can click to go to a particular frame 
in your movie. Make sure you place the button on the 
Stage (Figure 7).

2. Select the button and use the Property inspector to give 
the button a unique instance name (Figure 8).

3. In the main timeline of your movie, create a layer named 
actions.

4. Create a keyframe in the actions layer that corresponds to 
the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer.

Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet.

5. Select Window > Actions to display the Actions panel.

6. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.

7. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Events package to 
display the classes it contains.

8. Scroll down to the IEventDispatcher class and click it to 
open it.

9. Click Methods to display methods for the 
IEventDispatcher class.

Figure 7 Button instance

Figure 8 Button instance

Instance name
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10. .Double-click the AddEventListener method to add it to 
the Script pane (Figure 9).

11. Click in the Object field in the parameters area of the 
Actions panel.

The Insert Target Path button is now active.

12. Click the Insert Target Path button.

The Insert Target Path dialog box appears (Figure 10).

13. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.

The event listener is attached to the instance of your 
button (Figure 11). 

Next, you select an event to listen for.
Figure 9 AddEventListener method in the Actions 
toolbox

Figure 10 Insert Target Path dialog box

Figure 11 Event listener code in the Script pane
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14. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class 
(Figure 12).

To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties.

15. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field.

16. In the Actions toolbox, double-click the CLICK property.

Script Assist adds the property to your code as  
MouseEvent.CLICK (Figure 13).

Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function.

17. In the parameters area, type a name for your function in 
the Listener field, such as startMovie. You can use any 
name you like, but make sure the name of the function is 
unique and contains no spaces (Figure 14).

The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.

18. In the Actions toolbox, select the function keyword from 
Language Elements.

To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.

19. Double-click the function keyword in the Actions 
toolbox.

The code for creating a function appears in the Script 
pane (Figure 15).

20. In the parameters area of the Script pane, type the name 
of your function in the Name field.

Note: The function name must be typed exactly as you 
typed it for the AddEventListener function in step 17. 
Function names are case-sensitive.

21. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field.

In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

Figure 12 CLICK property in the Actions toolbox

Figure 13 CLICK property in the Script pane

Figure 14 Function name in the Listener field

Figure 15 Function code
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22. In the parameters area of the Script pane, select Void 
from the Type pop-up menu.

Some functions return a value when called. The keyword 
void indicates that this function does not return a value.

Now you can tell the function what you want it to do 
when the CLICK event occurs.

23. In the Actions toolbox on the left side of the panel, select 
the GotoAndPlay method for the Flash.Display class 
(Figure 16).

To find the GotoAndPlay method, expand Flash.Display, 
and then expand MovieClip.

24. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox.

The method is added to the function (Figure 17).

25. Click in the Object field in the parameters area of the 
Actions Panel.

The Insert Target Path button is now active.

26. Click the Insert Target Path button to display the Insert 
Target Path dialog box.

27. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this.

28. Click OK to close the Insert Target Path dialog box.

29. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame.

30. Close the Actions panel.

31. Save the movie.

32. Select Control > Test Movie > In Flash Professional to 
test the movie.

33. Select File > Close to close the preview window.

Figure 16 GotoAndPlay method

Figure 17 GotoAndPlay method in the Script pane

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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Using code snippets

The Code Snippets panel lets you start using simple ActionScript 3.0 very quickly, without knowledge of 
programming or ActionScript 3.0.. It lets you add ActionScript 3.0 code to your Flash file to enable common 
functionality. Some of the code snippets you might use include the following:

• Drag And Drop. Lets viewers drag the symbol around the Stage.

• Move With Keyboard Arrows. Lets viewers move the symbol with the keyboard arrows.

• Click To Go To Frame And Stop. Moves the Playhead to a specific frame and stops the playhead when viewers 
click the symbol.

• Click To Play/Stop Sound. Plays a sound when viewers click the symbol.

Adding a code snippet to a movie clip symbol instance

You can add code snippets to movie clip symbol instances. Symbols are stored in the library. Whenever you place a 
symbol on the Stage, you are actually placing an instance of the symbol on the Stage. For ActionScript to act on a 
symbol instance, you must give the instance a name.

To add a code snippet to a movie clip symbol instance:

1. Draw an object on the Stage, such as an oval.

2. Convert the object to a Movie Clip symbol.

3. With the object selected, open the Properity inspector. 

4. In the Instance Name text box, enter a name for the 
symbol instance (Figure 18). 

5. Select Windows > Code Snippets.

The Code Snippets panel opens (Figure 19).

6. With the movie clip instance still selected, double-click 
the Animation folder in the Code Snippets panel.

Figure 18 Property inspector.

Figure 19 Code Snippets panel
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7. Double-click the Move With Keyboard Arrows code 
snippet.

The ActionScript panel opens showing the ActionScript 
in the code snippet (Figure 20).

The Move With Keyboard Arrows code snippet is a 
snippet of ActionScript that lets viewers move the movie 
clip with the keyboard arrows when the movie runs. For 
information on other code snippets, see Flash Help.

8. After looking at the ActionsScript added, close the 
ActionScript window.

9. Test the movie. Observe that the object moves with the 
keyboard arrows. Figure 20 The ActionScript window with the 

Move With Keyboard Arrows code snippet
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How to create an animated face
This activity walks you step by step through the process of creating a simple animation by using Adobe Flash 
Professional CS5. You use drawing tools and implement motion and shape tweens. After you test your movie, you 
publish it for playback by others, either through a browser or directly with Flash Player.

Drawing facial features

You begin by drawing the right eye. You will then save the right eye as a symbol and make a copy of it to create the 
left eye.

To draw the right eye:

1. Start Flash and choose File > New.

2. In the New Document dialog box, choose ActionScript 
3.0 (Figure 1).

Note: ActionScript 3.0 refers to the publish settings for 
the Flash file. This setting works with most recent 
version of the Flash player.You can change these settings 
using the Publish Settings dialogbox (choose File > 
Publish Settings).

The new document contains one layer and one empty 
keyframe.

3. Choose Modify > Document.

The Document Settings dialog box opens.

4. Change the frame rate to 12 and click Make Default.

The animation will now play at 12 frames per second. 
This frame rate is easier to work with for beginning 
animators.

5. Select Classic from the workspace switcher (Figure 2).

The Timeline appears at the top of the workspace.

6. Select the Oval tool and draw a small circle to represent 
the right eye on a face (Figure 3).

To draw a perfect circle, hold down Shift as you drag the 
Oval tool on the Stage.

Note: Make sure Stroke is set to at least 1.0 in the Fill 
And Stroke section of the Property inspector.

7. Select the Selection tool and double-click the circle’s 
center to select it. You should see both its outline (stroke) 
and center (fill) selected.

Figure 1 New Document dialog box

Figure 2 Flash workspace switcher

Figure 3 Right eye drawn with Oval tool

Oval tool
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8. To change the outline color of the eye, click the Stroke 
Color box in the Property inspector and select a new 
color (Figure 4). To change the fill color, use the Fill 
Color box.

9. On the Timeline, double-click the layer name, Layer 1 
(Figure 5).

This selects the layer name so you can rename it.

10. Rename the layer Right Eye and press Enter (Windows) 
or Return (Mac OS) (Figure 6).

Figure 4 Image Property inspector

Figure 5 Layer name selected

Figure 6 New layer name

Stroke color

Fill color
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Converting the eye to a symbol

Instead of creating two eyes separately,  you will convert the right eye from a shape to a graphic symbol. This adds 
the eye to the library so you can use it over and over. This will also reduce the size of your finished movie because 
the symbol is only stored once.

To save the eye graphic as a symbol:

1. Continue from the previous steps.

2. On the Right Eye layer, click frame 1 to select it 
(Figure 7).

This automatically selects the contents of frame 1.

Note: If the right eye is not completely selected, 
double-click the eye on the Stage with the Selection 
tool to select it.

3. Select Modify > Convert To Symbol.

The Convert To Symbol dialog box opens (Figure 8).

4. In the dialog box,  name the symbol eye, select Graphic 
as the behavior, and click OK.

The eye on the Stage is now just an instance (copy) of 
the master eye symbol, which is stored in the library. 
The eye now has a single blue selection border 
(Figure 9) and can be selected with a single click.

5. Select Window > Library to see that your symbol has 
been added to the Library panel (Figure 10).

Note: You must select the eye symbol in the library to 
see the graphic in the preview window.

You can now reuse the eye symbol as many times as 
you want without redrawing it.

Figure 7 Frame 1 selected

Figure 8 Convert To Symbol dialog box

Figure 9 Graphic symbol selected

Figure 10 Symbol in Library panel
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To reuse the eye symbol to create the left eye:

1. Continue from the previous steps.

2. Click the New Layer button in the lower left corner of the 
Timeline to insert a new layer (Figure 11).

3. Double-click the layer name and change the name to Left 
Eye.

4. On the Left Eye layer, select frame 1.

5. Select the eye symbol in the Library panel and drag the 
symbol onto the Stage.

You now have a second instance of the eye on the Stage. 
Using instances from the library keeps the file size of 
your movie smaller than copying and pasting. Smaller 
movies load faster in a browser.

Figure 11 New Layer button

To draw the nose:

1. Continue from the previous steps.

2. Insert a new layer and name it Nose.

3. Select frame 1 on the Nose layer.

4. Select the Line tool and draw two lines that form an angle 
to represent a nose (Figure 12).

5. To adjust the angle after you’ve drawn it, use the 
Subselection tool (white arrow) to drag the corner or one 
end of the line. (You might try dragging one end of a line 
with the Arrow tool to see the difference between the two 
tools.)

Figure 12 Draw nose

New Layer button
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Adding frames to make a three-second movie

A Flash movie typically plays 12 frames per second. To keep the nose on the Stage for 3 seconds, for example, you 
need to insert 36 additional frames on the Nose layer after frame 1, the current frame. (Starting at frame 1, it will take 
the movie 3 seconds to reach frame 37, because 1 + 36 = 37.)

To add frames:

1. Continue from the previous steps.

2. Select frame 37 on the Nose layer and select Insert > 
Timeline > Frame. 

Flash inserts frames through frame 37 (Figure 13). 

Observe that the playhead (the red rectangle at the top of 
the Timeline) is on frame 37 and that the nose is visible 
but the eyes have disappeared. At the bottom of the 
Timeline, you can see that this movie is currently 37 
frames, is set to play at 12 frames per second, and will 
play for 3 seconds.

Note: The keyboard shortcut for inserting a frame is F5. 

3. Drag the playhead to various frames.

The nose remains visible in frames 1 through 37, but the 
eyes appear only in frame 1.

4. To see your movie, drag the playhead to frame 1 and then 
select Control > Play.

At this point, not much is happening beyond frame 1.

Figure 13 Frame inserted in Timeline

Drawing the mouth

To draw the mouth, you first draw a line and then bend the line by using the Selection tool.

To draw the mouth:

1. Continue from the previous steps.

2. Insert a new layer and name it Mouth.

3. Select frame 1 of the Mouth layer.

4. Draw a mouth in frame 1.

• Use the Line tool to draw a straight line (Figure 14). 

• Select the Selection tool and click on the Stage away 
from the line to deselect it. 

• Move the pointer toward the middle of the line. 
When a curve appears next to the pointer, drag the 
middle of the line downward to create a smile 
(Figure 15). 

• When you release the mouse button, only the smile 
remains (Figure 16).

Figure 14 Mouth as straight line 

Figure 15 Drag line with Arrow tool

Figure 16 Mouth complete
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Animating the facial features

To animate the facial features, you will use tweens. With tweens, you cause objects to change over time by using the 
Timeline.

Animating the eyes

To use motion tweens to animate the eyes:

1. Continue from the previous steps.

2. On the Right Eye layer, select frame 37 and select Insert 
> Timeline > Frame (Figure 17). 

3. With the Right Eye layer selected, choose Insert > 
Motion Tween.

4. Select frame 37 on the Right Eye layer and drag the right 
eye a short distance. 

A motion path appears on the Stage showing the path 
from the position in the first frame of the tween span to 
the new position (Figure 18). Because you explicitly 
defined the X and Y properties of the object, property 
keyframes are added for X and Y in the frame containing 
the playhead. Property keyframes appear as small 
diamonds in the tween span on the timeline.

5. Position the playhead on frame 1 and select Control > 
Play to play your movie and see the effect of the motion 
tween.

The right eye gradually moves from its original position 
in frame 1 to the new position in frame 37. Notice that 
only the right eye moves.

Note: If you want to change the motion, move only the 
symbol in keyframe 37.

6. Choose frame 37 on the Left Eye layer and select Insert > 
Timeline > Frame. 

7. With the Right Eye layer selected, choose Insert > 
Motion Tween. In frame 37 move the left eye the same 
distance as the right eye.

Figure 17 Tween span in the Timeline panel

Figure 18 Tweened object with a motion path
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Animating the mouth

Because you created the mouth by using one of the drawing tools (the Line tool) and have not converted the mouth to 
a symbol, it is still a shape. You can use a shape tween to animate the mouth.

To use a shape tween to animate the mouth:

1. Continue from the previous steps.

2. Select frame 37 on the Mouth layer and insert a 
keyframe.

3. With the Selection tool, click on the Stage away from the 
mouth line to deselect it. Then drag the mouth line into a 
bigger smile.

4. To create a shape tween between the first and last frames 
on the Mouth layer, click a frame between frames 1 and 
37, and select Insert > Shape Tween.

The frames containing the shape tween are now light 
green and contain a solid arrow running from the start 
frame to the end frame (Figure 19). 

5. Select File > Save.

6. Select Control > Test Movie > In Flash Professional to 
see it play.

Selecting Control > Test Movie exports a .swf file and 
plays it in a preview window. When the movie reaches 
the last frame, it loops back to frame 1 and plays again.

7. Select File > Close to close the preview window.

Figure 19 Shape Tween on the Mouth layer

Create any additional animated facial features as you choose.
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Publishing your movie

When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can choose to 
publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to display 
them in a browser window.

When you publish HTML with your movie, Flash also creates a file called AC_OETags.js. This JavaScript file lets 
your SWF file play automatically in certain browsers (called active content-compliant browsers) that would 
otherwise require a site visitor to click to play your movie. To avoid this problem, upload AC_OETags.js to your site 
in the same location as the HTML file that hosts the movie. For more about this issue, visit www.adobe.com/go/
activecontent.

To publish your movie:

1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 20).

2. Use the Formats tab to determine which file formats to 
output when you publish.

Figure 20 Publish Settings dialog box
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3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 21). If you think your audience 
might not have the latest player, you might want to select 
an older player from the Player menu.

4. Select Generate Size Report under Advanced to see a 
detailed report of size for each asset in your movie.

5. Select Protect From Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file.

6. Select Compress Movie under SWF Settings to reduce 
the file size of the exported movie.

7. Use the HTML tab to control settings for the HTML file 
(Figure 22).

8. Deselect the Loop option if you want your movie to play 
through only one time and stop.

9. To publish your movie, click the Publish button. To save 
your settings without publishing, click OK.

Figure 21 Flash tab of Publish Settings dialog box

Figure 22 HTML tab of Publish Settings dialog 
box
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How to create animations in Flash

Overview of tweening

A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash Professional CS5 calculates the values for that property between 
those two frames. The term tween comes from the phrase in between. You can tween movie clip, graphic, and button 
symbols and text fields.

A tween span is a group of frames in the Timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the Timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the Timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called the 
target object of the tween span.

A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the Timeline from the tween span context menu.

Note:  Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from 
earlier versions of Flash. The term keyframe refers to a frame in the Timeline in which a symbol instance appears on 
the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value defined for a property at 
a specific time or frame in a motion tween.

Types of Flash Animation

Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in another 
frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for animation 
that consists of continuous motion or transformation of an object. Motion tweens appear in the Timeline as a 
contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple to 
create.

Shape tweens: Draw a shape at one frame in the Timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another.

Classic tweens: Like motion tweens but more complex to create. You can create some specific animated effects not 
possible with span-based tweens. For example, you can apply eases to the groups of frames between the keyframes 
within the tween instead of across the entire length of a motion tween span. (To ease only specific frames of a motion 
tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color effects, 
such as tint and alpha transparency, while motion tweens can apply only one color effect per tween.

Inverse kinematic poses: You can stretch and bend shape objects and link groups of symbol instances to make them 
move together in naturalistic ways. If you position the shape object or linked instances in different ways in separate 
frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make character 
animation quick and easy.

Note: You will learn more about how to use inverse kinematics poses to create character animations in Activity 5.4.

Motion tweens

You apply motion tweens only to symbol instances and text fields. All other object types are wrapped in a symbol 
when a tween is applied to them. The symbol instance can contain nested symbols, which can themselves be tweened 
on their own timelines.
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The minimal building block in a tween layer is a tween span, which can contain only one symbol instance. The 
symbol instance is called the target instance of the tween span. If you add a second symbol to the tween span, the new 
symbol replaces the original one. You can change the target object of a tween by dragging a different symbol from the 
library onto the tween span in the Timeline. You can delete the symbol from a tween layer without removing or 
breaking the tween.

To have a symbol in the Timeline, you do not have to include more than one property keyframe. You can edit 
individual property keyframes on the Stage, in the Property inspector, or in the Motion Editor.

To create a motion tween:

1. Start Flash and choose File > New (ActionScript 3.0). 

2. Draw a shape on the Stage.

The shape appears in keyframe 1 of Layer 1.

3. Using the Selection Tool (Figure 1), double-click to 
select the shape and border, if present 

4. Choose Modify > Convert To Symbol. 

The Convert To Symbol dialog box appears (Figure 2).

Note: You cannot apply motion tweens to shapes. 
Applying a motion tween to a shape automatically 
converts the shape to a symbol.

5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK (Figure 2).

6. Select  frame 10.

7. Select Insert > Timeline > Frame. (The motion tween will 
last for 10 frames.)

When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol.

8. Make sure frame 10 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.

9. Select the symbol in frame 10; then make one or more of 
the following changes:

Color change: In the Property inspector, select Tint from 
the Color Effect Style pop-up menu (Figure 4). Select 
100% for the Tint Amount and change the color in the 
Tint Color box.

Fading: In the Property inspector, select Alpha from the 
Color Effect Style pop-up menu. Reduce the percentage 
of the Alpha Amount for more transparency. For 
example, an Alpha value of 0% makes the object 
disappear.

Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable.

Figure 1 Tools panel with Selection tool

Figure 2 Convert To Symbol dialog box

Figure 3 Inserted frame

Figure 4 Tint options

Selection tool
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Size: Select the object. Then select Modify > Transform > 
Free Transform. Drag the object handles to increase size, 
decrease size, or rotate the object.

10. Select frame 1 on the Timeline.

In the Timeline, the motion tween is represented by a 
solid blue background running from the start keyframe to 
the end keyframe (Figure 5).  (When you inserted the 
motion tween in step 7, frame 10 was converted to a 
keyframe.)

11. With frame 1 selected, adjust one or more properties of 
the motion tween in the Property inspector (Figure 6).

• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes an 
object begin tweening quickly and end slowly.

• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times.

• Path: If you add a guide layer, the object is linked to 
the path drawn on the guide layer.

• Sync Graphic Symbols option: Starts and stops the 
tweening of all objects on the Stage at the same time.

12. You can also use the Motion Editor to adjust tweens 
(Figure 7).

You can view all tween properties and their property 
keyframes in the Motion Editor. You can also add 
precision and detail to your tweens. Once you create a 
tween in the Timeline, you can control the tween in 
several different ways: 

• Add or remove property keyframes for individual 
properties.

• Move property keyframes to different frames within 
the tween.

• Add or remove filters or color effects and adjust their 
settings.

• Add different preset eases to individual properties 
and property categories.

• Create custom ease curves.

• Enable roving for individual property keyframes for 
X, Y, and Z properties. Roving allows the property 
keyframe to move to different frames or between 
individual frames to create smooth motion.

Figure 5 Motion tween in the Timeline

Figure 6 Tween Property inspector

Figure 7 Motion Editor
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13. Select Control > Test Movie > In Flash Professional to 
test the movie.

14. Select File > Close to close the preview window.

15. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline 
(Figure 8).

16. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the Timeline) 
to span the frames in which the object appears.

All the intermediate steps of the tween are visible on the 
Stage (Figure 9).

17. Turn off onion skinning by clicking the Onion Skin  
button again..

18. Save the movie.

Figure 8 Onion Skin buttonl

Figure 9 Onion skinning visible

Shape tweens

In shape tweening, you draw a vector shape at one specific frame in the Timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another.

Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment 
with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the 
beginning shape should correspond to specific points on the end shape. Shape tweens can use much more computer 
memory than motion tweens, so it is best to use shape tweens sparingly.

Onion Skin button
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To create a shape tween:

1. Start Flash and choose File > New. 

2. Select ActionScripot 3.0 and click OK.

Frame 1 in Layer 1 already contains a blank keyframe.

3. Begin by adding a shape to the Stage:

Drawn objects: Select a shape tool (rectangle or oval) 
and draw an object on the Stage.

Text: Select the Text tool and type a word or phrase on the 
Stage. Then select the text and select Modify > Break 
Apart. This breaks the words into separate letters. With 
the letters still selected, select Modify > Break Apart 
again to convert the letters into shapes.

Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a bitmap, 
select Modify > Break Apart. To ungroup an image, 
select Modify > Ungroup.

Note: You might need to select Modify > Break Apart or 
Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Property inspector.

4. Select frame 10.

5. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames.

6. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape:

Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge. Drag the edge to 
change the shape of the object (Figure 10).

Different shape: To morph between your original shape 
and a new shape, delete the object in keyframe 10 and 
draw a new object.

Note: Select Modify > Break Apart if the drawn object is 
not a shape.

Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text on 
the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Property inspector.

Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape,  as indicated in the Property inspector.

Figure 10 Changing a shape with the Selection tool
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7. Click anywhere inside the tween span on the Timeline 
(Figure 11) and select Insert > Shape Tween.

8. Select frame 1 on the Timeline (on the current layer).

This is the start frame for your animation.

9. In the Tweening section of the Property inspector, adjust 
one or more properties of the Shape tween (Figure 12):

Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly.

Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular.

Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes.

10. Select Control > Test Movie to test the movie.

11. Select File > Close to close the preview window.

12. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline.

13. Drag the frame handles (they appear as brackets with 
circles on them at the top of the Timeline) to span the first 
10 frames of Layer 1.

The steps of the tween are all visible on the Stage.

14. Turn off onion skinning by clicking the Onion Skin 
button again.

15. Save the movie.

16. Close the movie.

Figure 11 Click inside the tween span

Classic tweens

In classic tween animation, you define keyframes at significant points in the animation and Flash creates the contents 
of frames between. The interpolated frames of a tweened animation appear as light blue with an arrow drawn between 
keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at those points in the 
artwork where something changes.

Classic tweens are similar to motion tweens, except they are more complex and you can create certain types of 
animated effects not possible with motion tweens, as in the following:

• Work with Timeline effects

• Add an animation to instances, groups, or types

• Create tween motion along a path

• Paste motion tween properties

• Apply custom ease-in/ease-out settings

Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Unit 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening.
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To create a classic tween:

1. Start Flash and choose File > New. 

2. Select ActionScripot 3.0 and click OK.

Frame 1 in Layer 1 already contains a blank keyframe.

3. Begin by adding a symbol to the Stage.

4. Select frame 10.

5. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames (Figure 13).

6. Make sure frame 10 is still selected and move the symbol 
to a new position on the Stage.

7. Click on the tween span on the Timeline and select Insert 
> Classic Tween. 

The classic tween appears as light blue with an arrow 
(Figure 14).

8. Select frame 1 on the Timeline (on the current layer).

This is the start frame for the animation.

9. Adjust the position, color, or scale of the symbol in the 
starting keyframe.

10. Select frame 10, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.

You can also adjust the properties of the symbol in the 
tweening section of the Property inspector.

11. Select Control > Test Movie to test the movie.

12. Select File > Close to close the preview window.

13. Save the movie.

14. Close the movie.

Figure 13 Insert keyframe

Figure 14 Insert classic tween
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How to create character animations

Inverse Kinematic Poses

Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other using an 
articulated structure of bones. Bones allow symbol instances and shape objects to move in complex and naturalistic 
ways with a minimum of design effort. For example, inverse kinematics lets you create character animation, such as 
arms, legs, and facial expressions much more easily.

You can add bones to separate symbol instances or to the interior of a single shape. When one bone moves, the other 
connected bones move in relation to the bone that initiated the movement. When animating using inverse kinematics 
you need only specify the start and end positions of objects. Inverse kinematics lets you create natural motion much 
more easily.
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Figure 1 A group of several symbols with IK bones attached Figure 2 A shape with an IK armature added

A chain of bones is called an armature. The bones in an armature are connected to each other in a parent-child 
hierarchy. An armature can be linear or branched. Branches of an armature that originate at the same bone are called 
siblings. 

You can use IK in Adobe Flash Professional CS5 in two ways. The first is to articulate a series of symbol instances by 
adding a single bone to each instance (Figure 1). The bones allow the chain of symbol instances to move together. 
For example, you might have a set of movie clips that each represents different parts of a human body. By linking the 
torso, upper arm, lower arm, and hand together, you can create a realistically moving arm. You can create a branched 
armature to include both arms, both legs, and the head.

The second way to use IK is to add an armature to the interior of a shape object (Figure 2). The shape can be created 
in merge drawing mode or object drawing mode. The bones allow you to move and animate parts of the shape 
without the need to draw different versions of the shape or create a shape tween. For example, you could add bones to 
a simple drawing of a snake to enable the snake to move and curve realistically. 

When you add bones to symbol instances or shapes, Flash moves the instance or shape and the associated armature to 
a new layer in the Timeline. This new layer is called a pose layer. Each pose layer can contain only one armature and 
its associated instances or shape.

Flash includes two tools for working with IK. You add bones to symbol instances and shapes with the Bone tool. You 
use the Bind tool to adjust the relationships between individual bones and control points of shape objects. 

You can animate armatures and their associated symbols or shapes either in the Timeline or with ActionScript 3.0. 
You animate in the Timeline by defining different poses for the armature in different frames. Flash interpolates the 
positions of the armature in the frames in between. For information about animating armatures with ActionScript, see 
the fl.ik classes in the ActionScript 3.0 Language and Components Reference. 

Note: To use inverse kinematics, your FLA file must specify ActionScript 3.0 as the Script setting in the Flash tab of 
the Publish Settings dialog box.

To add IK bones and poses:

1. Start Flash and select File > New (ActionScript 3.0) . 

2. Begin by creating and arranging on the stage multiple 
shapes in a rough spatial configuration of the object you 
wish to animate using IK.

3. Convert all of the shapes on the stage to symbol instances 
(Figure 3). 

In this example, symbols have been arranged to form a 
muscle man.

4. Select the Bone tool from the Tools panel.

You can also press the X key to select the Bone 
tool.

5. With the Bone tool, click the symbol instance 
that is to be the root or head of the armature. 
Then drag to a separate symbol instance to link 
it to the root instance.

As you drag, a bone appears. When you 
release, a solid bone exists between the two 
symbol instances. Each bone has a head (the 
round end) and a tail (the pointed end). Each 
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symbol instance can have only one attachment point. You 
can edit these attachment points later.

When dragging from one instance to another to create a 
bone, click the first instance at the specific point where 
you want to attach the bone to the instance. Release the 
mouse over the specific point on the second instance 
where you want the bone to attach. You can also edit 
these attachment points later.

The first bone in an armature is the root bone. It has a 
circle around the head of the bone.

By default, Flash moves the transformation point of each 
symbol instance to the location of the joint formed by 
each bone connection. For the root bone, the 
transformation point moves to the head of the bone. For 
the last bone in a branch, the transformation point moves 
to the tail of the bone. You can disable the automatic 
movement of the transformation point on the Drawing 
tab by selecting Edit > Preferences (Windows) or Flash > 
Preferences (Mac OS).

Figure 3 Symbol instances on the Stage
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6. To add another bone, drag from the tail of the first bone 
to the next symbol instance you want to add to the 
armature.

The pointer changes when you roll over the head or tail 
of an existing bone.

Link objects with bones in the order of the parent-child 
relationships you want to create (Figure 4).

You can move, add, delete, and edit control points of the 
contours in an IK shape by using the Subselection tool 
(Figure 5).

• To move the position of a bone without changing the 
IK shape, drag the endpoint of the bone.

• To display the control points of the IK shape 
boundary, click the stroke of the shape.

• To move a control point, drag the control point.

• To add a new control point, click a part of the stroke 
without any control points.

You can also use the Add Anchor Point tool in the Tools 
panel.

To delete an existing control point, click to select it, and 
then press the Delete key.

You can also use the Delete Anchor Point tool in the 
Tools panel.

As you add bones to instances, Flash moves each 
instance to a new layer in the Timeline. The new layer is 
called a pose layer (Figure 6). All the bones and symbol 
instances associated with a given armature reside in the 
pose layer. Each pose layer can contain only one 
armature. Flash adds the new pose layer to the Timeline 
between existing layers to maintain the previous stacking 
order of objects on the Stage.

Figure 4 Linking symbols with the Bones tool

Figure 5 Moving linked objects with the 
Subselection tool

Figure 6 Pose layer 
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You can now animate this character and keep the 
relationship between the symbols by using the bones you 
have created.

7. Insert a Pose in an Armature layer at frame 10 by right-
clicking (Windows) or Control-clicking (Mac OS) the 
frame and selecting Insert Pose (Figure 7).

8. Rearrange this pose as you like.

9. Select Control > Test Movie > In Flash Professional to 
preview the movie. 

The symbols move in relation to each other. You can fine-
tune this movement by shifting the anchor points in the 
bones.

10. Select File > Close to close the preview window.

11. Save the movie.

12. Close the movie.

Figure 7 Insert Pose

To change pose properites:

1. Click an Armature layer to select it.

2. Click a bone to select it (Figure 8).

3. Make sure the Property inspector is open (Figure 9).

4. Change one or more of the following properties:

• To enable springiness, drag the Strength and 
Damping scrubbers in the Spring section of the 
Property inspector. The higher the Strength, the more 
rigid the spring becomes. Damping determines how 
fast the spring is reduced: the higher the value, the 
faster the animation ends.

• To disable rotation of the selected bone around the 
joint, deselect the Enable option in the Joint: 
Rotation section of the Property inspector. To 
constrain rotation of a bone, drag the 
Min and Max scrubbers in the Property inspector.

• To diable translation, deselect the Enable option in 
the Joint: Translation section of the Property 
inspector. Translation refers to how the bone 
stretches as the joint moves. To limit the amount of 
motion enabled along the x or y axis, drag the 
Min and Max scrubbers in the Joint: Translation 
section of the Property inspector.

Figure 8 Bone selected

Figure 9 Bone Property inspector
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How to create a button symbol

Button symbols

Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie clips. 
The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, defines 
the active area of the button. The Timeline for a button doesn’t play like other movies; it reacts to pointer movement 
and actions by jumping to and displaying the appropriate frame.

You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools.

Create a button

You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect.

To create a button:

1. Start Adobe Flash Professional CS5 and create a new 
Flash file (ActionScript 3.0).

2. Select Insert > New Symbol.

The Create New Symbol dialog box appears (Figure 1).

3. Select Button for Type, name the button, and click OK.

You are now in symbol-editing mode and viewing a 
separate Timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2).

Each frame on the Timeline of a button symbol has a 
specific function:

• Up state: Represents the button’s appearance 
whenever the pointer is not over the button.

• Over state: Represents the button’s appearance when 
the pointer is over it.

• Down state: Represents the button’s appearance as it 
is clicked.

• Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie.

4. Make sure the Up frame is selected.

5. Use the drawing tools to create a shape for your button. 
Use the Property inspector to set the fill and stroke colors 
for the Up state of the button.

6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe.

Adding this keyframe copies the button graphic from the 
Up frame to the Over frame.

Figure 1 Create New Symbol dialog box

Figure 2 Button frames: Up, Over, Down, Hit
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7. Select the Over keyframe and use the Selection tool to 
select the button.

8. Change the fill or stroke color of the button shape.

When visitors roll over the button, the button will appear 
as you see it in the Over frame.

9. Insert keyframes in the Down and Hit frames of the layer.

This copies the button graphic from the Over frame to the 
Down and Hit frames.

10. Insert a new layer and name it Text.

11. Select the Up frame of the Text layer.

This frame already contains a keyframe.

12. Use the Text tool to type text on the button shape.

13. Use the Property inspector to adjust the font, size, and 
color of the text so it fits nicely on your button shape.

14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape.

15. Insert a keyframe in the Over frame of the Text layer.

16. Select the text and use the Property inspector to change 
some feature of the text in the Over frame, such as color.

17. Insert a keyframe in the Down frame. If you want the text 
to change appearance when the button is clicked, edit the 
appearance of the text in the Down frame.

The Timeline should now appear as it does in the 
example (Figure 3).

Now you can insert an instance (copy) of the button 
symbol into the main Timeline of your movie.

18. Click Scene 1 (Figure 4) to exit symbol-editing mode 
and return to the main Timeline.

19. Select Window > Library to display the Library panel.

The new button symbol appears in the Library panel 
(Figure 5).

Note: You must select the symbol in the library to see the 
symbol in the preview pane.

20. Drag the button symbol from the library onto the Stage.

21. Select Control > Test Movie > In Flash Professional to 
test the movie.

When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button.

22. Select File > Close to close the preview window. Then 
save your movie.

Figure 3 Button Timeline

Figure 4 Symbol-editing mode

Figure 5 Button in library
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Adding sound to a button

You can also add sounds to the button so visitors hear a sound when they interact with the button.

To add sound to a button:

1. Use the Selection tool to double-click the button.

You enter symbol-editing mode for the button.

2. Insert a new layer and name it Sound.

3. Select File > Import > Import To Library to import a 
short sound into the library. 

You can acquire royalty-free sounds from sites such as 
www.flashkit.com.

4. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound.

For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state.

5. Click the new keyframe.

6. Make sure the Property inspector is visible. (Select 
Window > Properties.)

7. In the Property inspector, select a sound file from the 
Sound pop-up menu (Figure 6).

8. Select Event in the Sync pop-up menu.

The sound will play when visitors interact with the 
button.

Figure 6 Property inspector

Sound pop-up menu
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Adding control with actions

Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript code 
to your movie.

Buttons give visitors control over the movie. You can create code for your buttons to stop the movie, stop sounds, 
restart the movie (after stopping it), or jump to different frames within the movie and begin playing. You can add 
actions to any instance of the button symbol you’ve placed in your movie.

To add control with actions:

1. Select the button instance to which you want to add an 
action. Use the Instance Name box in the Property 
inspector to give the button a unique instance name 
(Figure 7).

2. In the main Timeline of your movie, create a new layer 
named Actions.

3. Make sure there is  a keyframe in the Actions layer that 
corresponds to the keyframe where your button first 
appears on the Stage. Select this keyframe in the Actions 
layer.

Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame refers 
to an object that isn’t on the Stage yet.

4. Select Window > Actions to display the Actions panel.

5. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.

6. In the Actions toolbox on the left side of the panel, select 
the AddEventListener method for the IEventDispatcher 
class.

To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher and then 
Methods.

7. Double-click the AddEventListener method to add it to 
the Script pane (Figure 8)

8. Click in the Object box in the parameters area of the 
Actions panel.

The Insert Target Path button is now active.

9. Click the Insert Target Path button.

The Insert Target Path dialog box appears (Figure 9).

10. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.

Figure 7 Button Property inspector

Figure 8 AddEventListener method in the Actions 
toolbox

Figure 9 Insert Target Path dialog box

Instance name
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11. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class 
(Figure 10).

To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent and then Properties.

12. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type box.

13. In the Actions toolbox, double-click the CLICK property.

Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 11).

14. In the Listener box in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces.

The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.

15. In the Actions toolbox, select the function keyword from 
Language Elements. 

To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.

16. Double-click the function keyword in the Actions 
toolbox.

The code for creating a function appears in the Script 
pane.

17. In the parameters area of the Script pane, type the name 
of your function in the Name box.

Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive.

18. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters box (Figure 12).

In this box, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

19. In the Actions toolbox on the left side of the panel, select 
the StopAll method for the SoundMixer class.

To find the StopAll method, expand Flash.Media, and 
then expand SoundMixer.

Figure 10 CLICK property in the Actions toolbox

Figure 11 CLICK property in the Script pane

Figure 12 Function code in the Script pane
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20. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox.

The method is added to the function (Figure 13).

21. Now when visitors click the button, all sounds currently 
playing in the movie will stop.

Figure 13 StopAll method in the Actions panel

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help.  Select ActionScript 3.0 And Components, select Programming ActionScript 3.0, and select 
Getting Started With ActionScript).
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How to create masks
In Adobe Flash Professional CS5, a mask is a special type of layer that lets you reveal select parts of another layer. 
For example, if you want to show people walking around inside a house, and you want them to be visible when they 
pass by a window but invisible otherwise, you can use a mask. You can use masking for effects such as creating a 
spotlight or showing pictures behind images.

Creating a mask

In the following steps, you’ll create a mask by using a simple shape.

To create a mask:

1. Start Flash and open a document.

2. Import an image to the Stage.

3. Create a new layer and name it mask. Put this layer 
directly above the layer containing the image.

4. Use a drawing tool, such as the Oval tool or the 
Rectangle tool, to define the area of the mask layer that 
you want to be transparent (Figure 1). 

Make the transparent area of the mask a solid, noticeable 
color. This will help you see where the transparent area 
is.

5. Right-click (Windows) or Control-click (Mac OS) the 
mask layer, and select Mask from the context menu.

The two layers change to indicate that the bottom layer is 
masked. The name of the masked layer is indented under 
the name of the masking layer and its icon changes to a 
mask layer icon (Figure 2). Both of the layers are locked 
by default.

Note: To display the mask effect, lock both the mask 
layer and the layer containing the masking content. 
Unlock one or both layers to hide the effect.

6. Select Control > Test Movie > In Flash Professional to 
see it play.

Observe that only the masked area is visible.

7. Select File > Close to close the preview window.

Figure 1 Mask layer with mask area

Figure 2 Mask applied

Mask layer Mask area
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Animating the mask

You can animate the mask so that, for example, the mask pans along a picture.

To animate the mask:

1. Continue where you left off in the previous steps.

2. On the mask layer, add a frame at frame 20.

3. On the masked layer below, also add a frame at frame 20.

4. Click the Mask layer anywhere between frames 1 and 20, 
and then select Insert > Classic Tween.

5. Unlock the mask layer, click frame 20, and move the 
mask object (Figure 3). 

6. Adjust the motion guide as necessary.

7. Select Control > Test Movie > In Flash Professional to 
see it play.

Observe that only the masked area moves across the 
content beneath it.

8. Select File > Close to close the preview window.
Figure 3 Motion tween on the mask layer

Change the masked content

You can change content on the layer below the mask while keeping the mask the same.

To change the masked content:

1. Continue where you left off.

2. On the masked layer, select frame 10 and select Insert > 
Timeline > Blank Keyframe.

Inserting a blank keyframe clears the contents of the 
frame.

The contents of the masked layer clear.

3. Add new content to the masked layer at frame 10. 
(Unlock the masked layer, if necessary.)

For example, you could drag a different picture to the 
Stage.

4. Select Control > Test Movie > In Flash Professional to 
see it play.

Observe that the area under the mask changes halfway 
through the animation.

5. Select File > Close to close the preview window.
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To revert the masked content to its original state:

1. Continue where you left off.

2. Select frame 10 (where you inserted the second 
keyframe), and select Modify > Timeline > Clear 
Keyframe.

This reverts the keyframe to a regular frame, and changes 
the layer back to its original state.
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How to ease tweens
Easing is a technique for modifying the way Adobe Flash Professional CS5 calculates the property values between 
property keyframes in a tween. Without easing, Flash calculates these values so the change to the value is the same in 
each frame. You can use easing to adjust the rate of change to the values for more natural or more complex animation.

An ease is a mathematical curve you apply to the property values of a tween. The final effect of the tween is the result 
of the combination of the range of property values in the tween and the ease curve.

You can apply easing in the Motion Editor for motion tweens or in the Property inspector for classic tweens. Eases 
applied in the Motion Editor can affect a single property, a group of properties, or all properties of a tween. Eases 
applied in the Property inspector affect a single property or all of the properties included in a tween.

An ease can be simple or complex. Flash includes a range of preset eases you can apply for simple or complex effects. 
In the Property inspector or Motion Editor, you can also create your own custom ease curves.

One of the many common uses of easing is when you have edited a motion path on the Stage and enabled roving 
keyframes to make the speed of motion consistent in each segment of the path. You can then use easing to add more 
realistic acceleration and deceleration at the ends of the path.

Easing individual properties for motion tweens in the Motion Editor

You can apply a preset ease to an individual property or a category of properties in the Motion Editor. In the following 
steps, you first create a motion tween and then add a preset ease to the tween.

To apply a preset ease:

1. Start Flash and choose File > New (ActionScript 3.0). 

2. Draw a shape on the Stage.

3. Using the Selection tool, double-click to select the shape 
and border, if present 

4. Choose Modify > Convert To Symbol. 

The Convert To Symbol dialog box appears.

5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK.

6. Insert a frame at frame 40.

7. Make sure frame 40 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.

8. Select the symbol in frame 40 and use the Selection tool 
to move the object to a different position on the Stage.

9. In the Timeline, select the motion tween and select the 
Motion Editor tab (Figure 1).

10. In the Motion Editor, scroll down to Eases, click the Add 
Ease button (plus sign) and select an ease, such as Stop 
And Start (Medium) (Figure 2).

Figure 1 Flash Timeline with motion tween and 
Motion Editor tab

Figure 2 Adding eases in the Motion Editor

Motion Editor tab

Add Ease button
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11. Scroll up to Basic Motion, and select the ease you just 
added from the Ease pop-up menu (Figure 3).

12. Press Enter (Windows) or Return (Mac OS) to preview 
the eased tween.

If you chose the Stop And Start (Medium) ease, for 
example, the tween will stop briefly and then begin 
again.

13. Adjust the eases in the tween until you achieve the 
desired effect. 

See the following section for information about adjusting 
ease curves.

Figure 3 Adding the ease to Basic Motion

Editing ease curves for motion tweens in the Motion Editor

Eases are displayed as ease curves in the right side of the Motion Editor. You can edit the shape of preset ease curves 
and create custom ease curves.

To edit ease curves for motion tweens:

• To edit a preset ease curve, set the value for the ease in 
the field next to the ease name (Figure 4). To do so, click 
on the value and drag to the left (negative) or right 
(positive).

• For simple ease curves, the value is a percentage 
representing the strength of the application of the 
ease curve to the property curve. Positive values 
increase the ease at the end of the curve. Negative 
values increase the ease at the beginning of the 
curve.

• For ease curves that are waves, such as the sine wave 
or sawtooth wave, the value represents the number of 
half-cycles in the wave.

• To edit a preset ease, first add it to the list of 
available eases by using the Add button in the Ease 
section of the Motion Editor.

• To edit a custom ease curve, add it to the list of eases 
and then edit the curve by using the same techniques 
for editing any other Bezier curve.

Figure 4 Editing a simple ease curve
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Easing individual properties for classic tweens in the Property inspector 

For classic tweens, the Motion Editor is not available. You create eases for classic tweens by using the Property 
inspector.

To ease a classic tween:

1. Start Flash and choose File > New (ActionScript 3.0). 

2. Add a symbol to the Stage.

3. Select frame 40.

4. Select Insert > Timeline > Keyframe.

The tween will last for 40 frames.

5. Make sure frame 40 is still selected and move the symbol 
to a new position on the Stage.

6. Click on the tween span on the Timeline and select Insert 
> Classic Tween. 

The classic tween appears as light blue with an arrow.

7. Select frame 40, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.

You can also adjust the properties of the symbol in the 
tweening section of the Property inspector.

8. In the Timeline, select the classic tween (Figure 5).

9. In the Property inspector, enter an Ease value to 
determine the strength of the ease, such as -60 
(Figure 6).

10. To preview the animation on the Stage, press Enter 
(Windows) or Return (Mac OS).

11. Adjust the ease in the tween until you achieve the desired 
effect. 

Figure 5 Classic tween in the Timeline

Figure 6 Editing a simple ease curve

Ease value 
scrubber

Edit 
button
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Editing ease curves for classic tweens in the Property inspector 

In the Property inspector, you can edit the shape of the curves to create custom ease-ins and ease-outs.

To edit ease curves:

1. In the Timeline, select the classic tween that you created 
in the previous steps. 

2. Click the Edit button next to the Ease Value field in the 
frame Property inspector (Figure 6). 

The Custom Ease In/Ease Out dialog box appears 
(Figure 7).

3. (Optional) To display the curve for a property, deselect 
Use One Setting For All Properties, and select a property 
in the menu (Figure 8).

4. You can add control points anywhere along the curve to 
help you manipulate the curve. To add a control point, 
point, move the arrowhead pointer near the curve until 
the pointer changes to a full arrow, and then click.

5. To increase the speed of the object, drag the control point 
up; to slow down the speed of the object, drag it down.

6. To further adjust the ease curve and fine-tune the ease 
value of the tween, drag the vertex handles (Figure 9).

7. To view the animation on the Stage, click the play button 
in the lower left corner.

8. Adjust the controls until you achieve the desired effect.

Note: If you use the Custom Ease In/Ease Out dialog box 
to apply a custom ease to a frame, the ease value edit box 
displays '--'. If you use the edit box or the pop up slider to 
apply an ease value to a frame, the Custom Ease graph is 
set to the equivalent curve, and the Use One Setting For 
All Properties option is selected.

Figure 7 Custom Ease In / Ease Out dialog box

Figure 8 Easing property menu

Figure 9 Editing a simple ease curve

Play button Vertex handles
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How to produce Flash video for use on the web
Adobe Flash Professional CS5 provides a number of options for importing and publishing video with a Flash movie.

You can import the following video formats:

• Video for Adobe Flash (.flv, .f4v)

• 3GPP/3GPP2 for mobile devices (.3gp, .3gpp)

You can import the following video formats if you have QuickTime 7 or later installed (Windows and Mac OS):

• Audio Video Interleaved (.avi)

• Digital Video (.dv)

• Motion Picture Experts Group (.mp4, .m4v, .avc)

• QuickTime Movie (.mov, .qt)

Deploying video

How you choose to deploy your video determines how you create your video content and how you integrate it with 
Flash. You can incorporate video into Flash in the following ways:

Progressively download video from a web server: Flash creates a Flash video file that downloads from a regular web 
server and plays within the published SWF file.

Stream video with Adobe Flash Media Server: This option produces the overall best performance; however, it 
requires either the Flash Media Server or a subscription to a Flash Video Streaming service. See the Adobe website 
for more information: www.adobe.com.

Embed video in the Flash document: You can embed a small, short-duration video file directly into the Flash 
document and publish it as part of the SWF file. Embedding video content directly into the Flash SWF file 
significantly increases the size of published file and is only suitable for small video files (typically less than 10 
seconds in length).

To encode your video for Flash:

1. Open an existing Flash document or create and save a 
new Flash document.

Note: You must save the Flash document before you 
begin the video import process.

2. Select a keyframe on the layer in which you want to 
import the video.

This is where the video player will be located after the 
video import is complete.
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3. Click File > Import > Import Video.

The Import Video dialog box opens (Figure 1).

4. Click the Launch Adobe Media Encoder button.

The Adobe Media Encoder appears (Figure 2).

5. In the Media Encoder, click the Add button and browse to 
the location for the video file you want to encode.

6. Choose an appropriate Format, Preset (Figure 3), and 
Output File location in the Media Encoder.

7. Click the Start Queue button to begin encoding.

When the encoding process is complete, close the Adobe 
Media Encoder. 

Figure 1 Import Video dialog box 

Figure 2 Adobe Media Encoder

Figure 3 Preset options for encoding video
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To use progressive download:

1. Click File > Import > Import Video.

The import Video dialog box opens (Figure 4).

2. Click the Browse button to find the location for the newly 
encoded video file you want to import.

You can use a video file located either on your computer 
or on the Internet.

3. Select Load External Video With Playback Component.

This option progressively loads your external video file 
into your Flash document.

4. Click Next (Windows) or Continue (Mac OS).

The Skinning page of the Import Video wizard opens 
(Figure 5).

The video’s skin determines the location and appearance 
of the video controls. Visitors see this skin when Flash 
plays the video.

5. Select a skin from the Skin pop-up menu.

6. Select a skin color from the color picker.

7. Click Next (Windows) or Continue (Mac OS).

The Finish Video Import page of the Import Video wizard 
appears. This page confirms the location of the Flash 
video file.

8. Click Finish.

The FLVPlayback object appears on the Stage 
(Figure 6).

9. Click the Play button.

The video plays in the Playback object.

10. Open the folder in which you saved the Flash document.

This folder now contains two new files: an FLV file and a 
SWF for the video's skin. (The skin will be called 
something like MojaveOverAll.swf.) When you publish 
your Flash document, you need to copy both of these files 
to the same location as the Flash document.

Figure 4 Import Video wizard, Select Video page

Figure 5 Import Video wizard, Skinning page

Figure 6 FLVPlayback object on Stage

Play button
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To preview video in a preview window:

1. Select Control > Test Movie > In Flash Professional.

The video plays in the Flash Player window. You can use 
the controls to stop, pause, fast forward, rewind, and 
change the volume of the video.

2. Select File > Close to close the preview window.

Embedding video within SWF files

When you select the embedded video option, Flash converts video to Timeline frames. When the SWF file is 
published, the video is fully contained in that file. Unlike progressive download, embedded video requires no external 
file and so is easier to deploy. However, because embedded video often has problems with audio synchronization 
after 120 frames, Adobe recommends embedded video in only three cases:

• When you want visitors who have Flash 5 to be able to view your video

• When you must have one single file that encapsulates the video and the Flash content

• When your video clip is less than 5 seconds long

These situations are not common. In all other situations, embedded video is not recommended.
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How to use rulers and guides
Rulers and guides can be very helpful in positioning objects on the Stage.

Using guides

You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can 
move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides and change the guide 
color and snap tolerance (how close objects must be to snap to a guide). Adobe Flash Professional CS5 enables you to 
create nested Timelines (i.e., movie clips within the main movie). Guides appear on the Stage only when the Timeline 
in which they were created is active.

To create a guide:

1. Make sure rulers are visible by selecting View > Rulers. 

2. Click on a ruler and drag toward the Stage (Figure 1).

A guide appears as you drag.

3. Release the mouse button at the point you wish to locate 
the guide (Figure 2).

Figure 1 Drag a ruler

Figure 2 Guide on Stage
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Locking or Unlocking Guides

When guides are locked, they won’t respond to clicking or dragging, so that you won’t accidentally move them when 
you are working with objects on the Stage. However, you can still create new guides.

To lock a guide

• Select View > Guides > Lock Guides.

This command toggles between locking and 
unlocking guides.

Note: You can also use the Lock Guides option in 
the Guides dialog box (View > Guides > Edit 
Guides). For more information, see the section titled 
Changing guide properties at the end of this guide.

To view or hide the drawing guides:

• Select View > Guides > Show Guides.

To move a guide:

• Make sure guides are not locked. With the Selection 
tool, click anywhere on the guide and drag the guide 
to the desired place on the Stage.

To remove a guide:

• With guides unlocked, use the Selection tool to drag 
the guide to the horizontal or vertical ruler.
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Using guides to position objects on the Stage

By activating the SnapTo Guides option, you can automatically align objects with guides. As you drag objects toward 
guides, objects nap into place.

To position objects with guides:

1. Select View > Snapping > Snap To Guides (if it is not 
already selected).

2. Drag the edge of an object toward a guide.

When you get close to the guide, the object snaps to it 
(Figure 3).

3. Release the mouse.

The object remains snapped to the guide.

You can use guides to line up different objects 
(Figure 4). Guides are especially useful for aligning 
objects on different layers.

Figure 3 Snap object to guide

Figure 4 Aligning objects with guides

Changing guide properties

You can change guide colors, set guide snapping properties, and lock guides.

To change guide properties:

1. Select View > Guides > Edit.

The Guides dialog box opens (Figure 5).

2. Click the Guides Color control to change guide colors.

3. Select Lock Guides to lock guides in position.

4. Click OK to close the Guides dialog box.

Figure 5 Guides dialog box

Object snaps to guide 
here
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How to import sound
In Adobe Flash Professional CS5, you can import sound and video to integrate them into the Timeline. You can create 
media-rich content with very precise control.

Importing sound

You can use sound for many purposes in Flash. Some examples include soundtracks, narration, and sound effects that 
complement objects such as rollover buttons.

You can import the following sound file formats into Flash:

• ASND Adobe Sound Document

• WAV (Windows only)

• AIFF (Mac OS only)

• MP3 (Windows or Mac OS)

If you have QuickTime 4 or later installed on your system, you can import these additional sound file formats:

• AIFF (Windows or Mac OS)

• Sound Designer II (Mac OS only)

• Sound Only QuickTime Movies (Windows or Mac OS)

• Sun AU (Windows or Mac OS)

• System 7 Sounds (Mac OS only)

• WAV (Windows or Mac OS)

When you import a sound file, it’s placed in the library. Then you can drag an instance (copy) of the sound onto the 
Stage. Sound files must be tied to keyframes.

You can synchronize a sound to your movie in several ways (using the Sync pop-up menu in the Property inspector):

• Event: An event sound plays when the playhead reaches the first keyframe containing the sound. It plays in its 
entirety, independent of the Timeline, even if the movie stops. If a different instance of the same sound is started, 
the sounds will overlap.

• Start: The same as Event, except that if the sound is already playing, no new instance of the sound will begin 
playing.

• Stop: Silences the specified sound.

• Stream: Forces the movie to keep pace with the sound. If Flash can’t draw animation frames quickly enough, it 
skips frames. Unlike event sounds, stream sounds stop if the movie stops. Stream sounds can also produce a 
much smaller file size, although their quality tends to be poorer than event sounds.
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Importing a Sound

You import sounds into the library, then drag them onto the Stage to add them to the Timeline.

To import a sound:

1. Start Flash and open a document.

2. Insert a new layer.

3. Double-click the new layer name, and rename it Sound.

4. Select File > Import > Import To Library.

The Import To Library dialog box opens (Figure 1).

5. Locate a sound file, select it, and click Open (Windows) 
or Import To Library (Mac OS).

Note: You can download free music loops and sound 
effect clips at www.flashkit.com, for example.

6. Select frame 1 on the Sound layer.

7. Make sure the Library panel is open. (If not, select 
Window > Library.)

The sound appears in the Library panel. To preview the 
sound, select it and then click the Play button in the 
preview (upper) pane of the Library panel (Figure 2).

8. Drag the sound file from the Library panel onto the 
Stage.

The Sound layer must contain enough frames to play the 
entire sound. For example, if your movie is set for 12 
frames per second and your sound is 2 seconds long, the 
Sound layer must contain at least 24 frames. If you are 
adding sound to an existing movie, your movie might 
already be long enough to accommodate the sound.

9. If necessary, add frames to the Sound layer. To do this, 
click a frame down the Timeline for the Sound layer, 
such as frame 24 for a 2-second movie at 12 fps, and 
select Insert > Frame.

The sound does not appear on the Stage but does appear 
on the Timeline as a waveform (Figure 3). 

Note: Press the F5 key to insert a frame. Press Shift-F5 to 
delete a frame.

Figure 1 Import To Library dialog box

Figure 2 Library panel

Figure 3 Sound in Timeline

Play button
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Editing sound settings

In the Property inspector, you can change settings for the sound, including making the sound fade in and fade out.

To edit sound settings:

1. Continue where you left off in the previous task.

2. Select the first keyframe and adjust the settings for the 
sound in the Property inspector (Figure 4).

• Effect: Choose from previously created effects such 
as Fade In, Fade Out, keeping sound in only one 
channel (left or right), or fading sound from one 
channel to the other (Figure 5). Choosing Custom 
(or clicking the Edit button) opens a sound-editing 
window where you can create your own fading 
effects (Figure 6). In the sound-editing window, 
called the Edit Envelope dialog box, adjust the sound 
handles to control sound volume in each channel.

• Sync: Choose Event, Start, Stop, or Stream.

• Loop: Set the number of times to have the sound 
replay

Figure 4 Property inspector

Figure 5 Effect pop-up menu

Figure 6 Edit Envelope dialog box
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Sound compression

Sound files can drastically increase the file size of your movies. One way to control this is to set the compression for 
the sounds in Flash.

To compress sound:

1. Make sure the Library panel is open, and select the sound 
file.

2. Click the Properties button in the Library panel 
(Figure 7).

The Sound Properties dialog box opens (Figure 8).

3. Choose a compression method from the Compression 
menu and click OK.

• ADPCM: This method sets the compression for 8-bit 
and 16-bit sound data. Use this when you export 
short event sounds such as button clicks.

• MP3: This method offers good compression and 
sound fidelity for longer stream sounds such as 
music tracks.

• Raw: This resamples the file but does not perform 
any compression.

• Speech: A good compression to use for speech sound 
files.

4. Save the movie.

5. Select Control > Test Movie > In Flash Professional.

Figure 7 Library Properties button

Figure 8 Sound Properties dialog box

Library Properties button
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How to use a motion guide with a motion tween 
animation
In Adobe Flash Professional CS5, motion guides appear when you create motion tweens. By using a motion guide, 
you can move an object along an editable path. 

1. Select the layer that contains the object you wish to 
animate.

2. Select Insert > Motion Tween.

Notice the tween in the Timeline layer (Figure 1)

3. On the Stage, move the object and notice the motion 
guide appear (Figure 2).

4. Click and drag a point on the motion guide. Edit as many 
points of the guide as you choose (Figure 3).

5. Turn Onion Skinning on to see how the object moves 
(Figure 4).

6. Select Control > Test Movie > In Flash Professional to 
see it play.

Observe that the object moves along the guide.

7. Select File > Close to close the preview window.

Figure 1 Object layer with motion tween applied

Figure 2 Motion guide

Figure 3 Editing the motion guide

Figure 4 Object moving along the guide
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Symbols, instances, and the library

Symbols and instances

A symbol is a graphic, button, or movie clip you create once in Adobe Flash Professional CS5 and can use any 
number of times throughout your movie. Any symbol you create is automatically placed in a storage area called the 
library for the current document.

An instance is a copy of a symbol located on the Stage. An instance can be different from its symbol in color, size, 
and function. To create an instance of a symbol, drag the symbol from the library onto the Stage. Once you have 
created an instance, you can use the Color Effect options in the Property inspector to change its brightness, tint, alpha, 
or RGB color settings.

Editing the symbol automatically updates all of its instances, but applying effects to an instance of a symbol updates 
only that instance.

Using symbols offers a number of advantages. Symbols add interactivity to your documents. They save space and 
reduce the download time of your finished movie because Flash does not have to save duplicate information for each 
instance. For example, if you create an animated wheel symbol, you can use several instances of the symbol to create 
the wheels on a train. The result is a much smaller file than if you had created each wheel separately. Symbols also 
help you maintain consistency throughout your Flash document. For example, if you have buttons throughout your 
document, using symbols ensures that all buttons look alike. You can easily edit all instances of buttons in a 
document at once when you use symbols to create them. You can also use symbols to share content between different 
documents.

When you create a new drawing in Flash, you’re creating a shape, not a symbol. You can convert any shape to a 
symbol by selecting it and then selecting Modify > Convert To Symbol.

Libraries

The library is a container in each movie where Flash stores and organizes symbols, sounds, bitmap graphics, video, 
and other elements. The library is attached to the document you’re working on. To open the Library panel, select 
Window > Library (Figure 1). If you share your document with someone else, and they open it on their computer, 
they will see the same library objects. You can also open libraries from other documents by selecting File > Import > 
Open External Library. As your documents become more complex, you’ll find it helpful to use folders to sort your 
symbols into related groups within the library.

Figure 1 Library panel
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Types of symbols

Flash has three types of symbols: graphic, button, and movie clip.

Each symbol has a unique Timeline and Stage, complete with layers. When you create a symbol, you choose the 
symbol type, depending on how you want to use the symbol in your document.

• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
Timeline. Graphic symbols operate in sync with the main Timeline. Interactive controls and sounds won’t work 
in an animation sequence contained in a graphic symbol.

• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, and other site visitor 
actions. You define the graphics associated with various button states and then assign actions to a button 
instance.

• Use movie clip symbols to create reusable pieces of animation. A movie clip has its own Timeline that is 
independent from the main Timeline—think of it as a sub-Timeline nested inside the main Timeline. Movie clips 
can contain interactive controls, sounds, and even other movie clip instances.

Creating symbols

You create symbols in one of two ways:

• Select Insert > New Symbol. This creates a new symbol to which you must add content.

• Select an existing shape and select Modify > Convert To Symbol.
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How to work with symbols
A symbol is a reusable object stored in a library for an Adobe Flash Professional CS5 document. It can be as simple as 
a static drawing or as complex as a movie clip that runs within another movie clip. Both you and the Flash Player can 
reuse symbols stored in the library. Not only does this approach speed development, it also helps keep your document 
small, making it faster for site visitors to download.

Each symbol has its own Timeline. You can add frames, keyframes, and layers to a symbol Timeline, just as you can 
to the main Timeline.

An instance is a copy of a symbol located on the Stage or inside the Timeline of another symbol. An instance can 
differ from its symbol in color, size, and other characteristics set through the Property inspector. Editing the symbol 
updates all its instances, but applying effects or changing the properties of an instance of a symbol changes only that 
instance.

Types of symbols

Each symbol has a unique Timeline and Stage, complete with layers. You can add frames, keyframes, and layers to a 
symbol Timeline, just as you can to the main Timeline. When you create a symbol you choose the symbol type. 

• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
Timeline. Graphic symbols operate in sync with the main Timeline. Interactive controls and sounds won’t work 
in a graphic symbol’s animation sequence. Graphic symbols add less to the FLA file size than buttons or movie 
clips because they have no timeline.

• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, or other actions. You 
define the graphics associated with various button states, and then assign actions to a button instance. For more 
information, see Handling events in Programming ActionScript 3.0.

• Use movie clip symbols to create reusable pieces of animation. Movie clips have their own multiframe Timeline 
that is independent from the main Timeline—think of them as nested inside a main Timeline that can contain 
interactive controls, sounds, and even other movie clip instances. You can also place movie clip instances inside 
the Timeline of a button symbol to create animated buttons. In addition, movie clips are scriptable with 
ActionScript®.

Creating a new symbol

You can create a symbol from selected objects on the Stage, create an empty symbol and make or import the content 
in symbol-editing mode, and create font symbols in Flash. Symbols can contain all the functionality that Flash can 
create, including animation. 

Flash adds the symbol to the library and switches to symbol-editing mode. In symbol-editing mode, the name of the 
symbol appears above the upper left corner of the Stage, and a cross hair indicates the symbol’s registration point.
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To create a new symbol:

1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).

2. Select Insert > New Symbol.

The Create New Symbol dialog box appears (Figure 1).

3. In the Create New Symbol dialog box, give the new 
symbol a name and select a symbol type.

4. Click OK.

The new symbol has been created and opens in symbol-
editing mode.

5. Add content to the symbol.

6. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar (Figure 2).

The new symbol is stored in the Document library and 
can be reused in this and other Flash documents.

Figure 1 Create New Symbol dialog box

Figure 2 Edit bar

Converting an existing object to a symbol

Converting an existing object to a symbol

To convert an object to a symbol:

1. Select the object you want to convert to a symbol.

Note: To select both the stroke and the fill of a shape, you 
must double-click the fill unless the object is grouped. A 
single click on the fill selects only the fill, a single click 
on a stroke selects one side of a stroke where a double 
click on the stroke selects the complete stroke.

2. Select Modify > Convert To Symbol.

The Convert To Symbol dialog box appears (Figure 3).

3. In the Convert To Symbol dialog box, give the new 
symbol a name, and select a symbol type.

The object is now a symbol that is stored in the 
Document library and can be reused in this and other 
documents.

4. Select Window > Library to display the Library panel and 
see your new symbol.

Figure 3 Convert To Symbol dialog box
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Editing a symbol

You can edit an existing symbol either through the Library panel or in place on the Stage. You can also use the Edit In 
Place command to edit a symbol. By using the Edit In Place command, you can edit a symbol while still viewing 
other objects on the Stage. Editing a symbol is different from changing the properties of a symbol instance. When you 
click a symbol on the Stage and change its properties, you are changing the symbol instance, not the symbol 

Editing a symbol in place

To edit a symbol in place, you can double-click an instance of the symbol on the Stage or you can select an instance 
of the symbol on the Stage and right-click (Windows) or Control-click (Mac OS) and then select Edit In Place. You 
can also select Edit > Edit In Place to edit a symbol.

Editing a symbol through the library

You can edit a symbol by double-clicking it in the Library panel. When you edit a symbol through the library, Flash 
updates all instances of the symbol on the Stage. If the symbol has no instances (that is, if you have not copied it from 
the Library panel to the Stage), nothing on the Stage changes when you edit the symbol.

Using symbols with the Deco drawing tool

By using the Decorative drawing tools, you can turn your symbols into complex, geometric patterns. The Decorative 
drawing tools apply algorithmic calculations, known as procedural drawing, to movie clips or graphic symbols in the 
library. Flash contains a range of Deco drawing tools. This guide describes a representative set of these. For 
information on other Deco tools, see Flash Help.

The Symmetry effect

Use the Symmetry effect to arrange symbols symmetrically around a central point.

To apply the Symmetry effect:

1. Select the Deco drawing tool, and select Symmetry Brush 
from the Drawing Effect menu in the Property inspector 
(Figure 4).

2. In the Property inspector, click the Edit button.

The Select Symbol dialog box appears, with a list of 
custom symbols from the library (Figure 5).

You can use any movie clip or graphic symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash.

3. Select a symbol in the Select Symbol dialog box and 
click OK. Figure 4 Drawing Effect menu in the Property 

inspector

Figure 5 Select Symbol dialog box
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4. In the Property inspector, choose one of the options from 
the Advanced Options menu (Figure 6). 

• Rotate Around: Rotates the shapes in the symmetry 
around a fixed point that you designate. The default 
reference point is the center point of the symmetry. 
To rotate the object around its center point, drag in a 
circular motion.

• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify.

• Reflect Across Point: Places two shapes an equal 
distance apart around a fixed point that you specify.

• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco drawing tool on the Stage creates a grid 
of shapes. Adjust the height and width of the shapes 
by using the x and y coordinates defined by the 
Symmetry Brush handles.

5. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 7).

6. .Use the Symmetry Brush handles to adjust the size of the 
symmetry and the number of symbol instances.

Figure 6 Advanced Options menu

Figure 7 Placing symbols with the Symmetry 
Brush
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The Grid Fill effect

You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you have drawn the Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes 
accordingly.

The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke.

To apply the Grid Fill effect:

1. Select the Deco drawing tool, and select Grid Fill from 
the Drawing Effect menu in the Property inspector 
(Figure 8).

2. In the Property inspector, click the Edit button to select a 
custom symbol from the library.

The Select Symbol dialog box appears, with a list of 
custom symbols from the library.

You can use any movie clip or graphic symbol in the 
library with the Grid Fill effect.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

4. You can use the following advanced options in the 
Property inspector to specify the horizontal and vertical 
spacing and the scale of the fill shape. 

• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill.

• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill.

• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis).

Note: After you apply the Grid Fill effect, you cannot 
change the advanced options to alter the fill pattern.

5. Click the Stage or click within the shape or symbol where 
you want the Grid Fill pattern to appear (Figure 9).

The pattern fills the area.

Figure 8 Drawing Effect menu in the Property 
inspector

Figure 9 Placing symbols with the Grid Fill effect
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The 3D Brush effect

You can use the 3D Brush effect to spray symbols so that they appear to be in front of each other. After you have 
drawn the 3D Brush on the Stage, if you resize or otherwise change the filled symbol, the 3D Brush changes 
accordingly.

To apply the 3D Brush effect:

1. Select the Deco drawing tool, and select 3D Brush from 
the Drawing Effect menu in the Property inspector 
(Figure 10).

2. In the Property inspector, click the Edit button to select a 
custom symbol from the library.

The Select Symbol dialog box appears, with a list of 
custom symbols from the library.

You can use any movie clip or graphic symbol in the 
library with the 3D Brush effect.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

4. You can use the following advanced options in the 
Property inspector. 

• Max Objects: Specifies the total number of shapes 
used in the 3D Brush.

• Spray Area: Specifies the area covered in each spray 
of the 3D Brush.

• Perspective: Specifies that objects appear in front of 
each other.

• Distance Scale: Specifies how far in front of each 
other objects appear to be.

• Random Scale Range: Specifies the degree to which 
objects vary in size.

• Random Rotation Range: Specifies the degree to 
which objects are rotated.

Note: After you apply the 3D Brush effect, you cannot 
change the advanced options to alter the fill pattern.

5. Drag the pointer across the Stage to draw with the 3D 
Brush (Figure 11).

Figure 10 Drawing Effect menu in the Property 
inspector

Figure 11 Placing symbols with the 3D Brush 
effect
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The Vine Fill effect

You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a Vine pattern. You can substitute 
your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is contained 
in a movie clip that itself contains the symbols that make up the pattern.

To apply the Vine Fill effect:

1. Select the Deco drawing tool, and select Vine Fill from 
the Drawing Effect menu in the Property inspector.

2. In the Property inspector (Figure 12), click an Edit 
button to select a custom symbol from the library if you 
want to replace the default flower and leaf symbols.

The Select Symbol dialog box appears, with a list of 
custom symbols from the library.

You can use any movie clip or graphic symbol in the 
library to replace the default flower and leaf symbols 
when applying the Vine Fill effect.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

4. You can specify the horizontal and vertical spacing and 
the scale of the fill shape. 

• Branch Angle: Specifies the angle of the branch 
pattern.

• Branch Color: Specifies the color for the branch.

• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis).

• Segment Length: Specifies the length of the 
segments between leaf and flower nodes.

• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn.

• Frame Step: Specifies how many frames to span per 
second of the effect being drawn.

Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Property inspector to 
alter the fill pattern.

5. Click the Stage or click within the shape or symbol where 
you want the Vine Fill pattern to appear (Figure 13).

The pattern fills the area.

Figure 12 Edit buttons in the Property inspector

Figure 13 Vine Fill pattern
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The Lightning Brush effect

You can use the Lightning Brush effect to draw a Lightning pattern. 

To apply the Lightning Brush effect:

1. Select the Deco drawing tool, and select Lightning Brush 
from the Drawing Effect menu in the Property inspector.

2. You can specify the following advanced options in the 
Property inspector (Figure 14). 

• Lightning Color: Specifies the color for the 
lightning.

• Lightning Scale: Adjusts the size of the lightning 
pattern by enlarging or reducing it both horizontally 
(along the x axis), and vertically (along the y axis).

• Beam Width: Specifies the maximum width of the 
segments between lightning branches.

• Animation: Specifies that each iteration of the effect 
is drawn to a new frame in the Timeline. This option 
creates a frame-by-frame animated sequence of the 
lighting pattern as it is drawn.

• Complexity: Specifies how the amount of branching 
that will be generated in the lightning.

Note: After you apply the Lightning Brush, you cannot 
change the advanced options in the Property inspector to 
alter the fill pattern.

3. Drag the pointer across the Stage to create lightning 
(Figure 15).

Figure 14 Advanced Options in the Property 
inspector

Figure 15 Lightning pattern
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The Building Brush effect

You can use the Building Brush effect to draw buildings on the Stage.

To draw with the Building brush:

1. Select the Deco drawing tool, and select Building Brush  
from the Drawing Effect menu in the Property inspector.

2. You can specify the following options in the Property 
inspector (Figure 16). 

• Building: Specifies Random Building or one of four 
skyscraper patterns.

• Building Size: Adjusts the width of the building from 
1 to 10

Note: After you apply the Building Brush effect, you 
cannot change the advanced options in the Property 
inspector to alter the fill pattern.

3. Drag the pointer up from the bottom of the Stage to draw 
buildings (Figure 17).

Figure 16 Advanced Options in the Property 
inspector

Figure 17 Building Brush Fill pattern
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How to apply colors and gradients
Each Flash document holds its own color palette. You can use the Color panel to apply colors that aren’t in the default 
web-safe palette of 216 colors. You can create new colors and add them to the palette, which you can save for later 
use. You can also incorporate new colors into gradient fills and store your gradients for repeated use. A gradient is a 
multicolor fill in which one color gradually changes into another.

Gradients can be helpful when creating effects, such as glows, photo-realistic spheres, solar flares, and glowing 
buttons. With Adobe Flash Professional CS5 you can create two types of gradient fills—linear and radial.

Applying colors

You apply and manage colors using the Color panel.

To apply colors:

1. Start Flash and open a new blank document (ActionScript 
3.0).

2. Use the Oval tool to create a simple shape on the Stage.

3. You can adjust the fill and stroke colors by using the 
Property inspector. To apply a color that is not in the 
current palette, use the Color panel (Figure 1).

If the Color panel is not open, select Window > Color.

4. Make sure you have selected both the stroke and fill of 
your shape.

Note: To select the stroke and fill of your shape, double-
click the shape with the Selection tool.

5. In the Color panel, click the paint bucket icon (not the 
color box next to it) to select the Fill Color section. 
Choose a color in one of the following ways:

• You can select a new fill color in the palette by 
clicking Saturation and choosing a color in the Fill 
Color control (Figure 1). Drag the Brightness 
control to adjust the tint.

• You can select a new fill color by clicking Hue, 
dragging the Color control, and choosing a tint in the 
Fill Color control (Figure 2).

• You can also enter a hexadecimal number for the 
color. This is helpful if a client provides hexadecimal 
values. 

• You can also adjust red, green, and blue values by 
dragging their scrubbers. Use the Alpha slider to 
adjust the level of transparency.

6. To browse for a color, click and drag in the color picker. 
To adjust the tint, drag the Brightness control.

Figure 1 Color panel with Saturation selected

Figure 2 Color panel with Hue selected

Fill color control

Color picker

Brightness 
control

Hexadecimal 
value

Alpha

Saturation selected

Hue selected

Tint picker

Color control
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As you drag, the colors you point to are shown in the 
Current Color Swatch area and in the Fill Color control 
(Figure 3). (Once you release the mouse, the new color 
displays.)

Figure 3 Picking a new color

Add colors to the palette

Once you have mixed your own colors, you can use them to create a custom palette. You do this with the Color panel 
and the Swatches panel.

To add colors to the palette:

1. Make sure the Color panel and the Swatches panel are 
both open.

If they are not, select Window > Color and Window > 
Swatches.

Note: Since the Color panel and the Swatches panel are 
typically found in the same panel group, you may want to 
undock one panel in order to see both at the same time. 
Click the title of a panel and drag it away from the panel 
group.

2. In the Color panel, use the color picker or the RGB boxes 
to create a new color.

3. In the Color panel menu, select Add Swatch (Figure 4).

The new color is added to the palette in the Swatches 
panel (Figure 5).

Figure 4 Color panel menu

Figure 5 Swatches panel

Current color

Old color

New color swatch Gradient
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Web-safe colors palette

By default, the Swatches panel displays the web-safe colors palette. This palette is designed to work for all visitors’ 
monitors, including those with older monitors that display only 256 colors. Although all newer monitors work with 
more than 256 colors, many web designers recommend continuing to use this palette so your pages appear consistent 
to all visitors. (An additional benefit is that it gives you a limited range of colors from which to choose; sometimes 
it’s easier to make good choices when these choices are limited.) If you’re sure all your viewers have newer monitors, 
you can feel free to deviate from this palette by using the Color panel.

Creating gradients

You create gradients by selecting a gradient type and adding colors to the gradient.

To create gradients:

1. Make sure the Color panel and the Swatches panel are 
both visible.

If they are not, select Window > Color and Window > 
Swatches.

2. Use the Selection tool to double-click the oval shape on 
the Stage.

3. In the Color panel, select Radial Gradient in the Type 
menu (Figure 6). Selections in the Type menu determine 
the fill style of a shape.

This fills the selected shape with a radial gradient, 
composed of the two colors indicated by the color 
pointers under the gradient definition bar.

Note: By default, these colors may be set to black and 
white. 

You can have up to sixteen different colors in a gradient. 
To add more, click in the gradient definition bar 
(Figure 7).

Note: Radial gradients work best on elliptical shapes.

4. Make sure Extend is selected as the Overflow mode 
(Figure 7).

Overflow lets you control colors applied past the limits of 
a gradient. The overflow modes are Extend (the default 
mode), Reflect, and Repeat.

The gradient starts out black in the center (determined by 
the leftmost color pointer) and transitions to white 
(determined by the rightmost color pointer).

5. Double-click the left color pointer under the Color 
gradient definition bar. Use the color picker to select a 
new color for the inner color of the gradient. The gradient 
definition bar changes color.

Figure 6 Gradient options in the Color panel

Figure 7 Gradient definition bar

Extend mode 

Color pointers

Gradient definition bar 
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6. Click in the gradient definition bar to add a new color to 
the gradient (Figure 8).

A new color pointer appears below the gradient definition 
bar.

7. Click or drag in the color picker to select a new color for 
the gradient. You can also select colors by dragging the 
RGB scrubbers or entering a hexidecimal number (or by 
double-clicking the new pointer).  You can change the 
color of the right pointer to change the outer color of the 
gradient. Selecting black (or another dark color) gives the 
shape a hard edge.

A new color pointer appears below the gradient definition 
bar.

8. In the Color panel menu, select Add Swatch.  The new 
gradient is added to the gradients in the Swatches panel.

9. Deselect the shape on the Stage to see the new gradient 
applied to your shape (Figure 9).

Figure 8 Adding a new color to the gradient 
definition bar

Figure 9 Applied gradient
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How to maintain consistency
Consistency is an important element of usability—the measure of how well visitors can accomplish tasks when using 
your website. Consistency is especially important for larger sites that contain multiple pages and content created in 
Adobe Flash Professional CS5. The more you make these pages look and feel alike, the more comfortable visitors 
will be while using them.

You should keep elements within your site consistent, but also, whenever possible, follow the conventions of other 
sites. For example, many sites locate the main navigation at the top of each page. Unless you have a very good reason 
to locate the main navigation elsewhere, you should also locate it at the top of the page. (Although design innovation 
is desirable, making sure as many visitors as possible can use your website is more important.)

Consistency is especially important in the following areas:

Navigation: Not only should navigational controls be available on every page, but they should also look the same on 
each page. Navigation should tell visitors where they are in the site’s organization, using, for example, a highlighted 
button. It should also let visitors move to other site areas easily.

Colors: Similar objects should have the same or similar colors, and different objects should have different colors. Use 
a limited palette of colors on your site. You can do so easily by tracking colors in the Swatches panel.

Buttons: Generally, all buttons should look the same or similar—with the same font, drop shadow, and beveling, for 
example. Sometimes visitors have difficulty knowing what to click, and keeping buttons similar helps them use what 
they’ve learned on a previous page. You can use the library to reuse buttons across different pages. (This has the 
added advantage of reducing the file size of your site.)

Fonts: Use a limited group of fonts. Usually, you will not need more than two or three fonts for even a large site.

Graphics: Keep graphics similar on each page. You can use the library to reuse images across different pages.

Transitions: Use similar transitions between pages. For example, if one page fades into the next page, use fades for all 
page transitions. Transitions should also have similar timing; if one lasts three seconds, they should all last three 
seconds.

Scroll bars: Many usability experts recommend using a scroll bar that looks as similar as possible to those used in 
desktop software. Make these look the same on every page.

Sound: Use sound consistently throughout your site pages. If, for example, a button on one page makes a sound when 
your visitors roll over it, you should have all buttons on all pages make such a sound.

Layout: All the pages in your site should have a similar layout: the navigation should be in the same place on every 
page, for example. Interactive areas should also be in the same place. If one page has a simple game, for example, and 
another page has an interactive chart, position these in the same area. You can use Flash templates to maintain 
consistent layouts across different pages.
© 2010 Adobe Systems Incorporated How to maintain consistency 1
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Creating a template

Templates are a good way to keep your website pages consistent. You can include navigation, fonts, graphics, and 
layout in a template so these elements appear consistent throughout your site.

To create a template:

1. Start Flash.

2. Add content to a document to serve as a template, such as 
navigation, images, buttons, and background.

3. Select File > Save As Template.

The Save As Template dialog box opens (Figure 1).

Note: If a dialog box appears first, stating that SWF 
history data will be cleared if saved as template, click 
Save As Template.

4. Enter a name for the template.

5. Select a category in the Category pop-up menu, or enter a 
new category name.

6. Enter a description for the template.

This description appears in the New From Template 
dialog box.

7. Click Save.

The template is now available as an option in the New 
From Template dialog box.

Figure 1 Save As Template dialog box
How to maintain consistency © 2010 Adobe Systems Incorporated
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How to use filmmaking techniques
Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating websites 
and digital movies. With Adobe Flash Professional CS5, you can simulate traditional film techniques. As you design 
Flash movies, think of creative ways to incorporate these effects and look for opportunities to create new effects that 
may in turn inspire traditional filmmaking.

You can create the following popular filmmaking techniques with Flash:

• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the camera 
up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a scene is 
known as a zoom.

• Camera angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect of 
your subject.

• Cross fades: One image appears to fade in while another fades out, a transitional effect for moving from one 
image to another.

• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can focus viewers 
on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a “boing” or tire 
screech.

Create a pan, tilt, or zoom effect by using classic tweens

To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) 
followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention on 
a particular part of the image.

To create a pan and zoom effect:

1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).

2. To import an image directly into the current Flash 
document, select File > Import > Import To Stage.

3. If your image is not already a symbol, convert it to a 
movie clip symbol (Figure 1). Place the symbol on the 
right side of the workspace, covering the Stage.

Be sure the Stage is smaller than the image.

4. In the Timeline, select the keyframe where you want the 
pan to end and select Insert > Timeline > Keyframe 
(Figure 2).

5. Select the ending keyframe. Drag the instance of the 
movie symbol to the opposite side of the workspace.

Figure 1 Image converted to symbol

Figure 2 Insert a keyframe
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6. Click in the Outline column to the right of the name for 
the layer that contains the movie symbol (Figure 3).

Note: You can more easily see the border of an image if 
you set the layer holding the image to outline mode 
(especially if the image contains a lot of grays that can 
fade into the area outside the Stage). Be sure the image 
does not slide off the Stage during a pan.

7. Select the starting frame and select Insert > Classic 
Tween.

This classic tween moves the movie symbol horizontally 
across the Stage (a pan). The second keyframe that ends  
the classic tween will also serve as the starting point for 
the next tween.

8. Add a third keyframe further along in the time line to 
serve as the ending point of the second classic tween (a 
zoom) (Figure 4).

9. Select the third keyframe and select Modify > Transform 
> Scale.

Transformation handles appear on the image (Figure 5).

10. Shift-drag one of the corner transformation handles to 
resize the image approximately three times its original 
size.

The image expands.

11. Select the second keyframe and select Insert > Classic 
Tween, creating a classic tween between the second and 
third keyframes.

12. In the Property inspector, increase the easing to a value 
between 60 and 100 for the classic tween (Figure 6).

The zoom will start quickly and slow down as it arrives at 
the resting point.

13. In the Timeline panel, click the New Layer button.

14. Rename the new layer actions (Figure 7).

15. Select the last frame of the actions layer and insert a new 
keyframe.

Figure 3 Image outlined

Figure 4 Keyframe for zoom

Figure 5 Outline image with transformation 
handles

Figure 6 Property inspector

Figure 7 New Layer button in the Timeline

Outline column

Transformation handle

New Layer
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16. Select Window > Actions to display the Actions panel.

The Actions panel opens (Figure 8).

Note: If the Actions toolbox is hidden, click the triangle 
or drag the vertical bar to open. If you don’t see the 
parameters area in the Actions panel, click the Script 
Assist button.

17. You need to place a stop command at the end of the 
timeline to end the movie clip. In the Actions toolbox on 
the left side of the panel, choose flash.display > 
MovieClip > Methods. 

18. Double-click or drag the stop item to the script pane.

Note: You can also locate the stop and other methods by 
using the Index located at the bottom of the Actions 
toolbox.

19. In the Script pane, select the stop method. Then click in 
the Object text box in the parameters area of the Actions 
panel.

The Insert Target Path button is now active.

20. Click the Insert Target Path button.

The Insert Target Path dialog box appears (Figure 9).

21. Select the Relative option and select the movie clip you 
want to play when viewers click the button. If you want 
the movie in the main timeline to play, select root to set 
the target path to this.

22. Click OK to close the Insert Target Path dialog box.

The Script pane shows the correct code for stopping the 
movie (Figure 10).

23. Close the Actions panel.

24. To test how the SWF file works before you publish your 
SWF file, use Test Movie (Control > Test Movie > In 
Flash Professional) and Test Scene (Control > Test 
Scene). 

25. Select File > Close to close the preview window.

Figure 8 Stop method in the Actions panel

Figure 9 Insert Target Path dialog box

Figure 10 Stop method in the Script pane
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Path button
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Stop method 
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Adding frame labels

You may want to add frame labels to the keyframes. Frame labels help you and other designers remember what is 
happening in a particular frame.

To add a frame label:

1. Add a new layer called labels as the top layer of the 
Timeline. 

2. Choose Insert > Timeline > Blank Keyframe in this layer 
to correspond with each of the motion keyframes that 
drive the animation.

A blank keyframe acts as a placeholder for symbols you 
plan to add later or intend to leave the empty.

3. Select a blank keyframe in the labels layer. Then in the 
Property inspector, type the label name in the Name text 
box (Figure 11).

The label appears along the Timeline in the frames after 
the blank keyframe (Figure 12).

4. Turn off outlining, save the file, and select Control > Test 
Movie > In Flash Professional.

Figure 11 Frame Name text box in Property 
inspector

Figure 12 Frame labels in Timeline

Further ideas

• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and 
zoom go well with a documentary style narrative.

• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if you are looking 
for the subject of the scene. You might zoom in and out several times during a pan to show you are looking for 
something.

• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a mountain 
range leading to the ocean. Because it takes in the majority of the landscape, the effect adds depth and 
seriousness to the tone of the narrative.
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Camera angles

When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the rule 
of thirds and adjust the viewing angle to emphasize a certain aspect of the subject.

• The rule of thirds states that if you divide the screen into a 3-by-3 grid, the intersections of the lines are areas 
where the eye will focus. Line up the items of focus at these intersections on the screen.

• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can diminish 
the importance of a subject as seen from above.

Even though the girl isn’t in the center of Figure 13, she 
catches your eye because she is near the intersection of 
the rule-of-thirds lines.

Looking up at the man having a moment in Figure 14 
makes him look powerful. Angling the camera down on 
him would make him look smaller and less powerful.

Figure 13 Rule of thirds

Figure 14 Camera angle
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Create cross fades by using classic tweens

A transitional effect for moving from one image to another is to fade one image out as you fade the other in.

To create a cross fade:

1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).

2. Import two images into separate layers in the current 
Flash document. (Select File > Import > Import To 
Stage.)

3. Convert the two images to be cross-faded into symbols.

4. Insert keyframes in both layers at the same point in the 
Timeline to mark the beginning of the fade-out of the first 
image and the fade-in of the second image.

5. Decide how long you want the transition to last. Insert 
keyframes in both layers at the same point in the 
Timeline to mark the end of the fade-out of the first 
image and the fade-in of the second image.

6. Select the first keyframe for the image that will fade out, 
select the image, and use the Property inspector to set its 
alpha level to 100% (Figure 15).

Note: If your images are in the same position on the 
Stage, you need to hide the top layer before you can 
select the symbol in the bottom layer. Selecting your 
images is easier if they are offset on the Stage.

7. Select the first keyframe for each image and insert a 
classic tween.

8. Select the first keyframe for the image that will fade in 
and set its alpha level to 0%.

9. Select the last frame for the image that will fade in and 
set its alpha level to 100%.

10. Select the last frame for the image that will fade out and 
set its alpha level to 0%.

11. Add a frame label to the first keyframe of each classic 
tween (Figure 16).

The labels appear on the Timeline (Figure 17).

Note: You can make the fade-out start after the fade-in or 
vice versa. You can also extend the fade-out to end in the 
same frame as the end of the fade-in.

If the images zoom in or out before the fade-out, you 
probably want to continue the zooming process during 
the fade.

12. Save the movie and select Control > Test Movie > In 
Flash Professional to test the movie.

13. Select File > Close to close the preview window.

Figure 15 Applying an Alpha level in the Color 
Effect Style menu

Figure 16 Frame label text box

Figure 17 Frame labels in Property inspector
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Create a bounce effect by using classic tweens

Some animated text and images that move onto the Stage will seem more lifelike if you add a little bounce to them 
when they reach their stopping point. This is an old animation technique acknowledging that any moving object 
carries momentum and thus rebounds a bit before it comes to a stop. This technique also grabs attention and can focus 
viewers on an area of the screen.

To create a bounce effect:

1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).

2. Begin by adding a symbol to the Stage. 

By default the symbol is placed in the first keyframe of 
the timeline.

3. Select a second frame along the timeline.

4. Select Insert > Timeline > Keyframe.

5. Make sure the new frame is still selected and move the 
symbol to a new position on the Stage.

6. Click on the tween span on the Timeline and select Insert 
> Classic Tween. 

The classic tween appears as light blue with an arrow. 

7. Label the starting keyframe for the classic tween move 
right or move left (Figure 18) and label the second 
keyframe bounce.

8. Insert a keyframe 3–5 frames after the end of the classic 
tween. Label this frame back.

9. Insert another keyframe 8–10 frames after the end of the 
original classic tween. This will be the final resting point 
of the image. Label this frame end.

If you want the final bounce back into place to take 
longer (more frames) so the object appears to slow down, 
insert the keyframe in this step farther down the 
Timeline.

10. Select the keyframe labeled back.

11. In this keyframe, select the symbol instance on the Stage 
and use the arrow keys to move the instance 5–10 
keypresses back in the direction it came from.

12. Create classic tweens between all the keyframes by 
clicking on each tween span and selecting Insert > 
Classic Tween.

13. Add an actions layer to the top of the Timeline.

Figure 18 Frame label
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14. On this layer, insert a keyframe after the last frame and 
add a stop action. In the Actions toolbox on the left side 
of the panel, choose flash.display > MovieClip > 
Methods.

15. Double-click or drag the stop item to the script pane.

The code for the stop method appears in the script pane.

16. In the Script pane, select the stop method. Then click in 
the Object text box in the parameters area of the Actions 
panel.

The Insert Target Path button is now active.

17. Click the Insert Target Path button.

The Insert Target Path dialog box appears. 

18. Select the Relative option and select the movie clip you 
want to play when viewers click the button. If you want 
the movie in the main timeline to play, select root to set 
the target path to this.

19. Click OK to close the Insert Target Path dialog box.

The Script pane shows the correct code for stopping the 
movie (Figure 19).

The Timeline should appear as it does in Figure 20.

20. Close the Actions panel.

21. To test how the SWF file works before you publish your 
SWF file, use Test Movie (Control > Test Movie > In 
Flash Professional) and Test Scene (Control > Test 
Scene). 

22. Select File > Close to close the preview window.

Figure 19 Actions panel

Figure 20 Final timeline
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How to import images
Although Adobe Flash Professional CS5 provides great drawing tools of its own, you will often want to use images 
from other sources. In Flash, you can import photographs, vector drawings created in other applications, preexisting 
graphics such as company logos, and so on. As a designer, you need to decide when it’s best to create images in Flash 
and when you need to import images. You make these decisions based on design requirements, file size requirements, 
and available resources.

Image formats supported by Flash

Flash supports a range of images for import. Generally, you want to get these to their desired size and form by using 
an image-editing program before you import them into Flash.

Some of the most commonly used image formats are:

• PNG: This is the file format Adobe Fireworks CS5 uses, and Flash supports roundtrip editing between Flash and 
Fireworks. This means you can open a PNG in Fireworks from within Flash, edit it in Fireworks, and view these 
changes in Flash immediately. Any layers in the Fireworks document can be preserved in Flash.

• JPEG: This is the standard file format for web photos. JPEGs can be compressed. Use Adobe Photoshop CS5 
Extended to perform necessary compression before importing. You can also open a JPEG from within Flash, edit 
it in Photoshop or another image editor, and view these changes in Flash immediately.

• GIF and BMP: These should be optimized for file size prior to import, using Photoshop.

• Adobe Photoshop CS5 files: When importing a Photoshop file, Flash can preserve many of the attributes that 
were applied in Photoshop, and provides options for maintaining the visual fidelity of the image and further 
modifying the image.

• Adobe Illustrator CS5 vector files: You can import these into Flash, complete with vectors, layers, frames, and 
symbols.

Bitmapped and vector images

Bitmapped images are composed of different-colored pixels that combine to make an image. Graphics and 
photographs saved as GIFs or JPEGs are both bitmapped formats. When you create bitmaps, you essentially decide 
the color for each pixel.

Bitmap images are resolution dependent. This means the size and quality of the image depends on the number of 
pixels per inch in the image. Images saved for onscreen display have a resolution of 72 pixels per inch because that’s 
all most monitors can handle, whereas images saved for print can require 300 pixels per inch (or more).

In contrast to bitmaps, vector graphics are not created pixel-by-pixel. Instead, vector graphics use a series of 
commands to determine a line’s shape, location, thickness, and color. The actual shape is rendered (or drawn) on the 
screen at view time.

Flash’s native format is vector, because vector images produce smaller file sizes. However, as the previous list 
indicates, you can import bitmapped images into Flash when you need them.
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Importing images to the Stage

When you import an image to the Stage, it is also placed in the document’s library.

1. Start Flash and open the document into which you want 
to import an image.

2. Select the keyframe where the image should appear.

3. Select File > Import > Import To Stage.

The Import dialog box opens (Figure 1).

4. Browse to the folder with the desired image and select 
the image.

5. Click Open (Windows) or Import (Mac OS).

The image appears on the Stage. The image has also been 
added to the library.

Note: To edit the image, right-click the image (Windows) 
or Control-click (Mac OS) the image in the Library panel 
and select Edit With Adobe Photoshop CS5 from the 
context menu. Flash opens Photoshop, where you can 
edit the image and return to Flash after you finish.

Figure 1 Import dialog box

Importing images into the library

When you import an image into the Flash document’s library, the image is ready for use but not immediately added to 
the Flash document.

To import an image into the library:

1. Start Flash and open the document into which you want 
to import an image.

2. Select File > Import > Import To Library.

The Import dialog box opens.

3. Browse to the folder with the desired image and select 
the image.

4. Click Open (Windows) or Import To Library (Mac OS).

5. If the Library panel is not open, select Window > Library.

The image appears in the Library panel (Figure 2).

6. Select the image to preview it in the Library panel.

Figure 2 Library with imported image
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Importing a Fireworks PNG

When you import a Fireworks PNG, Flash lets you maintain editable elements of the PNG, including layers and text.

To import a Fireworks PNG:

1. Start Flash and open the document into which you want 
to import the Fireworks PNG.

2. Select the keyframe where the PNG should appear.

3. Select File > Import > Import To Stage.

The Import dialog box opens.

4. Browse to the folder with the desired PNG file and select 
it.

5. Click Open (Windows) or Import (Mac OS).

The Import Fireworks Document dialog box opens 
(Figure 3).

6. To keep layers in the source image intact, make sure 
Import As A Single Flattened Bitmap is not selected.

7. In the Import menu, select which page(s) of the source 
image you want to import. You can select all pages or you 
can select a single page.

8. Use the Into menu to indicate how you want frames to be 
imported—either as one or more movie clips or as new 
layers. 

9. Flash also asks if you want to keep PNG objects and text 
editable or import them as bitmaps to maintain their 
appearance.

• To keep image segments editable, select Keep All 
Paths Editable.

• To keep text editable, select Keep All Text Editable.

10. Click OK.

Flash imports the PNG. The image appears both on the 
Stage and in the library.

Figure 3 Import Fireworks Document dialog box
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Importing Photoshop and Illustrator images

Because programs such as Illustrator and Photoshop support layers, Flash lets you preserve these characteristics 
during import. The instructions below describe how to import an Illustrator source image—importing a Photoshop 
image is very similar.

To import an Illustator image:

1. Start Flash and open the document into which you want 
to import the Illustrator source image

Note: While there are no known issues about importing 
AI files created in earlier versions of Illustrator, Adobe 
recommends importing AI files created by using 
Illustrator CS5. If you encounter issues importing AI files 
created in earlier version of Illustrator, open the file in 
Illustrator CS5, and save the AI file as a CS5 compatible 
file and re-import it into Flash..

2. Select the keyframe where the vector file should appear.

3. Select File > Import > Import To Stage.

The Import dialog box opens.

4. Browse to the folder with the desired vector file and 
select it.

5. Click Open (Windows) or Import (Mac OS).

The Import Illustrator Document To Stage dialog box 
opens (Figure 4).

You can select which layers to import. You can choose 
whether to import layers in the source image as layers or 
as separate frames. Select each layer to set various import 
options for that layer.

Note:  If there is an Incompatibility Report button before 
the Convert Layers To menu, click it. Make changes as 
required to the Illustrator image and start the import 
process again.

6. Click OK.

Flash imports the Illustrator image, which appears on the 
Stage.

Figure 4 Import Illustrator Document To Stage 
dialog box
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Importing an XFL document

An XFL file is a type of Flash file that stores the same information as a FLA file, but in XML format. Other Adobe 
applications, such as After Effects,  can export files in XFL format. This allows you to work on a project in a separate 
application first and then continue working with it in Flash.

You can open and work with XFL files in Flash in the same way you would open an FLA file. When you open an 
XFL file in Flash, you can then save the file as a FLA file. For more information on XFL files, please see Flash help.

To import an XFL file:

1. In another Adobe application, such as After Effects, 
export your work as an XFL file. The application 
preserves all of the layers and objects of the original file 
in the XFL file.

2. In Flash, choose File > Open and navigate to the XFL 
file. Click Open.

The XFL file opens in Flash in the same way as an FLA 
file. All of the layers of the original file appear in the 
Timeline and the original objects appear in the Library 
panel.

You can now work with the file normally.

3. To save the file, choose File > Save.
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How to optimize Flash content
As with all web content, it is important to keep Adobe Flash Professional CS5 file sizes as small as possible. Even 
though connection speeds have increased in the past few years, keeping file sizes small continues to be important, 
because document size can also affect content performance, and content is now delivered on a range of devices. This 
process is known as optimizing Flash content.

The following general principles can help you optimize Flash content:

• Use symbols, animated or otherwise, for every element that appears more than once.

• When creating animation sequences, use tweened animations whenever possible. These animations use less 
file space than a series of keyframes.

• For animation sequences, use movie clips instead of graphic symbols.

• Limit the area of change in each keyframe; make the action take place in as small an area as possible.

• Avoid animating bitmap elements; use bitmap images as background or static elements.

Optimizing images

Images present one of the best opportunities for optimizing file size in Flash.

Certain fills and effects can increase the size of your Flash movie. Use the following tips to optimize these movie 
features:

• Use the Color Effect section in the Symbol Property inspector to create many different-colored instances of 
a single symbol instead of creating multiple symbols.

• Use gradients sparingly. Minimize the number of simultaneous gradients in any given frame. Filling an area 
with gradient color requires about 50 bytes more than filling it with solid color. Gradients are also more 
complex for a computer processor to handle than a solid color.

• Use alpha transparency sparingly. It can slow playback.

Optimizing bitmaps

Bitmapped images take up more space than vector images (vector is Flash’s normal format). Bitmapped images are 
imported into Flash. JPEGs, GIFs, and BMPs are all bitmapped. The best bitmap format to import into Flash is PNG, 
which is the native file format of Adobe Fireworks. All photos—which are usually in JPEG form—are bitmapped. 
When you create an animation with bitmap images, Flash must store one bitmap image in each frame of the 
animation. In addition, bitmap images, unlike vector images, do not scale or rotate well on the screen; and bitmap 
images must be rendered each time they change positions on the screen. This often entails changing large areas of the 
movie and slowing down playback as these areas are continually redrawn.

If you feel your Flash movie must include bitmaps, use the following tips to optimize your movie:

• Use bitmap images sparingly.

• Avoid animating bitmap images.

• Convert the bitmap image into a symbol if it appears in more than one keyframe.

Use the Trace Bitmap command

The Trace Bitmap command (Modify > Bitmap > Trace Bitmap) lets you convert a bitmap to a vector image. This 
works best with simple images made up of mostly large blocks of color. If the bitmap contains complex shapes and 
many colors, the converted vector graphic can have a larger file size than the original bitmap. Try a variety of settings 
in the Trace Bitmap dialog box to find a balance between file size and image quality.
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Compression options

Compression helps reduce the total file space occupied by bitmap images. JPEG compression is the default 
compression for all bitmap images published from Flash. In the Publish Settings dialog box, you can adjust the value 
in the JPEG Quality field from 1 (most compression, lowest quality) to 100 (least compression, highest quality). 
Because JPEG compression can result in a loss of image data, test images with different JPEG quality values to 
achieve the best balance between compression and image quality for your particular movie.

Optimizing sound

Sound is another factor that can increase Flash file size. There are several ways to use sound efficiently in a movie 
and keep file size down.

• Use MP3 compression, the smallest sound format, whenever possible.

• Keep sounds short.

• Use the lowest bit-depth and sample rate acceptable to achieve the smallest data size. Try to find a happy 
medium between quality and data size.

• Loop short sounds to create background music.

• Looping smaller event sounds can achieve longer audio playback because a small amount of sound data is 
downloaded once and used repeatedly.

• Do not set streaming sound to loop.

• Use the Event synch option to deliver the sound data all at once as needed for playback. Use Stream synch to 
deliver the sound data over the specified series of frames. Try both approaches. Then watch the size report 
closely for clogging of data near keyframes, and use the preloading techniques to trim down the amount of 
data needed per frame or per second. You can generate a size report for a Flash movie in the Flash tab of the 
Publish Settings dialog box (File > Publish Settings).

For more information about best practices in Flash, see the “Best Practices” section in Using Flash (Help > Flash 
Help).
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How to organize content 
Adobe Flash Professional CS5 documents can involve hundreds of different elements. Organizing these will make 
developing Flash content much easier.

Organize the library

You can create folders to organize your files in the library of a Flash document.

To create folders in the library:

1. Open a document in Flash.

2. Select Windows > Library to open the library.

3. To create a folder in the library, choose New Folder in the 
Library panel menu or click the New Folder button 
(Figure 1).

The new folder is added to the library.

Folders are represented by file folder icons.

4. Name the folder and drag files into the folder.

You can even store folders within other folders.

5. Double-click a folder icon to see or hide its contents.

Figure 1 Library organized with folders

New Folder button
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Organize layers

Organize your layers by using descriptive layer names, putting layers in a logical order, and creating folders 
(Figure 2). Use separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps 
you find these items quickly to edit them.

To organize layers:

1. To change the name of a layer, double-click the name and 
enter a new name.

2. You can change the order of layers by dragging a layer up 
or down in the stack.

Note: It is recommended that you place ActionScript in a 
layer named actions and labels in a layer named labels, 
typically at the top of the layer stack. Background layers 
go at the bottom of the stack.

3. To create a layer folder, click the New Folder button and 
give the folder a new name.

4. Drag layers into folders to keep them organized.

Figure 2 Timeline organized with folders

New Folder button
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Label keyframes

You can label certain frames to indicate when changes occur on the Timeline.

To label a keyframe:

1. Select a frame you want to label.

2. In the Property inspector, enter the label in the Name text 
box (Figure 3).

The label appears on the Timeline (Figure 4).

Note: Avoid long names to minimize file size and also to 
keep the label from spanning too many frames.

Figure 3 Name text box

Figure 4 Frame labels in Timeline

Set audio compression options

In the following steps, you set audio to stream and add the audio to the Timeline.

To set audio compression options:

1. Import audio into the Sound layer of your Flash 
document.

2. In the Property inspector, set Sync to Stream (Figure 5).

Although streaming means losing some audio quality, it 
creates a smaller SWF file and synchronizes the audio to 
the object movements on the Stage.

3. Use the frame rate and the length of the audio to figure 
how many frames down the Timeline to extend the 
sound.

4. Select the frame and extend the Timeline in the Sound 
layer by selecting Insert > Frame (Figure 6).

All the audio will be visible in the Timeline.

Note: Do not use Insert > Keyframe, because a new 
keyframe would stop the audio before it is finished.

Figure 5 Sound section of the Property inspector

Figure 6 Timeline with sound

Frame label
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How to publish a Flash document
You develop content in Adobe Flash Professional CS5 by using a Flash FLA document. These documents have a .fla 
extension and can be opened and edited in Flash.

For other people to see your movie, you publish it in a format that is accessible by other software. You use the Publish 
Settings dialog box to determine which formats to publish.

By default, the Publish command creates a Flash SWF file, an HTML document that inserts your Flash content in a 
browser window, and a JavaScript file labeled AC_OETags.js that lets your SWF file play automatically in active 
content-compliant browsers. 

You can also publish Flash files in EXE and HQX formats. Use these formats for stand-alone players when you know 
visitors do not have Flash Player installed. EXE files play on Windows; HQX files play on Mac OS.

Exporting Flash content as an image

Sometimes you may want to export Flash content as an image for use in another document. You can export Flash 
content in JPEG, PNG, or GIF format. This is similar to exporting an image in Adobe Fireworks CS5. When you 
select one of these options, Flash adds a tab to the Publish Settings dialog box that enables you to change settings for 
the image format. For example, if you select the JPEG format, Flash adds a JPEG tab that lets you change 
compression settings for the exported JPEG.

To export Flash content as an image:

1. Open a document in Flash.

2. Select File > Publish Settings on the menu bar.

If this is the first time you’ve opened the Publish Settings 
dialog box, it opens with the Formats tab selected 
(Figure 1).

3. In the Formats tab, select the types of files to produce 
when you publish the movie.

4. If you want to change the names of any of the files to be 
published, enter new names in the text boxes under File.

By default, every file type uses the same name as the 
FLA file. Only the file extensions are different.

5. Click the folder icon to the right of the filename if you 
want to select a different location in which to publish 
files.

By default, files are published in the same folder as the 
FLA file.

Figure 1 Publish Settings dialog box
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6. Click the Flash tab.

The Flash tab of the Publish Settings dialog box opens 
(Figure 2).

7. To change the Flash version supported by the Flash 
content, use the Player pop-up menu.

By default, version is set to Flash Player 10. If you know 
your visitors will have an earlier version installed, select 
the appropriate version in the menu. You can also select 
options for Apple iPhone applications or Adobe AIR 
here.

8. To control bitmap compression, adjust the JPEG Quality 
slider or enter a value.

Lower image quality produces smaller files; higher image 
quality produces larger files. Try different settings to 
determine the best trade-off between size and quality.

9. To set the sample rate and compression for all sounds in 
the SWF file, click the Set button next to Audio Stream 
or Audio Event and select options for Compression, Bit 
Rate, and Quality in the Sound Settings dialog box. Click 
OK when you finish.

10. Click Publish.

The movie is published in each of the formats you 
selected. Figure 2 Flash tab of Publish Settings dialog box

To publish a movie without changing publish settings, select File > Publish on the menu bar.
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How to work with text
Adobe Flash Professional CS5 lets you add text to a Flash application in two formats:

• A new text format called the Text Layout Framework (TLF).

• The previous text format called Classic text.

Using the Text Layout Framework

TLF text provides the following enhancements over Classic text:

• You can adjust a wider range of character aspects, such as leading and tracking.

• You can rotate text more easily.

• You can flow text across multiple containers, as it does in a magazine page layout.

• You can better control the attributes of Asian text.

• You can create right-to-left text.

The Text Layout Framework is available as an option in the Text Property inspector. 

TLF text requires that ActionScript 3.0 and Flash Player 10 or later are specified in the publish settings of your FLA 
file. See the guide “How to Publish a Flash Document” for more details.

To create TLF text:

1. Start Flash and choose File > New (ActionScript 3.0). 

2. On the Timeline, double-click a layer, name it, and press 
Enter (Windows) or Return (Mac OS).

3. Click the Text tool.

4. Make sure the Property inspector is open. If not, select 
Window > Properties.

5. Select TLF Text from the Text Engine pop-up menu 
(Figure 1).

6. Move the pointer to the Stage.

The pointer changes to a cross hair with the letter T 
attached to it.

7. Drag to create a container (Figure 2).

8. Release the mouse button and click in the container.

9. Type some text (Figure 3).

Figure 1 Text Engine pop-up menu.

Figure 2 Dragging to create a container

Figure 3 Text added to container
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Managing text flow for TLF text

In Flash, you’ve probably noticed that a red plus appears in a TLF text container when you fill it with more text than 
fits. This red plus indicates the text is overset. Overset text is text that does not fit in the container.You could solve the 
problem of overset text by making the container bigger, but often you will want to continue the text in another 
container, either on the same page or on another page. This is called text flow. 

For example, in Figure 4 the upper container is overset and needs to flow to the lower text container.

Figure 4 Overset text

In Figure 5, the two containers have been linked, as indicated by a line between the Out port of the top container and 
the In port of the bottom container.

Figure 5  Linked containers

Out port of text container
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To flow text:

1. Use the Selection tool to select a container.

2. Click the Out port in the lower right corner of the 
selected container.

The pointer changes to the loaded text icon, an arrow 
with small lines of text (Figure 6).

3. Then do one of the following:

• To link to an existing container, position the pointer 
over the target container. The pointer changes to the 
link text icon, an arrow with chain links (Figure 7). 
Click the container to link the two containers.

• To link to a new container, click or drag on an empty 
part of the Stage. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you determine the size of the container (Figure 8).

The containers are now linked and text will flow between 
them (Figure 9).

Figure 6 Loaded text icon

Figure 7 Link text icon

Figure 8 Linking to a new container

Figure 9 Result of linking to a text contaier
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Using Classic text

You can specify three types of Classic text in the Property inspector: Static, Dynamic, and Input. The default type is 
Static. Use Static text when the text will not change, such as button and form labels. Use Dynamic text for text that 
will change as the movie plays, such as text pulled from an external database in response to viewer’s request. Use 
Input text for requesting input from the viewer, such as a user name and password—input text is similar to a form 
field.

To use Classic text:

1. Start Flash and open a new Flash document (ActionScript 
3.0).

2. On the Timeline, double-click a layer, name it, and press 
Enter (Windows) or Return (Mac OS).

Naming layers helps keep the Timeline organized.

3. In the Tools panel, select the Text tool.

4. Make sure the Property inspector is open. If not, select 
Window > Properties.

5. Select Classic Text from the Text Engine pop-up menu.

6. In the Property inspector, make sure that Static Text is 
selected in the Text Type menu (Figure 10).

Note: You can also select Dynamic text for information 
that can be updated—for example, a text display of 
current news generated from an external file or 
database—or Input text for text entered by a site visitor, 
such as information in completing a form.

7. Move the pointer to the Stage.

The pointer changes to a cross hair with the letter T 
attached to it.

8. To create an expanding-width text field, click on the 
Stage.

The text field contains a flashing insertion point. This is 
where text will appear as you type. The round handle 
indicates that the text field is an expanding-width one-
line static text field (Figure 11).

9. Type the text.

The text field expands as you type.

10. Click away from the text to deselect it.

11. To create a fixed-width text field, drag approximately a 
half inch on the Stage.

A text field is created. This text field has a square handle 
in the upper right corner (Figure 12). The square handle 
indicates that the text field is a fixed-width static text 
field.

Figure 10 Text Type menu

Figure 11 Expanding-width one-line static text 
field

Figure 12 Fixed-width static text field

Round handleInsertion point

Insertion point Square handle
How to work with text © 2010 Adobe Systems Incorporated



Adobe Flash Professional CS5 Activity 6.1 guide
12. Type the text.

The text you type wraps to a new line when it reaches the 
right edge of the text field.

13. Drag the square handle to the right until the text is on a 
single line.

Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box.

14. Click away from the text to deselect it.

Formatting both TLF and Classic text

You can apply basic character formatting to TLF or Classic text, such as font family, font type, font style, and font 
color. You can also adjust tracking, adjust leading, and apply anti-aliasing to both formats.

To apply basic formatting to text:

1. Choose the Text tool. 

2. Select some text in the container (TLF) or field (Classic) 
with text.

3. In the Character section of the Property inspector, choose 
a different font family in the Font Family pop-up menu, 
such as Verdana (Figure 13).

4. Choose a different font style, such as italic or bold.

5. Set a different font size, such as 14, by using the Size 
scrubber. (You can also click the scrubber and type a 
value for Size.).

6. Choose a different font color by clicking the Color box 
and doing one of the following:

• Select a color from the Color menu (Figure 14).

• Type a color’s hexadecimal value in the box in the 
upper left corner.

• Click Color Picker and select a color from the 
system color picker. (When setting the text color, use 
only solid colors, not gradients. To apply a gradient 
to text, break the text apart and convert the text to its 
component lines and fills.)

7. In the Paragraph section of the Property inspector, choose 
an alignment for the text, such as left, centered, right, or 
justify.

Note: For TLF text, Flash provides additional Justify 
alignment options for the last line of text, such as Justify 
With Last Line Aligned To Start or  Justify With Last 
Line Aligned To Center.

Figure 13 Applying basic formatting to text

Figure 14 Color menu

Enter hexidecimal 
value here

Opens System 
Color Picker
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Adjusting leading and tracking

To improve readability and meet design goals, you can adjust the spacing between lines and characters—leading and 
tracking—for both TLF and Classic text.

Adjusting leading

Leading refers to the space between lines. In Classic text, leading is referred to as line spacing. You’re probably used 
to differentiating between single-spaced and double-spaced text. By adjusting leading, you can fine-tune the space 
between lines. By default, leading is set to 120% of the text’s height for TLF text and 0 for Classic text.  

To adjust leading:

1. Select some text.

2. Do one of the following:

• For TLF text, drag the Leading scrubber in the Text 
Property inspector (Figure 15). You can also enter a 
numeric value by clicking the scrubber.

• For Classic text, drag the Line Spacing scrubber in 
the Text Property inspector (Figure 19). You can 
also enter a numeric value by clicking the scrubber.

For example, leading of 150 was applied to the 30-point 
text in Figure 20.

Figure 15 Leading scrubber in the Text Property 
inspector

Figure 16 Line Spacing scrubber in the Property 
inspector

Figure 17 Leading applied
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Adjusting tracking

Tracking refers to the space between characters across a line of text. In Classic text, tracking is referred to as letter 
spacing. You adjust tracking to space the letters further apart or closer together. (You will usually not want to reduce 
tracking unless you’ve already increased it.)

To adjust tracking:

1. Select some text.

2. Do one of the following:

• For TLF text, drag the Tracking scrubber in the Text 
Property inspector (Figure 18). You can also enter a 
numeric value by clicking the scrubber.

• For Classic text, drag the Letter Spacing scrubber in 
the the Character area of the Text Property inspector 
(Figure 16). You can also enter a numeric value by 
clicking the scrubber.

For example, tracking of 110 was applied to the 30-point 
text in Figure 17.

Figure 18 Tracking scrubber in the Property 
inspector

Figure 19 Letter Spacing scrubber in the Property 
inspector

Figure 20 Tracking applied
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Applying anti-aliasing

Anti-aliasing lets you smooth the edges of onscreen text. Anti-aliasing is especially useful for small font sizes. When 
anti-aliasing is enabled, all text in the current selection is affected. Anti-aliasing operates with text of all point sizes in 
the same way. You can apply anti-aliasing to TLF text or Classic text.

You can select from the following anti-aliasing options:

Use Device Fonts: The SWF file will use fonts installed on the viewer’s computer to display the fonts. This option 
doesn’t increase the size of the SWF file.You should use this option only with commonly installed fonts, such as 
Verdana or Arial.

Readability: Allows for improved legibility of embedded fonts, particularly at small sizes. To use this option, you 
must embed the font. When you embed fonts, Flash copies the font into the SWF file so that the font does not need to 
be present on the viewer’s computer. This increases the size of the SWF file slightly.

Animation: Creates a smoother animation of text by ignoring alignment and kerning information. To use this option, 
you must embed the font. When you embed fonts, Flash copies the font into the SWF file, so that the font does not 
need to be present on the viewer’s computer. This increases the size of the SWF file slightly. Animation anti-aliasing 
will be hard to read if font size is smaller than 10 points.

For Classic text, you can select two additional anti-aliasing options:

Bitmap Text (No Anti-alias): Useful for displaying small font sizes. Bitmap fonts do not contain outlines, which helps 
keep the file size of a published Flash document to a minimum.

Custom Anti-alias: Modify thickness and sharpness to control the effect anti-alias has on your text.

To set anti-aliasing:

1. Choose the Text tool.

2. Click in the container (TLF) or field (Classic) with text.

3. Choose an anti-aliasing option, such as Readability, from 
the Anti-Alias pop-up menu (Figure 21).

The Font Embedding Warning dialog box opens if you 
selected Readability or Animation after selecting Use 
Device Fonts (Figure 22). 

Figure 21 Anti-Alias pop-up menu for TLF text

Figure 22 Font Embedding Warning dialog box
How to work with text © 2010 Adobe Systems Incorporated
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4. Click Embed.

The Font Embedding dialog box opens (Figure 23).

5. Click OK.

Fonts will now be embedded with the SWF movie.

Figure 23 Font Embedding dialog box

Applying filters to text

To add interest or fulfill other design goals, you can apply graphics filters to both TLF and Classic text in  Flash. 
These filters can make text appear to be raised, give text a shadow, or give text a glow. Graphics filters are available 
in the Filters section of the Property inspector.

Applying the Drop Shadow filter to text

The Drop Shadow filter makes it appear that text or an object is casting a shadow.

To add the Drop Shadow filter to text:

1. Start Flash and open the document you want to edit.

2. Use the Selection tool to select the container (TLF) or 
field (Classic) with text.

Note: You cannot select the text itself to apply the filter.

3. In the Property inspector, display the Filters section 
(Figure 24).

If the Property inspector isn’t visible, select Window > 
Properties. You may need to scroll down to see the Filters 
section because it's at the bottom of the panel.

4. Click the Add Filter button in the lower left corner of the 
panel.

Figure 24 Filters section of the Property inspector

Add Filter button
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5. Select Drop Shadow in the Filters menu (Figure 25).

The Drop Shadow filter is applied to the text (Figure 26).

You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Property 
inspector (Figure 27).

Figure 25 Filters menu

Figure 26 Drop shadow applied

Figure 27 Drop shadow properties

Other graphics filters

You can apply several other graphics filters to text to create interesting visual effects.

Blur

The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear to be behind 
other objects, or make an object appear to be in motion.  Adjust the amount and direction of blur by using the X and 
Y text boxes.
How to work with text © 2010 Adobe Systems Incorporated
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Glow

The Glow filter lets you apply a color around the edges of an object.

• Glow: Make the object appear to shine.

• Inner Glow: Apply the glow only within the boundaries of the object.

• Knockout: Remove the object and leave the glow. The object appears outlined in glow.

Bevel

Applying a bevel applies a highlight to the object that makes it appear to be raised above the background surface.

• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object.

• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object.

• Full Bevel: Apply both inner bevel and outer bevel effects to the object.

You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it.

Gradient Glow

Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color.

Gradient Bevel

Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, with 
a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the gradient 
with an Alpha value of 0.

Adjust color

You can use the Adjust Color filter to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue.

• Brightness: Make the object brighter or darker.

• Contrast: Increase or decrease the distinction between light and dark.

• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue.

• Hue: Increase or decrease the shade of the color.
© 2010 Adobe Systems Incorporated How to work with text 11
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How to create transitions with motion tweens
You may have noticed from watching television or movies that transitions are a subtle but important part of telling a 
story. For example, dissolving between images can indicate a passage of time. On the web, you can use transition 
effects to create moods and to help keep your visitors interested. You can use transitions to focus the visitor’s 
attention or to indicate a preferred path through your site. One way to create transitions in Adobe Flash Professional 
CS5 is to apply effects to a motion tween.

Rotation

In the Property inspector, you can add rotation to any motion tween. Rotation can draw attention to content that is 
entering or exiting the Stage.

To add rotation to a motion tween:

1. Open an existing Flash document or create and save a 
new Flash document.

2. Add a symbol to the Stage and make sure it is alone on its 
own layer. 

By default the symbol is placed in the first keyframe of 
the timeline. This will be the first frame and starting 
symbol position for the motion tween.

3. Decide how much time is required for the symbol to 
move to or from the Stage.

This tells you where to place the ending frame for the 
motion tween.

4. Insert the ending frame accordingly on the Timeline 
(Figure 1).

Note: If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline. 

5. Select the layer in the Timeline and select Insert > 
Motion Tween.

6. In the last keyframe, use the Selection tool to move the 
object to its ending position (Figure 2). Notice the 
appearance of the motion path.

Note: You might want to add multiple effects, such as 
changing size or fading to make the object appear to 
grow or fade in while it enters or fade out and shrink as it 
exits.

• Changing size: Reduce or increase the image 
percentage in the Transform panel with the Constrain 
options selected.

• Fading: Select the symbol and select Alpha from the 
Style menu in the Color Effect section of the 
Property inspector. Adjust the alpha setting to 
increase or decrease transparency.

Figure 1 Flash Timeline

Figure 2 Motion tween end position
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7. With the tween layer selected, display the Rotation 
section of the Property inspector. Select CW (clockwise) 
or CCW (counterclockwise) from the Direction pop-up 
menu (Figure 3).

8. For Rotate, enter the number of times you want the 
symbol to rotate (Figure 4).

9. In the Options section, select the Sync Graphic Symbols 
option.

This synchronizes the motion to the number of frames in 
the Timeline.

10. Save the movie.

11. Select Control > Test Movie > In Flash Professional to 
test the movie.

12. Select File > Close to close the preview window.

Figure 3 Direction menu in the Rotation section

Figure 4 Rotate amount

Change frame rate

The document’s frame rate determines how fast the playhead moves. A frame rate 12 frames per second (fps) usually 
gives the best results on the web. You can set the frame rate to any number between 0.01 and 120. QuickTime and 
AVI movies generally have a frame rate of 12 fps, while the standard motion picture rate is 24 fps. Performance of a 
Flash movie is likely to suffer at frame rates of 16 fps or higher. With larger movies, increasing the frame rate 
increases the size of your published document.

In short, if you want to change the timing of an animation, it’s usually better to change the number of frames than to 
change the frame rate.
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To change the frame rate:

1. Click away from any objects on the Stage.

Document properties are shown in the Property inspector.

2. For FPS (in the Properties section), type 15 and press 
Enter (Windows) or Return (Mac OS).

3. Select Control > Test Movie > In Flash Professional to 
test the movie.

Observe that the animation plays faster.

4. Change the FPS value to 6 and press Enter (Windows) or 
Return (Mac OS).

5. Select Control > Test Movie > In Flash Professional to 
test the movie.

Observe that the animation plays much more slowly.

6. Select File > Close to close the preview window.

Fading

By creating a motion tween with different alpha settings, you can fade images in and out.

To fade images in and out:

1. Start Flash and open the document you want to edit.

2. Locate the layer and keyframe that contain the symbol 
you plan to fade. 

This will be the starting frame for the fade.

3. Make sure the symbol is alone on its own layer.

4. Decide how much time is required for the symbol to 
complete the transition. 

This tells you where to place the ending frame for the 
motion tween.

5. Insert the ending frame accordingly on the Timeline. 
Then, with the layer selected, select Insert > Motion 
Tween.

Note:  If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline. 

6. Select the starting frame for the transition and click the 
symbol to select it.

7. To display the Motion Editor, click the Motion Editor tab 
next to the Timeline tab (Figure 5) or select Window > 
Motion Editor.

Note: The Motion Editor displays all tween properties 
and their property keyframes. It also provides tools for 
adding precision and detail to tweens. The Motion Editor 
displays the properties of the currently selected tween.

Figure 5 Timeline and Motion Editor tabs
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8. In the Motion Editor, scroll down to the Color Effect 
category and open it by clicking the disclosure triangle, if 
there is one.

If Alpha does not already appear in the Color Effect 
category, click the plus icon to the right of Color Effect, 
and select Alpha from the pop-up menu (Figure 6).

9. For Alpha Amount, enter 0% (Figure 7).

Note: The object will disappear from the Stage, but the 
blue outline is visible when the symbol is selected.

10. Return to the Timeline, select the final frame, and adjust 
the Alpha of the symbol to 100% in the Motion Editor.

11. Save the movie.

12. Select Control > Test Movie > In Flash Professional to 
test the movie.

The symbol fades in.

Note: To create a fade-out, leave the Alpha Amount 
setting at 100% on the starting keyframe and change the 
Alpha Amount setting on the ending keyframe to 0%.

13. Select File > Close to close the preview window.

Figure 6 Adding Alpha property to Motion Editor

Figure 7 Alpha Amount
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Color fades

You can use color fades to draw the viewer’s attention to an object onscreen. To create a color fade, apply a motion 
tween between two instances of the same symbol, and then change the color of the instances in the starting and 
ending frames.

To create a color fade:

1. Start Flash and open the document you want to edit.

2. Locate the layer and keyframe that contain a movie clip 
symbol.

This will be the starting keyframe for the color fade.

3. Make sure the symbol is alone on its own layer.

4. Decide how much time is required for the symbol to 
complete the transition.

This tells you where to place the ending frame for the 
motion tween.

5. Insert the ending frame accordingly in the Timeline. 
Select the layer in the Timeline and choose Insert > 
Motion Tween.

Note: If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline.

6. Select the starting frame for the transition and select the 
symbol.

7. In the Motion Editor, scroll down to the Filters category 
and open it by clicking the disclosure triangle, if there is 
one. (Figure 8).  

If Adjust Color does not already appear in the Filters 
category, click the plus icon to the right of Filters, and 
select Adjust Color from the pop-up menu (Figure 8).

8. Use the Hue scrubber to select a new color by changing 
the value (Figure 9).

As you change the value, notice the changing color of the 
symbol on the Stage.

9. When you have selected a color, save the movie.

10. Select Control > Test Movie > In Flash Professional to 
test the movie.

11. Select File > Close to close the preview window.

Figure 8 Adding Adjust Color property to Motion 
Editor

Figure 9 Hue scrubber
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Flipping images

Flipping images and then creating a motion tween can create an effective transition between images of roughly the 
same size. The trick is to flip the first image half way and then start fading in the second image while the first image 
is still flipping to make a smooth transition.

To flip an image:

1. Start Flash and open the document you want to edit.

2. Locate the exiting object on Layer 1 and the entering 
object on Layer 2 (Figure 10). Position the symbols in 
roughly the same position on the Stage.

3. Rename Layer 1 exiting object. Rename Layer 2 
entering object (Figure 11).

4. Decide how much time is required to complete the 
transition. 

This tells you where to place the ending frames for each 
of the images for the motion tweens.

5. Insert the ending frames accordingly in the Timeline. For 
each image, select the layer in the Timeline and choose 
Insert > Motion Tween.

6. Click the first frame for the motion tween in the entering 
object layer. In the Motion Editor, add an Alpha color 
effect and set the Alpha Amount to 0% (Figure 12).

7. Click the first frame for the motion tween in the exiting 
object layer,  add an Alpha color effect and set the Alpha 
Amount to 100%.

8. Click the last frame for the tween in the entering object 
layer in  and set the Alpha Amount to 100%.

9. Click the last frame for the tween in the exiting object 
layer and set the Alpha Amount to 0%.

10. In the Timeline, click the entering object layer in the 
middle of the tween, and select Modify > Transform > 
Flip Horizontal.

The entering object is flipped around a vertical axis 
through its center.

Note: Instead of Flip Horizontal, you can select Flip 
Vertical. As long as both exiting and entering objects flip 
the same way, the transition will work. Select the same 
type of flip for the exiting object as for the entering 
object.

11. Click the exiting object layer in the middle of the tween, 
and select Modify > Transform > Flip Horizontal..

The exiting object is flipped around a vertical axis 
through its center.

Figure 10 Two image symbols in two layers

Figure 11 Renamed layers

Figure 12 Adding an Alpha color effect
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12. Click the first frame of the entering object’s motion 
tween. Display the Eases category in the Motion Editor 
and change the Simple (Slow) easing to –100% 
(Figure 13).

Changing the easing value adjusts the rate of change 
between tweened frames. Negative easing values cause 
the motion tween to begin slowly and accelerate at the 
end of the tween. A positive value causes the tween to 
begin rapidly and decelerate at the end. The animation 
still takes the same amount of time, regardless of the 
easing value.

13. Select Control > Test Movie > In Flash Professional to 
test the movie.

14. Select File > Close to close the preview window.

Figure 13 Eases section of the Motion Editor 
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Motion presets

You can also add motion presets to your tweened symbol. Motion presets are preconfigured motion tweens you can 
apply to an object on the Stage. You simply select the symbol and click the Apply button in the Motion Presets panel.

To add a motion preset to your symbol:

1. Open an existing Flash document or create and save a 
new Flash document.

2. Create a shape and convert it to a symbol.

3. Display the Motion Presets panel by selecting Window > 
Motion Presets.

You can preview the Motion Presets by clicking on a 
preset from the list of Default Presets (Figure 14).

4. To apply a motion preset to the symbol on the stage, click 
the Apply button.

5. Click the Motion Editor tab to find the properties for the 
preset you have just applied. Make any changes you like 
in the Motion Editor.

6. After making changes to any motion settings in the 
Motion Editor, save your customized motion preset by 
clicking the Save Selection As Preset button in the lower-
left corner of the Motion Presets panel (Figure 15).

7. Type a name for your custom preset and click OK.

You will now see your motion preset under the Custom 
Presets folder of the Motion Presets panel. You can apply 
your custom motion presets to other tweens in this file or 
new files. Using presets can save significant production 
time during design and development of your projects, 
especially if you use similar kinds of tweens often.

8. Save the movie.

9. Select Control > Test Movie > In Flash Professional to 
test the movie.

10. Select File > Close to close the preview window.

Figure 14 Motion Presets panel

Figure 15 Save Selection As Preset icon 
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How to create visual effects
With Adobe Flash Professional  CS5 filters (graphics effects), you can add interesting visual effects to text, buttons, 
and movie clips. You can change text, shapes, and symbols in many ways by adding filters. This guide illustrates how 
to apply specific effects to shapes, how to edit effects, and how to remove effects. You can apply any number of 
effects by using this technique.

Creating visual effects

In the following steps, you first create a shape, then apply a filter to it.

To create a visual effect:

1. Open an existing Flash document or create and save a 
new Flash document.

2. From the Tools panel, select the Rectangle tool 
(Figure 1).

3. For the Rectangle tool, specify rounded corners by 
clicking the Round Rectangle modifier in the Property 
inspector and entering a corner radius value, such as 25 
(Figure 2).

A value of zero (0) creates square corners.

4. To create a rectangle shape, drag the Rectangle tool on 
the Stage.

For the Rectangle tool, Shift-drag to constrain the shape 
to squares. (Similarly, you can draw perfect circles by 
Shift-dragging the Oval tool.)

5. You will need to convert the shape to a symbol. Select the 
rectangle or several elements on the Stage. Do one of the 
following:

• Select Modify > Convert To Symbol.

• Drag the selection to the Library panel.

• Right-click (Windows) or Control-click (Mac OS) 
and select Convert To Symbol from the context 
menu.

Figure 1 Shape tool options

Figure 2 Adjust rectangle options

Round Rectangle modifier
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6. In the Convert To Symbol dialog box, type the name of 
the symbol and select the Movie Clip type (Figure 3).

Note: Symbol types include Movie Clip, Button and 
Graphic, and provide different filter options. 

• Use graphic symbols for static images and to create 
reusable pieces of animation that are tied to the main 
Timeline.

• Use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other actions.

• Use movie clip symbols to create reusable pieces of 
animation.

7. Click OK.

Flash adds the symbol to the library.

8. Select the rectangle object to apply a filter.

9. In the Filters section of the Property inspector, click the 
Add Filter button, and select a filter, such as the Bevel 
filter (Figure 4). 

The filter is applied to the object (Figure 5).

10. Experiment with the filter settings (Figure 6) until you 
get a look you like (Figure 7).

Figure 3 Convert To Symbol dialog box

Figure 4 Add Filter menu in the Property inspector

Figure 5 Bevel filter applied to rectangle

Figure 6 Bevel filter settings

Figure 7 Modified Bevel filter applied to rectangle

Add Filter button
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Removing and disabling visual effects

You can remove or disable an effect after you have applied it.

To remove or disable an effect:

1. Select the object from which you want to remove a filter.

2. In the Property inspector, select the filter you want to 
remove.

3. Click the Delete Filter button at the bottom of the Filters 
section of the Property inspector (Figure 8).

The effect is removed.

You can also enable or disable a filter applied to an object 
by clicking the Enable Or Disable Filter button.

Figure 8 Filters section of the Property inspector

Enable Or 
Disable Filter

Delete Filter
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How to use transparent or invisible buttons
Recall that the Hit state of a button is not visible. If you create a button with no graphics in the Up, Over, or Down 
states, the button will be transparent. However, you can control how a transparent button will operate when a visitor 
clicks within the hit area. You can use transparent buttons in Adobe Flash Professional CS5 in the same way you use 
hot spots in an image map in Adobe Dreamweaver CS5.

Create a button

Your first step is to create an ordinary button.

To create a button:

1. Start Flash and create a new Flash file (ActionScript 3.0).

2. Rename Layer 1 Graphics.

3. Insert a new layer and name it Button.

4. On the Graphics layer, add a photo or a graphic to the 
Stage.

The document illustrated in Figure 1 contains a photo of 
San Francisco. You can place transparent buttons over 
different areas of a photograph. Viewers can then click 
different parts of the photo to navigate to information 
about the subjects in the photograph. 

In this activity, you create a transparent button used to 
turn the hillside (in the background) into a clickable area 
linked to more information.

5. Select the Button layer.

6. Select the Rectangle tool.

7. Choose any color for the fill.

8. Set Stroke Color to No Color.

9. Draw a rectangle over an area in the photograph or 
graphic to which you want to add a button (Figure 2).

10. Select the Selection tool.

11. Click the rectangle to select it.

12. Select Modify > Convert To Symbol.

13. In the Convert to Symbol dialog box, type a name for the 
button in the Name text box.

14. Select Button as the Type.

15. Click OK.

The button is added to the library and an instance is 
added over the photograph on the Stage.

Figure 1 Photograph 

Figure 2 Rectangle drawn over hill

Shape used to create the button 
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Make a button transparent

In the following steps, you will add a keyframe to the Hit frame of the Button symbol timeline, then delete the button 
in the Up frame. The result is a button that is active, but not visible in the Flash document.

To make a button transparent:

1. On the Stage, double-click the button instance.

The button opens in symbol-editing mode. On the 
Timeline, the Up frame is selected.

2. Add a keyframe to the Hit frame.

3. Select the Up frame.

4. Press Delete.

The colored rectangle representing the button on the 
Stage of the Up frame is deleted.

The Hit frame should be the only frame containing a 
colored rectangle on the Stage. The Up, Over, and Down 
frames are empty, which makes the button invisible. 
(Figure 3).

5. On the edit bar, click Scene 1.

The button is now transparent. Although you can still see 
it in the Flash authoring environment (Figure 4), the 
button will not be visible when the movie plays.

In this example, the button represents the hills. You can 
now link this button to information about this part of the 
photo. 

6. Save the file.

Figure 3 Only the Button Hit frame has content

Figure 4 Transparent button over the photograph 
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Add ActionScript to launch a website

In the following steps, you will add ActionScript to the transparent button which instructs Flash to open a web page 
when a user clicks the button.

To add ActionScript to the button:

1. Select the button instance you want to use to launch a 
web page. Use the Instance Name text box in the 
Property inspector to give the button a unique instance 
name (Figure 5).

In this example, there is one instance of the 
invisible_button button on the Stage (Figure 4). This 
instance is named hills_button (Figure 5), and is placed 
over the hills in the photograph.

2. In the main timeline of your movie, create a new layer 
named Actions.

3. Create a keyframe in the Actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the Actions layer.

Note: If your button doesn’t appear on this frame, Flash 
will generate an error message when you publish the 
movie, because the ActionScript you include on this 
frame refers to an object that isn’t on the Stage yet.

4. Select Window > Actions to display the Actions panel.

5. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.

6. In the Actions toolbox on the left side of the panel, 
expand Flash.Events, EventDispatcher, and Methods. 
Double-click AddEventListener.

The AddEvent listener is added to the Script pane of the 
panel (Figure 6).

7. Click in the Object box in the parameters area of the 
Actions panel.

The Insert A Target Path button is now active.

8. Click the Insert A Target Path button.

The Insert Target Path dialog box opens (Figure 7).

9. Select the Relative option, select the instance name of 
your button, and click OK.

10. In the Actions toolbox on the left side of the panel, 
expand Flash.Events, MouseEvent, and Properties. 
Locate the CLICK Property.

11. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then click in the 
Type box in the parameters area.

Figure 5 Button Property inspector

Figure 6 AddEventListener method in the Actions 
panel

Figure 7 Insert Target Path dialog box

Instance Name
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12. In the Actions toolbox, double-click the CLICK property.

Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 8).

13. In the Listener box in the parameters area, type a name 
for the function that should execute when a user clicks 
the button. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces. (example: openURL) 

The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.

14. In the Actions toolbox, expand Language Elements, 
Statements, Keywords & Directives, and Definition 
Keyword. 

15. Double-click Function in the Actions toolbox.

The code for creating a function appears in the Script 
pane.

16. In the parameters area of the Script pane, type the name 
of your function in the Name box.

Note: The function name must be typed exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive.

17. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters box (Figure 9).

In this box, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

18. In the Actions toolbox on the left side of the panel, 
expand Flash.Net and Methods. 

19. Select the function line in the Script pane and double-
click the NavigateToURL method in the Actions toolbox.

The method is added to the function (Figure 10).

Figure 8 CLICK property in the Actions pane

Figure 9 Function parameters

Figure 10 NavigateToURL method in the Actions 
panel

Function parameters
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20. In the Request box, type:

new URLRequest(“http://www.adobe.com”) 
(Figure 11).

Note: You can replace www.adobe.com with a web 
address of your choice.

21. Collapse the Actions panel.

22. Save the document.

23. Select Control > Test Movie > In Flash Professional to 
test the button.

24. Click the area of the graphic on which you created the 
invisible button.

A browser window opens and navigates to the website 
you defined for the button.

Figure 11 URL entered in the Request box

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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	How to use filmmaking techniques
	Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating websites and digital movies. With Adobe Flash Professional CS5, you can simulate traditional film techniques. As you design Flash movies, think ...
	Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating websites and digital movies. With Adobe Flash Professional CS5, you can simulate traditional film techniques. As you design Flash movies, think ...
	You can create the following popular filmmaking techniques with Flash:
	• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the camera up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a scene is known as a zoom.
	• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the camera up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a scene is known as a zoom.
	• Pan, tilt, and zoom effects

	• Camera angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect of your subject.
	• Camera angles

	• Cross fades: One image appears to fade in while another fades out, a transitional effect for moving from one image to another.
	• Cross fades

	• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can focus viewers on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a “boing” or tire screech.
	• Bounce effect



	Create a pan, tilt, or zoom effect by using classic tweens
	Create a pan, tilt, or zoom effect by using classic tweens
	To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention on a particular...
	To create a pan and zoom effect:
	To create a pan and zoom effect:
	1. Open an existing Flash document or create and save a new Flash document (ActionScript 3.0).
	2. To import an image directly into the current Flash document, select File > Import > Import To Stage.
	3. If your image is not already a symbol, convert it to a movie clip symbol 
	(Figure 1)
	Be sure the Stage is smaller than the image.

	4. In the Timeline, select the keyframe where you want the pan to end and select Insert > Timeline > Keyframe 
	(Figure 2)

	5. Select the ending keyframe. Drag the instance of the movie symbol to the opposite side of the workspace.
	<GRAPHIC>
	<GRAPHIC>
	Figure 1 Image converted to symbol

	<GRAPHIC>
	<GRAPHIC>
	Figure 2 Insert a keyframe

	6. Click in the Outline column to the right of the name for the layer that contains the movie symbol 
	(Figure 3)
	Note: You can more easily see the border of an image if you set the layer holding the image to outline mode (especially if the image contains a lot of grays that can fade into the area outside the Stage). Be sure the image does not slide off the Stag...
	Note: You can more easily see the border of an image if you set the layer holding the image to outline mode (especially if the image contains a lot of grays that can fade into the area outside the Stage). Be sure the image does not slide off the Stag...


	7. Select the starting frame and select Insert > Classic Tween. 
	This classic tween moves the movie symbol horizontally across the Stage (a pan). The second keyframe that ends the classic tween will also serve as the starting point for the next tween.

	8. Add a third keyframe further along in the time line to serve as the ending point of the second classic tween (a zoom) 
	(Figure 4)

	9. Select the third keyframe and select Modify > Transform > Scale. 
	Transformation handles appear on the image 
	(Figure 5)


	10. Shift-drag one of the corner transformation handles to resize the image approximately three times its original size. 
	The image expands.

	11. Select the second keyframe and select Insert > Classic Tween, creating a classic tween between the second and third keyframes.
	12. In the Property inspector, increase the easing to a value between 60 and 100 for the classic tween 
	(Figure 6)
	The zoom will start quickly and slow down as it arrives at the resting point.

	13. In the Timeline panel, click the New Layer button.
	14. Rename the new layer 
	actions
	(Figure 7)

	15. Select the last frame of the actions layer and insert a new keyframe.
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	Figure 3 Image outlined
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	Figure 4 Keyframe for zoom
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	<GRAPHIC>
	Figure 5 Outline image with transformation handles

	<GRAPHIC>
	<GRAPHIC>
	Figure 6 Property inspector

	<GRAPHIC>
	<GRAPHIC>
	Figure 7 New Layer button in the Timeline

	16. Select Window > Actions to display the Actions panel. 
	The Actions panel opens 
	(Figure 8)

	Note: If the Actions toolbox is hidden, click the triangle or drag the vertical bar to open. If you don’t see the parameters area in the Actions panel, click the Script Assist button.
	Note: If the Actions toolbox is hidden, click the triangle or drag the vertical bar to open. If you don’t see the parameters area in the Actions panel, click the Script Assist button.


	17. You need to place a stop command at the end of the timeline to end the movie clip. In the Actions toolbox on the left side of the panel, choose flash.display > MovieClip > Methods. 
	18. Double-click or drag the stop item to the script pane. 
	Note: You can also locate the stop and other methods by using the Index located at the bottom of the Actions toolbox.
	Note: You can also locate the stop and other methods by using the Index located at the bottom of the Actions toolbox.


	19. In the Script pane, select the stop method. Then click in the Object text box in the parameters area of the Actions panel. 
	The Insert Target Path button is now active.

	20. Click the Insert Target Path button. 
	The Insert Target Path dialog box appears 
	(Figure 9)


	21. Select the Relative option and select the movie clip you want to play when viewers click the button. If you want the movie in the main timeline to play, select root to set the target path to this.
	22. Click OK to close the Insert Target Path dialog box. 
	The Script pane shows the correct code for stopping the movie 
	(Figure 10)


	23. Close the Actions panel.
	24. To test how the SWF file works before you publish your SWF file, use Test Movie (Control > Test Movie > In Flash Professional) and Test Scene (Control > Test Scene). 
	25. Select File > Close to close the preview window.
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	Figure 8 Stop method in the Actions panel
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	Figure 9 Insert Target Path dialog box
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	Figure 10 Stop method in the Script pane



	Adding frame labels
	Adding frame labels
	You may want to add frame labels to the keyframes. Frame labels help you and other designers remember what is happening in a particular frame.
	To add a frame label:
	To add a frame label:
	1. Add a new layer called 
	labels

	2. Choose Insert > Timeline > Blank Keyframe in this layer to correspond with each of the motion keyframes that drive the animation. 
	A blank keyframe acts as a placeholder for symbols you plan to add later or intend to leave the empty.

	3. Select a blank keyframe in the labels layer. Then in the Property inspector, type the label name in the Name text box 
	(Figure 11)
	The label appears along the Timeline in the frames after the blank keyframe 
	(Figure 12)


	4. Turn off outlining, save the file, and select Control > Test Movie > In Flash Professional.
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	Figure 11 Frame Name text box in Property inspector
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	Figure 12 Frame labels in Timeline



	Further ideas
	Further ideas
	• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and zoom go well with a documentary style narrative.
	• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and zoom go well with a documentary style narrative.
	• For a documentary

	• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if you are looking for the subject of the scene. You might zoom in and out several times during a pan to show you are looking for something.
	• For humor or action

	• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a mountain range leading to the ocean. Because it takes in the majority of the landscape, the effect adds depth and seriousness to the tone of the na
	• For drama



	Camera angles
	Camera angles
	When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the rule of thirds and adjust the viewing angle to emphasize a certain aspect of the subject.
	• The 
	• The 
	rule of thirds

	• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can diminish the importance of a subject as seen from above.

	Even though the girl isn’t in the center of 
	Even though the girl isn’t in the center of 
	Even though the girl isn’t in the center of 
	Figure 13
	Figure 14
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	Figure 13 Rule of thirds
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	Figure 14 Camera angle



	Create cross fades by using classic tweens
	Create cross fades by using classic tweens
	A transitional effect for moving from one image to another is to fade one image out as you fade the other in.
	To create a cross fade:
	To create a cross fade:
	1. Open an existing Flash document or create and save a new Flash document (ActionScript 3.0).
	2. Import two images into separate layers in the current Flash document. (Select File > Import > Import To Stage.)
	3. Convert the two images to be cross-faded into symbols.
	4. Insert keyframes in both layers at the same point in the Timeline to mark the beginning of the fade-out of the first image and the fade-in of the second image.
	5. Decide how long you want the transition to last. Insert keyframes in both layers at the same point in the Timeline to mark the end of the fade-out of the first image and the fade-in of the second image.
	6. Select the first keyframe for the image that will fade out, select the image, and use the Property inspector to set its alpha level to 100% 
	(Figure 15)
	Note: If your images are in the same position on the Stage, you need to hide the top layer before you can select the symbol in the bottom layer. Selecting your images is easier if they are offset on the Stage.
	Note: If your images are in the same position on the Stage, you need to hide the top layer before you can select the symbol in the bottom layer. Selecting your images is easier if they are offset on the Stage.


	7. Select the first keyframe for each image and insert a classic tween.
	8. Select the first keyframe for the image that will fade in and set its alpha level to 0%.
	9. Select the last frame for the image that will fade in and set its alpha level to 100%.
	10. Select the last frame for the image that will fade out and set its alpha level to 0%.
	11. Add a frame label to the first keyframe of each classic tween 
	(Figure 16)
	The labels appear on the Timeline 
	(Figure 17)

	Note: You can make the fade-out start after the fade-in or vice versa. You can also extend the fade-out to end in the same frame as the end of the fade-in.
	Note: You can make the fade-out start after the fade-in or vice versa. You can also extend the fade-out to end in the same frame as the end of the fade-in.

	If the images zoom in or out before the fade-out, you probably want to continue the zooming process during the fade.

	12. Save the movie and select Control > Test Movie > In Flash Professional to test the movie.
	13. Select File > Close to close the preview window.
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	Figure 15 Applying an Alpha level in the Color Effect Style menu
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	Figure 16 Frame label text box
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	Figure 17 Frame labels in Property inspector



	Create a bounce effect by using classic tweens
	Create a bounce effect by using classic tweens
	Some animated text and images that move onto the Stage will seem more lifelike if you add a little bounce to them when they reach their stopping point. This is an old animation technique acknowledging that any moving object carries momentum and thus ...
	To create a bounce effect:
	To create a bounce effect:
	1. Open an existing Flash document or create and save a new Flash document (ActionScript 3.0).
	1. Open an existing Flash document or create and save a new Flash document (ActionScript 3.0).

	2. Begin by adding a symbol to the Stage. 
	By default the symbol is placed in the first keyframe of the timeline.

	3. Select a second frame along the timeline.
	4. Select Insert > Timeline > Keyframe.
	5. Make sure the new frame is still selected and move the symbol to a new position on the Stage.
	6. Click on the tween span on the Timeline and select Insert > Classic Tween. 
	The classic tween appears as light blue with an arrow. 

	7. Label the starting keyframe for the classic tween 
	move right 
	move left
	(Figure 18)
	bounce

	8. Insert a keyframe 3–5 frames after the end of the classic tween. Label this frame 
	back

	9. Insert another keyframe 8–10 frames after the end of the original classic tween. This will be the final resting point of the image. Label this frame end. 
	If you want the final bounce back into place to take longer (more frames) so the object appears to slow down, insert the keyframe in this step farther down the Timeline.

	10. Select the keyframe labeled back.
	11. In this keyframe, select the symbol instance on the Stage and use the arrow keys to move the instance 5–10 keypresses back in the direction it came from.
	12. Create classic tweens between all the keyframes by clicking on each tween span and selecting Insert > Classic Tween.
	13. Add an actions layer to the top of the Timeline.
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	Figure 18 Frame label

	14. On this layer, insert a keyframe after the last frame and add a stop action. In the Actions toolbox on the left side of the panel, choose flash.display > MovieClip > Methods.
	15. Double-click or drag the stop item to the script pane. 
	The code for the stop method appears in the script pane.

	16. In the Script pane, select the stop method. Then click in the Object text box in the parameters area of the Actions panel. 
	The Insert Target Path button is now active.

	17. Click the Insert Target Path button. 
	The Insert Target Path dialog box appears. 

	18. Select the Relative option and select the movie clip you want to play when viewers click the button. If you want the movie in the main timeline to play, select root to set the target path to this.
	19. Click OK to close the Insert Target Path dialog box. 
	The Script pane shows the correct code for stopping the movie 
	(Figure 19)

	The Timeline should appear as it does in 
	Figure 20


	20. Close the Actions panel.
	21. To test how the SWF file works before you publish your SWF file, use Test Movie (Control > Test Movie > In Flash Professional) and Test Scene (Control > Test Scene). 
	22. Select File > Close to close the preview window.
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	Figure 19 Actions panel
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	Figure 20 Final timeline
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