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Overview of Adobe After Effects CS5 workspace
Adobe After Effects CS5 is the industry standard for motion graphics and visual effects. Its 2D and 3D compositing 
tools and huge collection of video effects help you create eye-catching animated text, exciting motion graphics, and 
sophisticated visual effects.

We recommend that you complete the guide titled “Overview of Adobe Premiere Pro CS5 workspace” before doing 
the tasks in this guide. The After Effects workspace has the same look and basic functionality as the Adobe 
Premiere Pro workspace.

The After Effects workspace (Figure 1) behaves the same as the workspace in Adobe Premiere Pro and the other 
Adobe digital video and audio applications. It uses frames and panels that you can adjust and move. You can place 
any number of panels within a single frame, close panels by clicking the X next to their name, and reopen them by 
selecting Window and then selecting the panel name.

After Effects works very closely with Adobe Premiere Pro. You can export an After Effects composition (a 
collection of layers akin to a sequence in Adobe Premiere Pro) as an Adobe Premiere Pro project, and you can 
import Adobe Premiere Pro projects for editing in After Effects. You can also copy and paste layers and assets 
between Adobe Premiere Pro and After Effects.

If you have Adobe Creative Suite 5 Production Premium installed, you can create or import After Effects 
compositions in Adobe Premiere Pro by using Dynamic Link. Dynamic Link allows changes made to a file in either 
application to appear in both, instantaneously, without rendering. To open a new After Effects project from within 
Adobe Premiere Pro, select File > Adobe Dynamic Link > New After Effects Composition. To open an existing 
Adobe Premiere Pro project while in After Effects, select File > Import > Adobe Premiere Pro Project.

There are some limitations: in particular, After Effects can not play Adobe Premiere Pro video transitions (except 
Cross Dissolve) and it does not import titles created with the Adobe Premiere Pro Titler.

Figure 1 Adobe After Effects CS5 workspace
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Animating text

Adding text to an After Effects composition and then animating it is a simple matter. You can animate text just as you 
would in Adobe Premiere Pro, by applying Transform properties (equivalent to using the Adobe Premiere Pro Motion 
or Transform effects), or you can go far beyond that basic level of animation. In After Effects, you can apply 
animations on a per-character or per-word basis, have characters move along a curved path, and have characters 
change to other characters. Animations can include changing colors, 3D motion, blurring, and other effects.

To create text and move it in 3D space:

1. Start After Effects

2. In the main menu, select Composition > New 
Composition.

The Composition Settings dialog box appears (Figure 9).

3. Name the composition Text Motion, and select an 
appropriate video preset.  

4. Click the Background Color swatch to open the Color 
Picker. Give your composition a color other than the 
default black.

5. Accept the other default settings and click OK.

6. In the main menu, select Window > Workspace > Text.

The Character and Paragraph panels appear on the right 
side of the workspace.

7. In the Tools panel, click the Horizontal Type tool 
(Figure 10).

8. Click in the Composition panel and type some text.

9. Make sure the text is selected. In the Character panel, 
change the font choice, size, color, and typeface style 
(bold, italic, all caps, etc.) and add a stroke (Figure 11).

Note: The two overlapping squares in the upper-right 
corner of the Character panel specify the fill and stroke 
colors and whether they’re activated. (Click the small 
box with the red diagonal line to turn off the display of 
whichever color box is in front.) The stroke menu lets 
you select whether the stroke is over or under the fill.

10. In the Tools panel, click the Selection tool (the large 
arrow on the left end) and use it to position the text in the 
Composition panel.

Figure 9 Composition Settings dialog box

Figure 10 Horizontal Type tool in the Tools panel

Figure 11 Character panel

Fill Color

Stroke Color

Stroke menu
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11. In the Timeline panel, display the text layer’s effects by 
clicking the triangle next to the layer name and then 
clicking the triangles next to Transform and Text, as 
shown in (Figure 12).

Note: As mentioned earlier, the After Effects Transform 
effect has, in addition to Opacity, the keyframeable 
options found in the Adobe Premiere Pro Motion effect.

12. Set keyframes for some of the Transform options as 
follows: 

• Move the CTI to the beginning of the composition.

• Click the Time-Vary stopwatch button (equivalent to 
the Toggle Animation button in Adobe Premiere 
Pro) to switch on keyframes for any option 
(Figure 12).

• Select an option value (a keyframe appears in the 
time ruler). Do this for more than one option.

• Move the CTI into the timeline a few seconds.

• Change the option parameters to add more 
keyframes.

13. Drag the CTI to the beginning of the timeline then click 
the Play button in the Preview panel (or drag the CTI in 
the Timeline panel) to see your work.

14. Position the CTI so the text is visible in the Composition 
panel. 

15. In the Timeline panel, click the 3D Layer button (the 
empty box below the 3D cube icon) (Figure 13).

A number of 3D options appear in the Timeline panel: 
Orientation, X/Y/Z Rotation, and Material Options 
(Figure 14).

16. In the Timeline panel, set new properties for the X, Y, and 
Z Rotation properties.

In the Composition panel, the text rotates in 3D 
(Figure 15). 

17. In the Tools panel, select the Rotation tool.

The Set Orientation/Rotation For 3D Layers menu 
appears to the right of the Tools panel (Figure 16).

18. In the Set Orientation/Rotation For 3D Layers menu, 
select Orientation or Rotation.

19. In the Composition panel, drag the Rotation tool on the 
text.

Make note of the changing values in the Timeline panel. 
Any changes you make are keyframeable.

Figure 12 Timeline panel, Transform options

Figure 13 3D Layer button

Figure 14 Timeline panel with 3D options visible

Figure 15 3D axis layer control

Figure 16 Set Orientation/Rotation For 3D Layers 
menu

Time-Vary stopwatch button

3D Layer button
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To place and move text on a curve:

1. Select Composition > New Composition, and name the 
composition Text on a Curve. Select an appropriate 
video preset, accept the other defaults, and click OK

2. In the Tools panel, select the Horizontal Type tool. Click 
anywhere in the Composition panel screen, and type 
some text.

A text layer appears in the Timeline panel.

3. Display the text layer’s effects by clicking the triangle 
next to its name. Further expand the Text and Path 
Options as shown in the example (Figure 18).

4. In the Tools panel, click the Pen tool (to the left of the 
Horizontal Type tool).

5. Create a curved path, using the same techniques you used 
in the Adobe Premiere Pro Titler (Figure 17). 

Make sure the text is still selected before you draw the 
line; otherwise, you will create a shape with a fill. 

A Masks option is added to the text layer in the Timeline 
panel.

6. In the Timeline panel, select Mask 1 from the Path menu 
(Figure 18).

The text drops onto the path in the Composition panel 
(Figure 19). Additional path options appear in the 
Timeline panel (Figure 20). 

7. Drag the CTI to the beginning of the Timeline.

8. Click the First Margin Time-Vary stopwatch to turn on 
keyframes and set a keyframe at the beginning of the 
Timeline.

Figure 17 Composition panel showing curve

Figure 18 Timeline panel Text and Path Options

Figure 19 Text on the curve path

Figure 20 Path Options

Time-Vary stopwatch
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9. Drag the First Margin value to the left (Figure 21). As 
you drag left, the value becomes a negative number and 
the text moves left along the path in the Composition 
panel. Adjust this value so the text begins off the path to 
the left in the Composition panel (Figure 22).

10. Drag the CTI further down the Timeline and add another 
keyframe for the First Margin effect. To add a keyframe, 
click the Add Or Remove Keyframe At Current Time 
button (Figure 23).

11. With the CTI on the second keyframe, drag the First 
Margin value to the right to move the text to the right. 
Adjust this value so the text ends off the path to the right 
in the Composition panel (Figure 24).

12. Move the CTI to the beginning of the Timeline and play 
the composition. 

The text travel along the path from left to right.

Figure 21 Adjusting the First Margin value

Figure 22 First Margin position at the first 
keyframe 

Figure 23 Adjusting the First Margin value 

Figure 24 First Margin position at the second 
keyframe 

Add Or Remove Keyframe At 
Current Time button
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To animate text:

1. Select Composition > New Composition. In the 
Composition Settings dialog box, name the composition 
Text Animation, select an appropriate video preset, 
accept the other defaults, and click OK.

2. In the Tools panel, select the Horizontal Type tool. Click 
anywhere in the Composition panel screen, and type 
some text.

A text layer appears in the Timeline panel.

3. Display the text layer’s effects by clicking the triangle 
next to its name. 

4. In the Animate menu, select Position (Figure 25).

In the Timeline panel, the Text options expand further 
and the Animator 1 options are added (Figure 26).

Figure 25 Animate menu

Figure 26 Animator options

Animate menu
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5. Expand the Animator 1 options, expand the Range 
Selector 1 options, and set Position to 0, 400 (Figure 27).

The text drops below the Composition panel screen.

6. In the Magnification Ratio menu of the Composition 
panel, select 33.3% (Figure 28).

The text bounding box and handles appear at the bottom 
of the Composition panel screen.

7. In the Timeline panel, set keyframes for the Start option: 
0% at the beginning and 100% a few seconds into the 
composition (Figure 29).

The text appears on-screen again.

8. Play this composition. 

The text jumps up from beneath the screen, one letter at a 
time.

9. In the Animator 1 Add menu, select Property > Skew.

Skew and Skew Axis options appear in the Timeline 
panel.

10. Set Skew to 45 and play the composition. 

The letters appear on-screen, skewed to the right, and 
then quickly straighten up as they arrive in place.

11. In the Animator 1 Add menu, select Property > Opacity.

The Opacity option appears in the Timeline panel.

12. Set Opacity to 0% and play the composition. 

The letters start animating at 0% opacity and quickly 
increase to 100% as they arrive in place.

13. In the Animator 1 Add menu, select Selector > Wiggly.

The Wiggly Selector 1 option appears in the Timeline 
panel.

14. Display the Wiggly Selector 1 options.

You can accept the defaults or change the settings. The 
options are plentiful.

15. Play the composition. 

The text has a wild animation (Figure 30).

Figure 27 Range Selector 1 Position option

Figure 28 Composition panel

Figure 29 Range Selector 1 Start keyframes

Figure 30 Text with Wiggly option applied

Magnification Ratio
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To apply per-character animation:

1. Select Composition > New Composition.

2. In the Composition Settings dialog box, name the 
composition Character Animation, select an 
appropriate video preset, accept the other defaults, and 
click OK.

3. In the Tools panel, select the Horizontal Type tool. Click 
anywhere in the Composition panel screen, and type 
enough text to fill the width of the screen.

A text layer appears in the Timeline panel.

4. Expand the text layer’s options. In the Text Animate 
menu of the Timeline panel, select Scale.

An Animator 1 option is added, with Range Selector 1 
and Scale displayed (Figure 31).

5. Set both Scale values to 300%.

6. In the Animator 1 Add menu, select Property > Tracking, 
and set Tracking Amount to 30 (Figure 32).

Note: This keeps the text from getting too tightly spaced.

7. Expand the Range Selector 1 options and set the 
following (Figure 33):

• In the Advanced options Units menu, select Index.

• Set Start to 0.

• Set End to 3 (to animate 3 characters at a time).

• Click the Offset option Time-Vary stopwatch button 
(Figure 33) and set two keyframes:

◦ At the beginning of the composition: –3

◦ A few seconds into the composition, with Offset 
set to the number of characters and spaces in 
your text phrase

Note: With a starting Offset value of –3, the animation 
starts three characters before the first character. If you 
had chosen a value of 0, the first three characters would 
initially display at 300% of their normal size. By 
selecting –3, the 300% value is applied to three virtual 
characters at the outset. The actual first three characters 
of your text string are treated as the 4th through 6th 
characters of this animation, so they initially display at 
their regular size.

8. In the Timeline panel, click the text layer name (whatever 
you typed in the Composition panel) to select that layer.

Note: This ensures that the next Animate menu selection 
creates a separate Animator option.

Figure 31 Timeline panel Animator options

Figure 32 Tracking Amount value set to 30

Figure 33 Timeline panel Range Selector options

Offset option Time-Vary 
stopwatch button
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9. In the Text Animate menu, select Fill Color > RGB.

An Animator 2 option is added, with Range Selector 1 
and Fill Color displayed (Figure 34).

Note: The Fill Color default color is Red. You can 
change that and use keyframes to animate color changes 
over time. In this case, let the Wiggly function change the 
intensity of a single color.

10. In the Animator 2 Add menu, select Selector > Wiggly.

11. Play the composition and note how the red color shifts as 
the characters animate (Figure 35).

Figure 34 Fill Color option 

Figure 35 Per-character animation

Using text animation presets

Many other types of text animation are available in After Effects. You can animate text outlines and text interiors with 
scribbles, wiggles, multiple colors, and such. Letters can bounce, move through 3D space, twist, bend, curl, flip, 
invert, change colors and opacities, and even change randomly to different characters or to preselected words. Test 
the many parameters available within the Add and Animate menus built into any text layer in the Timeline panel and 
refer to After Effects Help for more information.

One quick way to get an idea of the possibilities is to use a preset. After Effects has hundreds of text animation 
presets, including 3D text animation.

To use a text animation preset:

1. Select Composition > New Composition. In the 
Composition Settings dialog box, name the composition 
Text Animation Presets, select an appropriate video 
preset, accept the other defaults, and click OK.

2. Select Window > Workspace > Effects.

3. In the Tools panel, select the Horizontal Type tool, click 
anywhere in the Composition panel screen, and type at 
least two words.

4. In the Effects & Presets panel, expand Animation Presets, 
and open the Text bin (folder).

There are more than a dozen text-animation preset bins 
(Figure 36).

5. In the Animate In bin, drag Center Spiral to the text in the 
Composition panel screen.

Two option sets are added to the text layer in the 
Timeline panel. These are Animator layers that have been 
renamed as a convenience. Spiral applies rotation 
keyframes and Fade In adds opacity keyframes. 

Expand the text layer’s options to see these (Figure 37).

Figure 36 Effects & Presets panel Text presets

Figure 37 Timeline panel with Spiral and Fade In 
options
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6. Press the spacebar to play the animation.

Mid-animation, the text should look something like the 
example (Figure 38).

7. Select Edit > Undo to undo the preset.

Note: You may need to select Edit > Undo more than one 
time.

8. In the Effects & Presets panel, click the 3D Text bin (the 
first Text Animation Preset bin) to expand it, and drag 3D 
Rain Down Words & Colors to the text in the 
Composition panel screen.

Three option sets are added to the text layer in the 
Timeline ruler: More Options, Animator 1, and Animator 
2.

9. Play that animation. 

The text flips onto the screen, one word at a time.

10. In the Timeline panel, display the Animator 1 options, 
display the Range Selector 1 options, and display the 
Advanced options (Figure 39).

11. In the Advanced options Based On menu, select 
Characters.

12. Play the animation. 

This time the text flies on-screen one character at a time 
(Figure 40).

Trying out text animation presets is guaranteed to keep 
you busy for a long time. When you add a preset, take a 
look at the Timeline panel and note that each preset adds 
options and keyframes. You can customize presets by 
changing the option values and keyframe locations.

Figure 38 Center Spiral text animation preset

Figure 39 Timeline panel Animator options

Figure 40 3D Rain Down Words & Colors 
animation preset with Characters setting
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Using paint tools

After Effects has a set of Adobe Photoshop CS5-style paint tools. You can use them to create some wild, animated art 
or to add animation or images to video in rotoscope style.

Working with paint tools is slightly different from working with text tools. When you create text, you automatically 
create a new layer in the Timeline panel and you work directly in the Composition panel. With paint tools, you create 
a composition layer and work on that layer in the Layer panel.

To use the paint tools:

1. In the main menu, select Composition > New 
Composition.

2. In the Composition Settings dialog box, name the 
composition Paint Tools, select an appropriate video 
preset, accept the other defaults, and click OK.

3. In the main menu, select Layer > New > Solid.

The Solid Settings dialog box appears (Figure 41).

4. Select a color and click OK to close the Solid Settings 
dialog box.

5. Double-click the solid layer in the Timeline panel.

The Layer panel appears, with the solid color layer 
displayed in it (Figure 42).

Figure 41 Solid Settings dialog box

Figure 42 Layer panel
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6. In the main menu, select Window > Workspace > Paint.

The Paint and Brushes panels appear.

7. In the Tools panel, select the Brush tool (Figure 43).

The options in the Paint and Brushes panels become 
active and accessible.

8. In the Brushes panel, select a brush (Figure 44).

You can change the tip diameter, put it at an angle, 
change its roundness (turn it into an oval), alter its 
hardness (more or less diffusion around its perimeter), 
and select and update spacing.

Note: Spacing is the distance between the brush marks in 
a stroke, measured as a percentage of the brush diameter. 
When this option is deselected, the speed at which you 
drag to create the brush stroke determines the spacing. 

Note: Brush Dynamics determines how brush marks are 
controlled by the features of a pressure-sensitive 
digitizing tablet, such as a Wacom pen tablet.

9. In the Paint panel, select a color and paint a single line on 
the solid layer in the Layer panel.

10. Change the color and continue until you’ve created a 
graphic that has several lines and several colors 
(Figure 45).

11. In the Timeline panel, display the solid color layer 
options, display Effects, and display Paint.

Each brush stroke appears in its own layer (Figure 46).

12. Drag each brush stroke a different distance to the right to 
create a stair-step effect, so the strokes appear on-screen 
in the order you drew them (from the bottom of the list to 
the top) (Figure 47).

13. In the Timeline panel, display the Brush 1 Stroke options.

14. Set keyframes for the End option:

• 0% at the beginning of the time ruler

• 100% at about 2 seconds

15. Play the composition and view it in the Composition 
panel.

The first paint stroke animates just as you drew it. You 
can apply the same animation to the remaining strokes by 
repeating steps 13 and 14 for each of the brush strokes.

Note: To paint on a video clip, drag the clip into the 
Timeline, double-click to open it in the Layer panel, and 
paint directly on the video clip.

Figure 43 Brush tool

Figure 44 Brushes panel

Figure 45 Paint example

Figure 46 Timeline panel brush strokes

Figure 47 Brush strokes timed to appear at 
different times in the Timeline
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Applying effects

After Effects has more than 200 effects you can use to correct and enhance your footage. Additional effects are 
available from third-party developers. Here are a few effects that come with After Effects:

• Cartooning: Makes a video clip or image appear as if has been painted or drawn in the manner of a cartoon. 

• Lens Blur: Simulates a narrower depth of field by blurring some objects in an image while leaving others in 
focus.

• Fractal: Renders one of two types of fractal images that add a colorful texture to your clips.

• Turbulent Displace: Uses fractal noise to create distortions.

• Warp: Transforms layers into geometric shapes, arcs, waves, and fish-eye lens views.

• Liquify: Has 10 brush-based tools for distorting footage.

• Vegas: Generates running lights and other path-based pulse animations around an object.

Working with effects in After Effects is a lot like working with effects in Adobe Premiere Pro. As you apply effects to 
a layer, they show up in the Effect Controls panel and in the Timeline panel. You can apply changes or keyframes in 
either panel. To complete this task, you need one brief video clip.
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To apply effects:

1. Select Composition > New Composition. In the 
Composition Settings dialog box, name the composition 
Video Effects, select an appropriate video preset, accept 
the other defaults, and click OK.

Note: If the video clip you intend to use is longer than 30 
seconds, you need to change the composition length in 
the Composition Settings dialog box from its default 30-
second value. Any change you make in the Composition 
Settings dialog box becomes the new default setting.

2. Select Window > Workspace > Effects.

The Effect Controls, Composition, and Effects & Presets 
panels appear.

3. Select File > Import > File.

The Import File dialog box appears.

4. Select a video file you want to apply effects to, and click 
Open.

The video file appears in the Project panel.

5. Drag the video clip to the Video Effects composition in 
the Timeline panel.

The clip appears as a layer and appears in the 
Composition panel.

6. Position the CTI somewhere in the video clip in the 
Timeline panel.

The video clip appears in the Composition panel.

7. In the Effects & Presets panel, display the Distort bin, 
and drag Warp to the Composition panel.

A box with two diagonal lines appears in the 
Composition panel (Figure 48). Then the effect appears 
in the Effect Controls panel (Figure 49).

8. In the Warp Style menu in the Effect Controls panel Warp 
effect options area, select any number of styles (one at a 
time), including Wave, Flag, Arc, and Twist. 

The video changes in the Composition panel (Figure 50).

Figure 48 Composition panel with effect being 
applied

Figure 49 Effect Controls panel Warp effect

Figure 50 Warp effect with Twist option applied
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9. In the Effect Controls panel, select Warp and press 
Delete.

10. In the Effects & Presets panel Distort bin, drag Liquify to 
the video clip in the Timeline panel.

Note: This is another way to add an effect to a clip.

The effect appears in the Effect Controls panel. 

11. In the Effect Controls panel Liquify options area, display 
View Options and select View Mesh (Figure 51).

A mesh appears on the clip in the Composition panel 
(Figure 52).

12. In the Effect Controls panel, click a tool such as Twirl. 
Note that the options below the tool icons change for the 
selected tool. Drag the tool in the Composition panel 
(Figure 53).

Note: The longer you hold a tool in one place in the 
Composition panel, the greater the change in that 
location.

13. In the Timeline panel, click the triangle next to the clip 
name to display its options: Effects, Transform, and 
Audio (if the clip has audio).

14. Display the Effects options and display the Liquify 
options.

They are the same options available in the Effect 
Controls panel.

Note: You need to click a Liquify tool icon in the Effect 
Controls panel to have its name appear in the tool options 
menu in the Timeline panel.

15. In the Effect Controls panel or the Timeline panel, click 
the Liquify Effect switch to turn it off (Figure 51).

Figure 51 Effect Controls panel Liquify effect

Figure 52 Liquify effect with View Mesh selected

Figure 53 Liquify effect with Twirl applied 

Effect switch
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16. In the Effects & Presets panel, display the Animation 
Presets bin, display the Image-Creative bin, and drag 
Colorize-Gold Dip to the Effect Controls panel.

The effect appears in the Effect Controls panel and 
applies the color change to the clip in the Composition 
panel (Figure 54).

Note: This effect is actually the Solid Composite effect 
with an animation preset built in. This is how most 
presets work. They are regular After Effect video effects 
with preset values. Their purpose is to make it easy for 
you to find an effect that does what you want without 
having to adjust too many options.

17. View the Solid Composite effect options area of the 
Effect Controls panel. Open the Animation Presets menu, 
and select any number of presets (one at a time) to see 
what’s available in addition to Colorize-Gold Dip.

18. Delete the Solid Composite effect.

19. In the Effects & Presets panel, expand the Animation 
Presets bin, expand the Image-Special Effects bin, and 
drag Bad TV 2-Old to the Effect Controls panel.

Note: This preset combines five effects: Wave Warp, Box 
Blur, Color Balance (HLS), Noise, and Venetian Blinds. 
Because some of these effects have built-in animations, 
you don’t need to set any keyframes to create the waves 
and moving static shown in the example (Figure 55). 
Presets can save you a lot of time.

Continue trying effects. The creative possibilities are 
endless.

Figure 54 Colorize-Gold Dip effect animation 
preset

Figure 55 Bad TV 2-Old effect animation 
preset

Putting effects in motion with Motion Tracker

With the After Effects Motion Tracker, you can accurately, quickly, and painlessly track any number of moving 
objects and then link effects directly to those objects.

You can track something you want to touch up and then apply that touch-up effect to the motion track (a collection of 
keyframes) to save a lot of time. You can highlight action, such as someone skiing, by having a transparent color 
matte match the skier’s every move. Follow a golf swing, leaving an arc that shows the swing’s characteristics. Apply 
a blur over someone’s face to protect his identity. Or, in this coming example, add a lens flare to a DJ’s hand 
movements.

In Adobe Premiere Pro, you used a traveling matte to follow action. Depending on the motion, that required manually 
setting multiple keyframes. Motion Tracker does most of that work automatically.

To complete this task you need a brief video clip with some action. For our example, we used a DJ, had Motion 
Tracker follow the action of his forearm over the turntable, and then applied a lens flare to that motion track.
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To use Motion Tracker:

1. In the main menu, select Composition > New 
Composition.

2. In the Composition Settings dialog box, name the 
composition Motion Tracker, select an appropriate 
video preset, accept the other defaults, and click OK.

3. Select Window > Workspace and select Effects.

The Effect Controls, Composition, and Effects & Presets 
panels appear.

4. Select File > Import > File.

The Import File dialog box appears.

5. Select the video file you want to use in this task and click 
Open.

The video file appears in the Project panel.

6. Drag the video clip to the Motion Tracker composition in 
the Timeline panel.

The clip appears as a layer.

7. Click the clip layer to display it in the Composition panel. 

Make sure the CTI is over the clip in the Timeline panel 
and the clip is showing in the Composition panel.

8. In the Effects & Presets panel, display the Generate bin, 
and drag Lens Flare to the Composition panel.

A lens flare appears in the Composition panel 
(Figure 56).

9. In the main menu, select Animation > Track Motion.

The Tracker Controls panel appears (Figure 57), the 
Layer panel appears, and a Track Point pointer appears in 
the Layer panel (Figure 58).

Note: The Track Point pointer has several features. 
Briefly, it consists of a search region (outer box), feature 
region (inner box), and attach point (plus sign). After 
Effects Help explains how to adjust these features. For 
this exercise, click in the search region to retain the Track 
Point pointer’s shape and size.

10. In the Tracker Controls panel, make sure the following 
default values are set:

• Motion Source: Your video clip

• Current Track: Tracker 1

• Track Type: Transform

• Position option: Selected

Figure 56 Composition panel, clip with Lens Flare 
applied

Figure 57 Tracker Controls panel

Figure 58 Track Point pointer

Analyze 
Forward 
button
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11. Click Edit Target.

The Motion Target dialog box appears (Figure 59).

12. Make sure the Effect Point Control is set to Lens Flare/
Flare Center and click OK.

Note: If you had more than one object or effect to choose 
from, there would have been additional Effect Point 
Control selections.

13. In the Layer panel, click in the search region of the Track 
Point 1 pointer (the outer box) and drag the pointer to the 
object you want to track.

The image in the feature region magnifies 400% to help 
you define the area to be tracked. We chose the DJ’s 
forearm because the highlight on it is easier for Motion 
Tracker to follow than a dark, nondescript area 
(Figure 60).

14. Check that the CTI is at the beginning of the video.

15. In the Tracker Controls panel, click the Analyze Forward 
button (Figure 57).

The video plays and the Track Point 1 pointer follows the 
target you selected.

Note: If the Track Point pointer slips off the target, here’s 
how you can remedy that:

• In the Timeline panel, move the CTI to the location 
in the clip slightly before the point where the Track 
Point pointer slipped off-target.

• In the Timeline panel, display the clip options.

• Marquee-select the keyframes after the CTI and 
press Delete.

• In the Composition panel, drag the Track Point 
pointer to the proper location.

• In the Tracker Controls panel, click Analyze 
Forward.

16. In the Tracker Controls panel, click Apply.

The Motion Tracker Apply Options dialog box appears 
(Figure 61).

17. Make note of the default Apply Dimensions setting of X 
and Y, and click OK.

In the Timeline panel, the motion track Attach Point 
position keyframes are copied and then pasted in the 
Lens Flare, Flare Center layer (Figure 62).

18. Play the Timeline and watch the Lens Flare follow the 
object on-screen (Figure 63).

Figure 59 Motion Target dialog box

Figure 60 Track Point pointer feature region

Figure 61 Motion Tracker Apply Options dialog 
box

Figure 62 Timeline panel Motion Tracker options

Figure 63 Lens Flare on a Motion Tracker path
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How to rotoscope in After Effects
Rotoscoping is an animation technique in which you draw, paint, or add other visual effects in a layer over live-action 
film or video, one frame at a time. The technique was invented by Max Fleischer in 1914, when he projected motion 
film images onto a frosted glass panel. He traced the images on the glass, one frame at a time, creating realistic 
animation. His original equipment was called the rotoscope. Modern rotoscoping has been replaced by special 
computers and software such as Adobe After Effects CS5, but the name “rotoscoping” remains. 

If you’ve been to the movies or watch television, you’ve probably seen the results of rotoscoping. For example, an 
object or character appears in color when everything else is black and white (Figure 1). Anytime it looks like 
someone has drawn or painted over the movie, frame-by-frame, you are probably looking at the result of rotoscoping.

Figure 1  Rotoscoping before and after

These days, rotoscoping refers to the technique of creating a matte for a moving element on one layer so that it can be 
composited over another background layer. As you can imagine, creating this matte in every frame of a movie is a 
laborious process, but necessary if you don’t have a good key or haven’t shot footage in which the foreground is 
easily separated from the background. 

The Roto Brush tool in After Effects makes this process a lot more efficient by helping you select and mask each 
frame in less time and with greater accuracy.

We recommend that you complete the guide titled “How to apply and adjust keying effects” before doing the tasks in 
this guide. Keying and rotoscoping are not the same process, but understanding keying will help you understand what 
you hope to accomplish by rotoscoping. 

It’s easy to confuse rotoscoping with keying effects. With keying, you have shot your footage with a foreground and 
background that you can easily separate and replace. For example, you may have shot your subjects in front of a blue 
or green screen. Rotoscoping allows you to work with your existing footage that was shot in its natural environment. 

To complete the tasks in this guide, you will need to import one short video clip (just a few seconds) with some 
motion. The best sort of video clip has at least one moving object in the foreground that you would like to isolate 
from the rest of the scene.
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Adding the background and foreground layers

In this task, you will place the same movie clip in the foreground and background layers so  you can isolate and apply 
special effects to a portion of the image while preserving the overall image in the background.  

To add the foreground and background layers:

1. Start After Effects.

2. In the main menu, select Composition > New 
Composition.

The Composition Settings dialog box appears (Figure 2).

3. Name the composition Rotoscoping, select an 
appropriate video preset, and click OK.

4. In the main menu, select Window > Workspace > Motion 
Tracking.

5. Choose File > Import > File. Browse to locate your 
motion video clip, select it, and click Open.

The video file appears in the Project panel.

6. Drag the video clip to the Rotoscoping composition in 
the Timeline panel.

This copy of the clip will be the foreground.

7. Drag a second copy of the video clip to the Rotoscoping 
composition in the Timeline panel.

This copy of the clip will be the background. There are 
now two copies of the same video in the Rotoscoping 
composition Timeline (Figure 3).

Figure 2  Composition Settings dialog box

Figure 3  Rotoscoping composition 
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Creating a matte by rotoscoping

You need to create a matte (or more specifically, a series of mattes in each frame) so you can isolate and apply special 
effects to a portion of the image without affecting its surroundings. You can do this by using the Pen tool to carefully 
select objects in every frame. But it’s a lot faster to use the Roto Brush tool.   

To create a matte by rotoscoping:

1. Double-click the video clip in the top layer of the 
Rotoscoping composition Timeline.

The video opens in the Layer panel (Figure 4).

2. Click the First Frame button in the Preview panel to 
move the current time indicator (CTI) to the first frame of 
the selected video clip (Figure 5).

You need to rotoscope every frame in the video, so you’ll 
start on frame 1.

3. Choose View > Resolution > Full.

Work with the Roto Brush in full resolution for more 
accurate selection.

4. Select the Roto Brush tool in the Tools panel (Figure 6).

With the Roto Brush tool selected, the pointer changes to 
a green circle with a plus sign. 

Figure 4  Layer panel

Figure 5  Preview panel

Figure 6  Roto Brush tool

First 
Frame

Previous 
Frame

Play/Pause

Next Frame

Last
Frame
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5. In the Layer panel, drag over an object you want to 
isolate in the foreground (Figure 7).

The Roto Brush paints in green, and After Effects selects 
an area. It’s trying to guess which part of the frame you 
want selected (Figure 8). The alpha boundary for the 
matte is defined by a bright colored line (pink by default).  

6. Drag over another part of the object to add to the 
selection.

More of the object is selected. Sooner or later, you’ll end 
up selecting parts of the image that belong in the 
background (Figure 9). 

You can remove from the selection by holding down Alt 
(Windows) or Option (Mac OS) as you draw with the 
Roto Brush. When you remove from the selection, the 
Roto Brush changes to a red circle with a minus sign and 
paints in red (Figure 10).

Note: To paint small regions, you can click the Roto 
Brush instead of dragging it.

Figure 7  Add to a selection with the Roto Brush

Figure 8  Roto Brush selection

Figure 9  Add to the Roto Brush selection

Figure 10  Remove from Roto Brush selection

Unintended selection area
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7. Continue to draw with the Roto Brush, adding and 
subtracting from the selection, until you’ve isolated the 
objects you want to separate from the rest of the image 
(Figure 11).

Figure 11  Roto Brush selection in Alpha 
Boundary view mode

Refining a Roto Brush selection

Before you move to the next frame and continue rotoscoping, you can refine your selection by using the options in the 
Effect Controls panel.   

To refine a Roto Brush selection:

1. In the Layer panel, click the Toggle Alpha Boundary 
button (Figure 12).

Turning off Alpha Boundary view mode helps you see 
the boundary of the matte (Figure 13). Based on what 
you see, you may need to add to or remove from the 
selection.  

Figure 12  Layer panel 

Figure 13  Alpha Boundary view turned off

Toggle Alpha 
button

Toggle Alpha 
Boundary button

Toggle Alpha 
Overlay button
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2. In the Layer panel, click the Toggle Alpha button 
(Figure 12).

This view shows a cutout of the selection area. By 
removing the video, you can see the edges of the 
selection better (Figure 14).  

3. In the Layer panel, click the Toggle Alpha Overlay 
button (Figure 12).

Now you see an overlay of everything inside and outside 
the selection area, but the area outside the selection is 
tinted. This is the Alpha Overlay view mode (Figure 15).

Toggling between views help you see the result of your 
choices as you refine the selection. 

4. In the Effect Controls panel, expand the Roto Brush 
effect properties and expand the Matte options 
(Figure 16).

Note: The Propagation settings control how After Effects 
applies the matte forward in other frames of the video. 
You can use the Matte settings to refine the matte you’ve 
created with the Roto Brush tool.

5. Adjust the Smooth, Feather, and Choke values to see how 
they affect the edges of the matte.

You can go back to the default settings at any time by 
clicking Reset.

6. Select Refine Matte (Figure 16) to enable additional 
matte adjustment options.  

Note: Depending on which alpha view you have selected, 
a warning message may tell you to turn off Alpha 
Overlay or Alpha Boundary views.

7. Click Reset in the Effect Controls panel to go return to 
the default Roto Brush settings.

Figure 14  Viewing the matte 

Figure 15  Alpha Overlay view mode

Figure 16  Roto Brush selection

Refine Matte
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Modifying the matte in other frames 

You just defined a selection for a matte in the first frame of your video. You’ll need to create a similar matte in every 
frame in the video clip, but the Roto Brush tool is going to save you a lot of time doing this.    

To modify the matte in other frames:

1. In the Preview panel, click the Next Frame button 
(Figure 5).

As you move forward in the clip, the objects move 
beyond the outline of the matte you created for frame 1. 
After Affects attempts to adjust the selection 
automatically (Figure 17). You’ll still need to use the 
Roto Brush to add to or remove from the selection in 
each frame.

2. Select the Roto Brush tool and refine the selection to 
compensate for the movement in the video.

Note: The amount of change to the selection depends on 
the movement of the objects you are attempting to matte. 

3. Using the Preview panel, advance to the next frame and 
modify the selection. Continue modifying the matte for 
each frame until you have reached the end of the video 
clip. Save your work often.

Note: Rotoscoping is a time-consuming process, but the 
Roto Brush tool is a huge time saver compared to 
drawing selections in each frame by using the Pen tool.

Figure 17  Toggle Alpha Boundary in frame 2 

Selection needs adjustment
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Applying effects after rotoscoping 

When you’re finished rotoscoping the entire clip, you can apply video effects to it. Your effects will apply only to the 
selected objects. Everything outside the selection is transparent. Since you’ve placed a copy of the original clip 
behind it, you create the illusion of an effect that moves with the selected objects. 

You can also place the rotoscoped clip over other background videos to transport the selected objects into the new 
scene. 

Another option is to reverse the matte in the rotoscoped clip. Then, when you add effects, they apply to the 
transparent portion of the clip, thereby changing the appearance of the background clip. 

To apply effects after rotoscoping:

1. Choose Window > Workspace > Effects.

2. In the Effects & Presets panel, expand the Color 
Correction bin.

3. Drag the Back & White effect and drop it onto the video 
in the Composition panel.

The effect applies only to the objects you selected by 
rotoscoping. The reset of the clip is transparent and the 
background image shows through (Figure 18). 

Note: You can adjust the Black & White effect properties 
in the Effect Controls panel to increase or decrease the 
effect.

4. In the Effect Controls panel, select Invert Foreground/
Background in the Roto Brush effect options 
(Figure 19). 

The effect applies to the transparent (background) portion 
of the rotoscoped clip, so whatever is directly behind the 
clip appears to have the effect applied to it. In this 
example the background appears black and white, but the 
foreground character is in color (Figure 20).

5. Move the CTI to the beginning of the clip and click the 
Play button in the Preview window to preview the effect 
in motion. 

6. In the Effect Controls panel, select and delete the Black 
& White effect. Then add other effects from the Effects 
panel to see how they look.

Figure 18  Effect applied to the rotoscoped video 

Figure 19  Roto Brush effect options

Figure 20  Inverting the rotoscope 
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